Cannot clear/set breakpoints with J-Link

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Cannot clear/set breakpoints with J-Link

    I have been using my J-Link for ARM and IAR Workbench IDE ver. 6.50.1 for about 6 months now.
    Occasionally, I try setting too many breakpoints, and get the "J-Link V4.56b Out of breakpoints" dialog asking me to upgrade my license to unlimited flash breakpoints.
    I have always dismissed this dialog clicking on "No".
    Yesterday, this dialog appeared, I again clicked "no" and proceeded to delete all my breakpoints from the IAR breakpoint window, then, set the new breakpoint I want.
    Well, now I am unable to set any breakpoints when running the debugger.
    If I quit the debugger, It seems I can set a breakpoint, but when I then start the debugger again I get the
    "J-Link V4.56b Out of breakpoints" dialog listing 6 breakpoints that shouldn't be set and disabling the one I tried to set.

    If I leave the "J-Link V4.56b Out of breakpoints" dialog, open and start the
    "J-Link V4.56b - Control panel" it also shows these breakpoints in the "Code (managed by emulator)" section of the Breakpoints Tab - Note: I can't clear a breakpoint form the control panel by right clicking, since, the clear option is grayed out. Furthermore, if I then dismiss the "J-Link V4.56b Out of breakpoints" dialog, and reopen the
    "J-Link V4.56b - Control panel's Breakpoints tab, there are no set breakpoints shown.

    I have tried rebooting and power cycling PC, J-Link, Target without any luck. Before I go on to re-installing, is there a way to fix this problem?

    Thanks,

    Steve
  • Hi Steve,

    What device are you working with (Manfucaturer + Device name)?
    Sounds a bit like your settings in IAR EWARM are messed up.
    Could you please rename "settings" folder in your project folder to settings_ or something like that and then re-start the debug session?
    Just to check if this fixes the messed up settings.


    Best regards
    Alex