Support for Intel HR28F640W18UD1?

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Support for Intel HR28F640W18UD1?

    Does J-Flash ARM support or will it support the Intel HR28F640W18UD1 flash chip? I'm using a SEGGER Flasher with J-Flash ARM V3.82. It's correctly identifying our processor but won't automatically detect the flash chip. I've tried manually selecting the flash device to be the 28F640W18T--an older chip but one with the same sector geometries--but no luck.

    I can connect to the target, but when I try to program or erase the chip, I get "Could not erase Sector @ 0x30000000 - Block Lock-Bit Detected". (Show CFI info... also fails though the flash chip is a CFI device.)

    The target device is known good and can be programmed via JTAG from Rowley CrossWorks for ARM via their CrossConnect Lite.

    Any insight or ideas would be greatly appreciated.

    Emilio
  • Hello Emilio,

    J-Flash support any CFI compliant Flash device.
    You probably need a project file, which enables the Bus interface and whatever else may
    be required to access the flash.
    In general, if it does not identify the flash chip, then you will be unable to program it.

    You create the project file yourself. Simply add the steps that are required to access the Flash to
    the init sequence. It may also help if you look at an example project for the same processor.

    Which processor are you using ?

    Rolf
  • Hello Emilio,

    that makes it a little clearer.
    We do not (yet) have a project file for this device, but we can help you to create one.
    The only relevant part is really the Setup part.
    This needs to be basically the same as in the setup code of your project.
    The PLL / and clock settings are one thing, but the important thing is
    a RESET and then setup of the static memory controller in order to allow
    write access to the flash.

    Does this sound doable ?
  • Hi Rolf.

    Thanks so much for your helpful information.

    We've made some progress. Now that I've got the PLL and static memory controller set up, I'm able to fetch the CFI info, which is correct, and am able to do some programming of small images. That's good.

    We're still struggling with the "Block Lock-Bit Detected" message and also failures when programming larger images. I'll be working with a colleague here to try to work through these. If we're without luck, I'll post again with all the details.

    Regards,
    Emilio