[SOLVED]'start application' in Stand Alone mode

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED]'start application' in Stand Alone mode

    Flasher ARM: Stand alone mode does not execute 'start application' after programmingI configured 'Actions performed by "Auto" ' ticking Erase, Program, Start application in the Project settings window (Production tab). I start this with F7 in the JFlash environment and it works fine. The application starts after erasing and programming. After this, I downloaded the configuration to the Flasher. No error so far.

    I start the stand alone programming by pressing the start button on the Flasher. The erasing and programming work fine but the application do not start after the programming finished.

    What must I do to start up the target automatically after programming in stand alone mode?

    Thank you.
  • Hi,

    Could you please give us some information about your setup?
    • Which device (manufacturer + device name) do you use?
    • What SW version do you use?
    Please note that the Flasher firmware that comes with SW V4.42 or later must be used in order to guarantee proper function of the start application command in stand alone mode. Please also note that the reset pin (nRESET) of the CPU also needs to be connected to the JTAG/SWD connector so the Flasher can toggle this pin.

    Best regards,
    Erik