Search Results

Search results 1-20 of 32.

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Hello, Thanks for your reply. I am not sure if I understood your procedure correctly, but it sounded like you are checking the J-Flash log file to check if the programming has succeeded or not. We recommend to check the return value of J-Flash for that. More information as well as a sample batch script can be found on the SEGGER Wiki: wiki.segger.com/UM08003_JFlash#Command_line_options wiki.segger.com/UM08003_JFlash#Batch_processing Could you maybe provide some more information on your setup? Co…

  • Hello, we have successfully determined the root cause for this. With the version V6.82 of J-Flash, a bug was introduced unintentionally, causing the command line options "-savedat" and -"-savecfg" to no longer work correctly. We have fixed the behavior of J-Flash internally already. Thank you very much for reporting this issue. A version which contains the fix is planned to be released later this week. Sorry for any inconveniences caused by this.

  • Hello, You can find more information on how to use SystemView's UART recorder on the SEGGER Wiki: wiki.segger.com/Use_SystemView_UART_Recorder The above article includes a sample Embedded Studio project. Quote from phryniszak: “Is "hello" message also required as in IP example? ” Yes, SystemView expects a "Hello" message from the target when using the UART recorder.

  • Hello, The 'Select' and 'Copy' feature of the J-Link RTT Viewer has been fixed with the most recent version of the J-Link software package. You can download the most recent version of the J-Link software package here: segger.com/downloads/jlink/#J-…twareAndDocumentationPack

  • Hello, @whazin Could you please give the most recent version of the J-Link RTT Viewer (V6.51e) a try and tell me if the problem still occurs for you? @Barak14 For text formatting, the RTT Viewer is made to work with the RTT_CTRL defines as they are defined in the SEGGER_RTT.h. Similarly, we suggest to use the RTT_CTRL_CLEAR define when clearing the terminal. Do you have a source/ examples for terminal applications using ANSI CSI SGR parameter 39 for clearing the screen?

  • Hello, Currently, the 'Select' and 'Copy' feature of the J-Link RTT Viewer are not working as intended. We are working on a fix for this right now.

  • Hello, The J-Link RTT Viewer does not support character encodings other than ASCII. Currently, there are no plans to support other character encodings. You may create your own application which interprets RTT data to suit your own needs. This can be done by using a) the TELNET channel of the J-Link software, for more information please refer to wiki.segger.com/RTT#TELNET_channel_of_J-Link_software or b) the J-Link SDK, for more information please refer to segger.com/products/debug-prob…nk/techno…

  • Hello, We found the issue that caused RTTClient to fail when connecting to a running J-Link debug session. We have fixed this internally already. A release version of the J-Link software package that contains this fix is planned for Friday this week (19th July). Thank you very much for your patience and for reporting this issue.

  • Hello, We are aware that the current version of the J-Link RTT Client is not working correctly on Ubuntu. We are working on a fix for this as of right now. I will get back to you as soon as I know when a fix for this will go live. Sorry for any inconveniences caused by this.

  • Hello, Quote: “when i connected my j-link after upgrading to 6.46 the fw was updated too, could have defected it maybe ? ” No, I do not think so. If you can't see logs (I assume you are talking about RTT output) in any of our software, this may have several reasons. In order to investigate this behavior, could you please answer the following questions? 1) Did you make sure that your target is running an application that makes use of RTT? For example, using SEGGER_RTT_printf(..)? 2) Are you using…

  • Hello Jacob, You are right, that behavior is not intentional and it has been fixed already. It was caused by the different behavior, depending on where the application was executed from. This will be fixed with the next release of the J-Link software package. Stay up-to-date regarding J-Link: segger.com/notification/subscribe.php?prodid=7,94

  • Hello Jacob, Could you please tell me how you start the J-Link RTT Viewer? I was able to reproduce the error you describe when executing the J-Link RTT Viewer from a directory which is different from the directory that the J-Link RTT Viewer resides in. Have you tried executing the J-Link RTT Viewer from its directory? For example by calling cd [...]/JLink_Linux_V646g_x86_64/ ./JLinkRTTViewerExe

  • Hello, Thank you for your inquiry. We are sorry to hear you are having issues with one of our products. Are you referring to the [...] button for "Specify Target Device" (Please see the attached screenshot for reference)? I just tried this on ubuntu 16.04 and the device selection dialog worked as expected. Same goes for ubuntu 18.04. Could you please tell me if you do anything else before clicking the [...] button, or do you just open RTTViewer and click the button immedieately?

  • Hello maximevince, Sorry to hear that you are facing issues with our software. Could you please tell me which application exactly you are referring to? You are mentioning JLinkExe (J-Link commander) as well as RTTClient. The thread you linked to refers to the RTTViewer. Additionally, could you please tell me what you are doing with that application (e.g. what do you do to see the "slow" behavior?). Thank you very much in advance and sorry for any inconveniences caused by this.

  • Hello Joe, Thank you for your inquiry and for reporting this issue to us. Your command line is correct. A bug was introduced with the most recent version (V6.46d) that causes --autoconnect to crash the RTTViewer. This bug has already been fixed internally. The fix will be part of the next release of the J-Link software package, which is planned for Friday this week (14th June 2019). We are sorry for any inconveniences caused by this. If you are interested in a preliminary version of the J-Link R…

  • Hello kjhuebner, Thanks for your reply. It's great to hear that you are up and running now. Thank you very much for the feedback on the J-Link RTT Viewer.

  • Hello kjhuebner, Thank you for your inquiry and your feedback regarding the J-Link RTT Viewer. Could you please tell me which version of the J-Link RTT Viewer you are using? Recently, there have been a couple of updates and improvements regarding the output speed and more of the RTT Viewer. One of those updates included the change from word-wrap to a horizontal scrollbar. Could you please give the current version of the J-Link RTT Viewer (V6.44i) a try? You can find the download here: segger.com…

  • Hello rum, I am glad to hear that you are up and running now. We're aware of the manuals being misleading in this way and will improve them in the future.

  • Hello rum, In the command line that you posted, you are using a different symbol than an ASCII minus. If you look closely: forum.segger.com/index.php/Att…b1d7f26679f6a43fc89cc067d You can see that those symbols are different, which is why they were parsed incorrectly. Could you please make sure to only use the standard ASCII minus symbol (0x2D) for command line parameters? Here is a corrected version of your command line: "C:\Program Files (x86)\SEGGER\JLink_V642\JLinkRTTViewer.exe" --autoconnec…

  • Hello rum, I asked for a screenshot to ensure that there are no typos or similar in the command line, but I can exclude this now. I know you are using multiple J-Links, thank you for the heads-up. We highly appreciate you using our products. I managed to reproduce the issue you are facing and am currently trying to pinpoint the exact issue. As soon as I have a fix or work-around ready, I will get back to you. I expect to find and resolve the problem tomorrow. Thank you for your patience.