Search Results

Search results 1-20 of 1,000. There are more results available, please enhance your search parameters.

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Hello, FYI. We improved Ozone so he display of size optimized code in the inline disassembly is accurate now. This will be available with the next Ozone update. You can subscribe to our notification mail to stay up to date: segger.com/notification/subscribe.php?prodid=178,7 Best regards, Nino

  • Hello, Thank you for providing the option information. With it the behaviour is reproducible. We are currently investigating. I will inform you once we have new information about this topic. Best regards, Nino

  • Hello, It sounds this issue may be related to the indexer not having finished its job. Do you have a rather large project? In the Source Navigator window, do you see the indexer still running? If yes wait for the indexer to finish its task. After that all goto features should work as expected. Can you confirm this? Best regards, Nino

  • Hello Pieter, Thank you for your inquiry. Quote from piconomix: “Feedback for the Segger R&D team: I noticed this comment in the documentation, but the implication should really be explained better: In case timestamp is not retrieved from cycle counter but from system timer, SEGGER_SYSVIEW_TickCnt must be incremented in the SysTick handler before any SYSVIEW event is generated. I guess what you mean to say is that the SysTick timestamping handler must be configured and running before generating …

  • Hello, Thank you for your inquiry. Such an issue is not known to us. Could you provide your exact settings that you have changed that lead to said behaviour? Best regards, Nino

  • Hello, Thank you for your inquiry. Generally we do not recommend to have optimizations active when trying to debug as debug information may be missing which is crucial for many of the Ozone features. On first glance it also appears that gdb is not correct with the grouping either. Anyhow thank you for the report and we will check if Ozones behaviour can be improved here. But no promises. Best regards, Nino

  • Hello, Yes, the issue is not fixed yet and it is still being worked on. As it is at a timing related issue the setup specifics are crucial and it is why it is extremely difficult to reproduce for our developer team as we do not have the exact same host PC with the same hardware and software running like you who are able to reproduce the behaviour. So far the appearance of the bug was also completely random and unfortunately not a single user could provide a reliable reproducer that triggers the …

  • Hello, Thank you for your inquiry. We are not allowed to share this information via our public forum. But if you like we can provide you this information via our support system. Simply open a ticket as described below referencing this forum post. I also talked to our hardware team regarding this parts and according to them, if one of these ICs is damaged it is guaranteed that more than just that part is damaged. So just replacing that part will most likely not lead to any success. Instead we rec…

  • Hi, Thank you for your suggestion. We will discuss this by the end of next week and come back to you once we have news. Best regards, Nino

  • Hello Thomas, We received now a new MB997D board (Rev. C boards are no longer sold by ST) where we converted the ST-Link as described here: segger.com/products/debug-prob…j-links/st-link-on-board/ And everything is working as expected. Did you make sure that you followed all the steps from the guide? Did you install the ST-Link USB drivers? Please understand that we can't put more time into this investigation as the issue seems not be be related to SEGGER software but is rather either a usage er…

  • Hello, Thank you for your contribution to the community. Best regards, Nino

  • Hi, Thank you for clarifying. This is currently not possible. But we will add it to our wishlist for future features for Ozone. Best regards, Nino

  • Hi, Ah I see, good to hear that you are up and running again. We will consider this thread as solved now. Best regards, Nino

  • Hi, Thank you for providing additional information. We will see what we can do to improve the experience with such keyboard layouts as well. Best regards, Nino

  • Hello, No worries, and yes, the nRF package does not come with the correct startup yet. But an update is planned shortly. All other packages that are not transformed yet will also be updated by us. But if you generate a generic project for your target device without any CPU support package, the project generator will use the generic files from the /samples folder in the ES installation path which are in the correct form for the new SEGGER tool chain. You can also do this manually as explained in…

  • Hello, A list of our distributors can be found here: segger.com/purchase/distributors/ Unfortunately we do not get the stocking information from them so you would have to contact the distributors directly. Best regards, Nino

  • Hello, Thank you for your inquiry. Dark mode is not supported officially and as you found out correctly, Ozone simply uses the current OS theme. A proper darkmode is on our ToDo but no fixed timeschedule yet. Best regards, Nino

  • Hello, Thank you for your inquiry. Such an issue is not known to us. Could you provide a video or gif showing the behaviour? What Linux version are you using exactly? Best regards, Nino

  • Hi, Thank you for your inquiry. I just gave it a quick try on a Ubuntu18 VM and the versions were showing up correctly for both the deb and tgz. Most likely this is somehow related to your specific Linux config. Best regards, Nino

  • Hello Max, Thank you for your inquiry. You can display the data in a table in the Data Sampling window in the Samples tab. If you right click the content you can also export it. Best regards, Nino