Search Results

Search results 1-9 of 9.

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Attached is the svd file ... (note: work in progress)

  • Hi, I am in the process of creating an SVD file for a ADuCM350 processor. One of the registers contains 2 bits that are sticky, they keep their value unless a one is written to them to clear. Here is the register. forum.segger.com/index.php/Att…52754346aa0e3bd63da740f00 ... and the SVD description I have made using CMSIS Schema version 1.1 forum.segger.com/index.php/Att…52754346aa0e3bd63da740f00 So when viewing the register in Peripherals->Register if one of these sticky bits are set and i attem…

  • Hi Nino, I have downloaded Ozone V2.62a. Running with it for a day and the issue looks to be resolved. I appreciate your team's rapid response to this, 5 stars Best Regards, --Duane.

  • i Nino, Thank you for your response. I will see if I can reproduce this with the Cortex-M Trace Reference Board and the tutorial project. Thanks for the note on J-Trace PRO V2 probe, we did notice that the measurement was offset a little, but not a huge concern as we are just looking at knocking down the peaks. Will look forward to the future update. For Ozone these are my settings, I am also streaming Data Graph items. forum.segger.com/index.php/Att…52754346aa0e3bd63da740f00 forum.segger.com/in…

  • Hi, So when using power graph it sometimes will continue recording after halting program execution. Other times it will halt power trace readings. I am using Ozone v2.62, J-Trace Cortex Pro (connected via JTag) Firmware: J-Trace PRO V2 Cortex compiled Oct 25 2018 11:51:34 Hardware version: V2.00 I'm not sure what the expected behavior is but halting power trace readings when the program is halted is desired. It seems to be random in its behavior ... sometimes it will halt for a full session othe…

  • Hi Nino, Thanks for the reply. So, I was able to get this working, not sure exactly what the issue was. I did a couple of things that may or may not have "fixed" it. - I reset my J-Link Pro configuration (via J-Link Configuration) - I recalibrated using J-Link Commander (via "calibrate" command) Question on Ozone is there a hard limit on the Power Graph data? For example when I load and run the power graph will stop after a period of time. @10kHz sample, stops at 100 seconds @20kHz sample, stops…

  • Hi, So, I have a need to analyze my power consumption on a Cortex-M3 and need some guidance on proper setup. I have a J-Link Pro V4.5 loaded with the latest firmware. These are the steps I have performed: Setup 1. Installed the latest version of Ozone (v2.61 Beta, as of this writing) 2. Configured my target to be supplied power by J-Link 3. Open Ozone and Create New Project1. Select my Target Device (ADuCM350) and Peripherals (ARMv7M) 2. Set Connection Settings for my J-Link (choose defaults, JT…

  • Thanks for the response Arne. Understood, we found a workaround that fits our needs... 1) save the raw data file. 2) create a new project file and save it then open the new project file in an editor and ... a) point to the raw data file b) add our symbol names forum.segger.com/index.php/Att…52754346aa0e3bd63da740f00 Then opening the project file we have our symbol names and can export to CSV with our symbol names It might be nice if when saving the project file we could apply symbol names Cheers…

  • Hi all, Is there a way to set the symbol names when connecting to a target with JScope and using RTT? When I connect JScope with an RTT target, default symbol names are assigned (i.e. "Symbol No 1", etc.) forum.segger.com/index.php/Att…52754346aa0e3bd63da740f00 Best Regards, Duane.