Search Results

Search results 1-20 of 27.

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • GUI_alloc erro

    Ana - - emWin related

    Post

    HI, I have tried with both using custom callback for the background window as well as just using WM_SetDesktop color(GUI_BLACK). Summary of the scenarios: 1) Using WM_DeleteWindow function. Following error message forum.segger.com/index.php/Att…ae3045d877ebed81917fe5fff is seen, but graph window is properly deleted forum.segger.com/index.php/Att…ae3045d877ebed81917fe5fff and other functionality works fine. Following is the code: if (GUI_data.Graph_win != 0) { WM_DeleteWindow(GUI_data.Graph_win);…

  • GUI_alloc erro

    Ana - - emWin related

    Post

    Hi, Following is the code I have used to create the graph window. GUI_data.Graph_win = GRAPH_CreateEx(WINDOW_POS_X, (WINDOW_POS_Y+35), WINDOW_SIZE_X, 378, WM_HBKWIN, WM_CF_SHOW| WM_CF_CONST_OUTLINE, 0, 0); WIDGET_SetEffect(GUI_data.Graph_win, &WIDGET_Effect_None); GRAPH_SetBorder(GUI_data.Graph_win, 60, 10, 40, 40); GRAPH_SetColor(GUI_data.Graph_win, GUI_BLACK, GRAPH_CI_BK); GRAPH_SetColor(GUI_data.Graph_win, GUI_BLACK, GRAPH_CI_BORDER); GRAPH_SetColor(GUI_data.Graph_win, GUI_WHITE, GRAPH_CI_FRA…

  • GUI_alloc erro

    Ana - - emWin related

    Post

    Hi, I have tried calling the WM_SetDesktopColor. immediately after GUI_Init(). I have attached a screenshot of the graph screenforum.segger.com/index.php/Att…ae3045d877ebed81917fe5fff and the screen after I delete the the graph using GRAPH_DATA_YT_Delete(GUI_data.Graph_data1); and after creating listbox screenforum.segger.com/index.php/Att…ae3045d877ebed81917fe5fff. I am also calling WM_SetDesktopColor(GUI_BLACK); after deleting the graph window. Thanks,

  • GUI_alloc erro

    Ana - - emWin related

    Post

    Hi, I have checked and the GRAPH_DATA_YT_Create() returns a non-zero value. So the data object is being created successfully. Please help me with this issue. I have read the documentation and am unable to find any fault. When is the following error generated ""gui_alloc.c: block to be deleted is already locked in free()" Thanks

  • GUI_alloc erro

    Ana - - emWin related

    Post

    Hi, I have used the following code to create the data for the graph I16 Transducer_data1[40]; GRAPH_DATA_Handle Graph_data1; I16 Graph_pixel_data1[720]; static void graph_data_computation(U8 new_old) { unsigned int i, j, k; float diff1, diff2; GUI_data.Transducer_data1[0] = 10; GUI_data.Transducer_data1[1] = 11; GUI_data.Transducer_data1[2] = 12; if (new_old == 1) { GRAPH_DATA_YT_Clear(GUI_data.Graph_data1); for(i=0; i<65530;i++); GUI_data.Transducer_data1[0] = 20; GUI_data.Transducer_data1[1] =…

  • GUI_alloc erro

    Ana - - emWin related

    Post

    Hi, No, it only gives me an error when I attach the data using the following line of code GRAPH_AttachData(GUI_data.Graph_win, GUI_data.Graph_data1); Thanks

  • GUI_alloc erro

    Ana - - emWin related

    Post

    Hi Adrian, No the graph window hasn't been deleted. The graph has been created as follows: GUI_data.Graph_win = GRAPH_CreateEx(WINDOW_POS_X, (WINDOW_POS_Y+35), WINDOW_SIZE_X, 378, WM_HBKWIN, WM_CF_SHOW| WM_CF_CONST_OUTLINE, 0, 0); After the processing, I am using WM_DeleteWindow to delete the instance as follows: if (GUI_data.Graph_win != 0) { WM_DeleteWindow(GUI_data.Graph_win); GUI_data.Graph_win = 0; } I tried using GraphDelete functions but the background window still shows the graph. Thanks

  • GUI_alloc erro

    Ana - - emWin related

    Post

    Hi, I get the following error when I try to delete the graph widget using WM_DeleteWindow "gui_alloc.c: block to be deleted is already locked in free()". Why is that so? Thanks,

  • Alpha Blending Windows

    Ana - - emWin related

    Post

    Hi, No the other windows are created quite fast. The windows are drawn as follows: GUI_data.Window1 = WM_CreateWindow(WINDOW_POS_X, WINDOW_POS_Y, WINDOW_SIZE_X, WINDOW_SIZE_Y, WM_CF_SHOW, callback_standby_screen, 0); GUI_data.Window2 = WM_CreateWindow(Child_window_x_pos, Child_window_y_pos, Child_window_x_size, Child_window_y_size, WM_CF_SHOW, callback_standby_screen, 0); WM_SetHasTrans(GUI_data.Window1); The call back is as follows: if((pMsg->hWin) == GUI_data.Window1) { GUI_SetAlpha(85); // Se…

  • Alpha Blending Windows

    Ana - - emWin related

    Post

    Hi, I was able to resolve the issue. The popup windows were being drawn on top of each other without memory being deleted. Now on the actual hardware, the popup window is displayed very slowly. How can I make sure that it is displayed in one go? I have enabled multi-buffering as well. Thanks

  • Alpha Blending Windows

    Ana - - emWin related

    Post

    Hi, I have created popups using "Alpha blending". To achieve the popup effect, I am using two windows. One base window with transparency enabled and one window on top of that which has the required text. When the popup windows are deleted and a listbox screen is displayed then some portion of the screen is purple. I am setting the background color to be black. I have attached screenshots of both the scenarios. Image1: Is the popup window with transparency enabled for the base window Code is as f…

  • Listbox text

    Ana - - emWin related

    Post

    Hi, Is there any way to limit the maximum number of characters in the listbox item so as to avoid clipping of data? Thanks

  • GUI_DrawBitmap

    Ana - - emWin related

    Post

    Hi, I want to replace the current image with a new image using "GUI_DrawBitmap" under the WM_PAINT message. But the screen still displays the old image. Why is that so? Thanks,

  • TEXT_SetTextColor

    Ana - - emWin related

    Post

    Hi, I am calling the "TEXT_SetTextColor" function under WM_PAINT message to modify the text colour after a particular condition is generated. I then use "TEXT_SetText" to modify the textbox data. The data is getting modified but the colour remains the same. Why is this so? Is it wrong to call the TEXT_SetTextColor function under WM_PAINT message? Thanks

  • Simulation system time

    Ana - - emWin related

    Post

    Hi, Where can I find information about this function? Thanks

  • Simulation system time

    Ana - - emWin related

    Post

    Hi, Can I access the system time while using the exe in a PC simulation? I have to implement a time-out of 30 days. Thanks,

  • alpha blending

    Ana - - emWin related

    Post

    I have to implement the following overlay type of image(untitled.png), using alpha blending and GUICC_16. Using the following code:forum.segger.com/index.php/Att…ae3045d877ebed81917fe5fff GUI_SetAlpha(85); // Set alpha value for drawing operations GUI_SetBkColor(GUI_DARKGRAY); // Draw gray background... GUI_Clear(); // ...with alpha blending GUI_SetAlpha(0); I am able to achieve Untitled2.png. Is there any way to achieve this, using 4bpp? Thanks,

  • Contrast setting

    Ana - - emWin related

    Post

    Hi, Is it possible to change the contrast setting for an LCD using Emwin or is it a controller specific setting? Thanks

  • Font file creation

    Anagha - - emWin related

    Post

    Hi, Yes I have created c files. We wanted to calculate the memory requirement. If we use the file sizes as they are, the memory required is huge. How do we do that? Thanks

  • Font file creation

    Anagha - - emWin related

    Post

    Hi, I want to have support for the following languages: English(en), German(de), Portuguese(pt),Spanish(es), French(fr), Slovenian(sl) and Chinese using the ‘Arial Unicode MS’ font. The font sizes required are 26 – regular, 26 – bold, 55 –regular and 70 – regular. The following ranges are enabled: (0021- 007E, 00A0-00AF, 00B0-00BF, 00C0-00CF, 00D0-00DF, 00E0-00EF, 00F0-00FF, 0100-010F,0150-015F, 0160-016F, 0170-017F and 4E00 – 9FFF) If font files are generated using the ‘Font converter’, the fil…