Search Results

Search results 1-20 of 55.

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Hi, I included RTT into my target firmware and it works like a charm with RTT Viewer. Thanks a lot! Cheers

  • Hi Nino, another thing that I found yesterday is an inconsistency between the Watched Data and the Data Sampling views. Still related to renaming an entry, so I just add it here. When I click an entry in the Watched Data view and type in another name (so pointing at another variable), the changed entry seems to be considered as new entry, so its refresh rate is set to default (off). When I do the same in the Data Sampling view, the changed entry inherits the settings from the old entry. To see t…

  • Hi Nino, thank you for clarification. I thought so ... but hope dies last. I will look into the RTT link, thanks. Cheers

  • Hi, we have a problem where we need to debug the conditions at very close time to the power-on state. If we switch on the device and then connect with Ozone manually, it is already too late. Is there a way to have Ozone start the debugging session automatically when the J-Link Pro detects a connected device? Or can the J-Link Pro maybe cache some data before Ozone connects to it? Maybe a stupid question but after two days of fiddling with this and on a Friday evening, my brain is fried. Cheers

  • Hi, since I can only debug this at work and I am usually busy doing other stuff, I find it hard to create a minimal example project. Would it be possible for you to send me some debug version of Ozone which writes some log file? This still happens to me two to four times a day, which is quite inconvenient. Cheers

  • Hi, in Ozone 3.20a, when I have a variable in the Watched Data tab and set it up with a certain Refresh Rate (e.g. 1 Hz), I can delete that variable and when I add it back into the list, it still has the Refresh Rate I gave it earlier. While I would still love to see some kind of default refresh rate setting in the toolbar, the default behaviour of adding a variable with a refresh rate of "Off" should also apply to variables that had been in the list at some earlier point in time. Cheers

  • Hi, thanks for reproducing. I wasn't sure about the earlier versions. It just stumbled across it the other day, probably because I opened more views. Cheers

  • Hi, thanks for the clarification. I can see your point. Cheers

  • Hi, in the file menu there are three Save options: forum.segger.com/index.php/Att…0f97b71925fffe3667eb8243a - Save saves the currently shown source file when modified - Save Project as... saves the project session to a selected file - Save all saves all modified source files Suggestion: - order them so that the file-related save options are together - add a new option Save Project to save the current project configuration to the file the project is already opened from The latter is already done …

  • Hi, in Ozone v3.20a when I have several stacked views, on restart Ozone forgets what view in a stack was at the top. See the picture: forum.segger.com/index.php/Att…0f97b71925fffe3667eb8243a I usually have the Data Sampling and Watched Data tabs on top but when I exit and restart Ozone, it's always the rightmost tab that's on top. I _think_ in the past the selected tab was restored for the next session. Not sure about that, though. It feels like it should, though. Reordering the tabs to the ones…

  • Hi, this still hits me several times a week in Ozone v3.20a. I do not know how to cleanly reproduce but it always happens when a debugging session runs for an hour or two. vimeo.com/428175176 Maybe you are able to check your code for the case when the debugging session is not stoppable anymore. Edit: It happened again, this time with a different Sampling Frequency. In the video I had set it to 1kHz and now at 100Hz. Both times it foze at around 400 000ms forum.segger.com/index.php/Att…0f97b71925…

  • Hi, looking at v3.20a I can see that 1) the install path is not versioned anymore and 2) the SVD path in the .jdebug file uses a variable. So, I guess that should fix the SVD path problem. (Not sure if there was a real problem though since I did not see any negative effects of the path being invalid) The project path, however, is still an absolute path. Project.AddPathSubstitute ("C:/path/to/project", "$(ProjectDir)"); Is this still planned for the future or made absolute on purpose? Cheers

  • Hi, .jdebug files are created with an entry containing an absolute path in it. Project.AddSvdFile ("C:/Program Files/SEGGER/Ozone V3.10j/Config/CPU/Cortex-M4F.svd"); When I now install Ozone v3.20a and remove v3.10j and then open the .jdebug file in the newer Ozone, the path is invalid but I do not get an error message. When I then save the file with File -> Save project as... the path is not updated, so it remains invalid. Maybe it is better to use a runtime variable to determine the position o…

  • vimeo.com/427641189 The procedure is that I change the value of a variable over CAN and then send, still over CAN, a command to store that value to Flash memory.

  • Hi, in Ozone v3.20a when I start a debugging process and then change the Sampling Freq: in the Data Sampling window, the Timeline view just freezes. Changing the frequency back to the original one lets the Timeline run again. It's not always the same frequency that freezes the timeline. The one I start the debugging process with works fine but then trying the other frequencies shows two or sometimes three working, the other ones freeze the timeline. Can you reproduce this? /edit: I just found ou…

  • Hi, here is a short video showing the behaviour. Due to the overlay, it is not that easy to see but I click away from the window in between and then refocus the window. Within the time without focus, the timeline view runs fine but the numbers in the status bar are stopped. forum.segger.com/index.php/Att…0f97b71925fffe3667eb8243a Cheers

  • Hi, from software developer to a developer team. I know how hard it is to get testing on the agenda when time-to-market or just recource planning is on the plate. The week I get to write a single unit test is a good week and this does not happen too often and I am the only one pushing for this. So yes, I know reality. But regressions like these are quite unfortunate not only for the user but also for the image of a company. Maybe push the importance of testing a bit more within your development …

  • Hi, this is happening with v3.20a on a windows 10 host but I think it happened with the v3.10 series as well. Cheers

  • I cannot get the GIF video small enough to upload it here. Can I send a video file via email?

  • Hi, yes, took me a few seconds in pause mode to realise this as well. Chers