Search Results

Search results 1-3 of 3.

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • GRAPH_DATA_YT_AddValue questions

    TonyWang - - emWin related

    Post

    Hi, I would like to use GRAPH widget to show the waveform. GRAPH_DATA_YT_AddValue function can only add one value into GRAPH_DATA_Handle, is there any methold to update the whole date array? I can use the following code to initial data array, and attach them to GRAPH_DATA_Handle, but when I change the content of data after then, the Graph are not change accordingly. My quetions is how to update the whole data array and let Graph change accordingly. Thanks for your support. static I16 data[600]; …

  • sawtooth issue

    TonyWang - - emWin related

    Post

    Hi, Florian Thanks a lot for your fast response. This issue can be solved by 2 method. your reminder about GUI_MULTIBUF_Begin() use is really help. Could you please help to explain why the following ways can work? The first solution is add GUI_MULTIBUF_Begin() and GUI_MULTIBUF_End(); void MainTask(void) { GUI_Init(); GUI_SetBkColor(GUI_BLUE); GUI_Clear(); GUI_MULTIBUF_Begin(); GUI_SetPenSize(10); GUI_FillCircle (100, 60, 50); GUI_DrawCircle (250, 100, 50); GUI_DrawLine(200,200,300,350); GUI_Draw…

  • sawtooth issue

    TonyWang - - emWin related

    Post

    Hi, I am new for emwin. My platform is RT1052, I encounter an issue when using GUI_DrawCircle and GUI_DrawLine, Attached is the pic, sawtooth can be seen. It is normal when I display string or rect, and also display Widgets very well. What kind of problem can cause this kind of issue? I supposed the problem is likely to be in the hardware driver, but I do not know how to address it. Thanks a lot for your support. Following is the code. void MainTask(void) { GUI_Init(); WM_MULTIBUF_Enable(1); GUI…