Search Results

Search results 1-20 of 1,000. There are more results available, please enhance your search parameters.

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Hello Maxim, Thank you for your inquiry. The reported behaviour is reproducible and no intended. This will be fixed. Best regards Nino

  • Hello Thomas, Thank you for your inquiry. Embedded Studios C++ library is based on the STLPort and can be installed via the Package Manager. However due to low demand it is based on the C++98 standard with a couple user requested extensions of more modern features but so far no feature from C++17. Currently our core market is C where we are currently moving our complete toolchain to our own SEGGER toolchain with some heavy optimization and great features for embedded targets. You can find some m…

  • Hello Fränz, Thank you for your inquiry. For autocomplete to work quickly the indexer must index the project first. Could you check if the indexing process is completed? You can see the progress e.g. in the Source Navigator window. After the indexing is done auto completion should work instantly. Best regards, Nino

  • Hello, Thank you for your inquiry. It appears the guide is a bit outdated. I assume you are stuck at the part which says to install J-Link drivers with COM support. Just download and install the latest J-Link software and you should be good to go: segger.com/downloads/jlink/ Should that still not work please note that we do not provide any support for the conversion to J-Link as stated in the guide. As the Spansion Board you are using features a 9-pin debug header for external debug probes we re…

  • Hi Alessio, Ok I was able to Flash the application now. However it gets stuck in the ROM bootloader at 0x00200000 for me. I have the same jumper settings like on your board. Anything else that might need to be considered? If you do a erase of the external e.g. with J-Flash or J-Link Commander and then try to Flash the application you have attached. Does it run for you as expected? Regarding the profiling of RAM data via SWO, it is currently not fully supported but we are looking into it. Regardi…

  • Hello, Quote from Zeke: “Here are some logs. These are from after I closed Ozone via task manager. ” Thank you for providing the logs. The J-Link log does not seem to be saved correctly. Is Ozone the only tool in this instance that is connected to your J-Link or are there also other tools? You write that this issue appears on your own eval boards. I believe we should have them in our office as they are using J-Link OBs. Could you provide an example project for your boards with reproduction steps…

  • Hi, Thank you for providing the information. Could you send us the J-Link log and Ozone log file for reference? wiki.segger.com/Enable_J-Link_log_file and for Ozone log start Ozone via commandline with parameter -logfile <filepath> Best regards, Nino

  • Hi, Thank you for your inquiry. The behaviour is intended as SystemView V2 was essentially a complete different software than V3. So it is possible that the V2 package will not be detected as a predecessor of V3. But from V3 on the packages should be consistent and upgradable with the rpm packages of newer V3 versions. Best regards, Nino

  • Hello, Thank you for your inquiry. Unlock Kinetis may only work for NXP Kinetis target devices and not the MAC7xxx series. On many legacy ARM7/9 target devices debug interface speeds are not consistent. So it is possible that this target device has such inconsistency when the device is locked. However this is no issue related to J-Link but rather a target specific topic. For more information we recommend contacting the silicon vendor if there is known behavior like this. Best regards, Nino

  • Hi, The Arm debug interface is unfortunately not designed to catch such power on issues directly. So proper debugging as you know it with J-Link usually will not work. The only viable way is to write debug messages or variable values to some buffer on target side that gets written after startup. Then you can attach with J-Link at a later point and read out the data buffer. For a minimal footprint and maximal performance of such implementation we recommend RTT: segger.com/products/debug-prob…abou…

  • Hi, Thank you for your inquiry. We have added this as an improvement to our ToDo. Best regards, Nino

  • Hello, Thank you for your inquiry. We are aware of this issue, however so far no one could provide us with a working reproduction scenario. Could you provide us with reproduction steps that work reliably? What is your debug setup? Which J-Link? What is the target device name? Custom or eval board hardware? Does it appear only with a specific project or with any? Best regards, Nino

  • Hello, Thank you for your inquiry. Which pop-up do you refer to exactly? Could you provide a screenshot of it? What is the J-Link serial number you are currently using? Quote from M0NKA: “Yes, i can use the STLink perfectly, but wanted to see if JLink is suited for ST development, seems bit faster on flashing, also if not mistaken was promising 100 Mbps streaming on the SWO pin, i would love that. ” Depends on the probe you are using but yes one of the biggest benefits of J-Link is that our flas…

  • Hi, Thank you for your inquiry. To our knowledge the only way to disable the EZPort is by pulling the EZP_CS pin high. For information if there is a non-official/undocumented way we recommend contacting the silicon vendor. The inconsistencies in the Wiki article were accidental and should be fixed now. Thank you for pointing them out. Best regards, Nino

  • Hello, Thank you for your inquiry. SystemView PRO may only be used commercially with a PRO license that has to be bought. There are currently also no deals in place with silicon vendors like it e.g. is for Embedded Studio. In the past there were two versions of SystemView. A free version with a limited featureset and the PRO version. This was up until version number V2.52d. So up to V2.52d you may also use the free variant commercially which you can also find in the download section. However sin…

  • Hello, Thank you for your inquiry. The patch files provided with SystemView are only examples and provide a reference for some versions so customers can easily create their own patches. So it is possible that not all of the available FeeRTOS releases will get a patch file that is provided with SystemView. If you have created your own patch file and want to provide it to other users feel free to attach it here in the forum in your post so other community members can access it. Best regards, Nino

  • Hi, Thank you for your inquiry. A generic guide on how to port project from IAR to ES can be found here: wiki.segger.com/Port_Projects_…kbench_to_Embedded_Studio Not all information can be translated from IAR during the import process e.g. some preprocessor options. You can add them manually via Embedded Studio project options under Preprocessor->Preprocessor Definitions Best regards, Nino

  • Hello Darren, Good to hear that you are up and running again. You can find documentation about this here: studio.segger.com/ide_project_macros.htm We will consider this case as closed now. Best regards, Nino

  • Hello, Thank you for your inquiry. Please note that this forum is no support forum. As you are working for one of our silicon vendor partners we recommend to contact us via our support system. For more information see my signature. When opening the inquiry could you also add information on which linker you are using for your setup and what target device. Could you also add an example project for reference that shows the reported behaviour? This thread will be closed now to avoid duplicate inform…

  • Hello, Thank you for your inquiry. The reported behaviour does not seem to be related to issues in SEGGER software. So please understand that we can't put much time into this request as it is user responsibility to debug and write user code. But as a general tip make sure all code optimizations are disabled and make sure that variables are defined in a way that the compiler may not optimize variables away. How to do this can be found in numerous online resources. For debugging this we recommend …