Search Results

Search results 1-8 of 8.

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Hi, I am trying to integrate a new Cortex-M33 microcontroller with Segger Jlink in order to enable users to download their applications to flash. The setup uses a cortex-M33 MCU, Jlink mini board to connect to it. The flash loader algorithm was written using Keil MDK environment and tested out for flash erase, program and read/verify functionality. The FLM file was generated. JLinkDevices.xml file in Segger installation folder was modified as shown in the attached file. The devices has two flash…

  • Hi, I am using the Embedded Studio IDE for developing a flash loader utility for a new Cortex-M33 microcontroller. I have adapted the template project and added in details about flash array into it. I have implemented the Segger Open API functions like erase, program etc. The "elf" and "hex" file is generated successfully. However in the "map" file I can see absolute address of device SRAM being used for various sections of code and memory. I want to generate position independent code, similar t…

  • Hi, I am developing a flashloader based on Open Flashloader API described in wiki.segger.com/Open_Flashloader#Open_Flashloader This flashloader is for a CM33 MCU which is still under development. The MCU has two regions of flash memory - NVR section and Main Flash Array. The NVR region needs to be programmed in a special way, with some addional security features, while the main flash array can be programmed normally. I have the following queries: 1. Can we have separate flashloaders for each of …

  • Hi, I was able to setup Ozone for my MCU and use Jlink with Ozone. After setting up MTB parameters like POSITION, OVERFLOW etc in the "AfterTargetReset ()" function of Ozone project file, I enabled trace using Tools->Trace Settings->Trace Source->Trace Buffer. When I click on the Debug button (Download and Reset on top left hand corner of Ozone IDE), get the error "ETB selected as trace source but current device does not have ETB". I am able to view the MTB setting in the memory window and also …

  • hi, Can you please tell me how to initialize the MTB buffer pointer and overflow parameters before the actual program starts? In the case of Keil MDK IDE, I was able to set the parameters using the DBG_MTB.ini script, which is loaded by the Jlink debugger before jumping into the reset vector. In the case of Ozone, my guess is that the initialization script is written as described in Chapter 6 of the Ozone Manual, and is stored in *.jdebug file. How should I configure Ozone to use the modified sc…

  • Thank you for your prompt response. I will try out Ozone and JLink, I hope that should resolve any issues I am seeing. The MCU description is as follows, Cortex-M0+ (r0p1) with 8KB of RAM and 64KB of embedded FLASH memory. The MCU has MTB capability and dedicated 2K RAM for the same. Best Regards, Radhika

  • Hi, I am trying to setup traces using our company's cortex-m0+ MCU having MTB capability. I have setup the following: 1. Created MTB.ini file containing the MTB SRAM size and MTB address fields for my device. 2. Setup Keil MDK with the project to be debugged. I have setup the debug tab with appropriate parameters as displayed below: 3. Whenever I debug the program it gives me an error "Trace HW not present" Can you please tell me what the problem is? I have read up different blogs and forum arti…

  • I am using Segger JLink to download my binary to flash using the Eclipse IDE. Eclipse IDE version is Oxygen.3a Release (4.7.3a) and I am using the GDB Segger Jlink Debugging to download the binary to flash. When I try to download I get the following error on the debug console. Can you help me resolve this error. Once I physically disconnect the debugger and reconnect again, things start working fine. Thank you. Regards, Radhika SEGGER J-Link GDB Server V6.30f Command Line Version JLinkARM.dll V6…