Search Results

Search results 1-4 of 4.

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Hi, When to trace with Cortex-M3, I set project properties -> Target Trace Options as the attachment. Do I have to edit the Trace Initialize Script -- EnableTrace("$(TraceInterfaceType)") in JavaScript or the SES can done the EnableTrace functionality automatically? forum.segger.com/index.php/Att…a72f65129dee12038b01a326e Thank you very much. Best Regards, Shuai

  • Hi, Trace with Cortex-M3, SES log output “ Executing trace initialization script Executing Trace Initialize script EnableTrace("TracePort") LTRACE (Time since start: 0.942 973, Thread=PRE J-Trace sends trace data faster than J-Link software can analyze it, trace data had to be discarded. Stopping streaming trace. Communication timed out: Requested 4 bytes, received 0 bytes ! ” What is this log means? I have another question: EnableTrace("TracePort") script is done by the SES tool itself or need …

  • Add picture the TPIU register configuration: "Cortex-M Trace Reference Board" VS "My Ozone project based on Cortex-M3 MCU". My question is Whether Ozone can configure the right value to regs in ETM/TPIU component of Cortex-M3 automatically? Any why my Ozone project failed ? Thank you very much.

  • Hi, I am trying to enable the ETM Tracing with Ozone on a ARM Cortex-M3 MCU. But when starting a debugging session there is no instruction data, also I can't get the half-sync 16'h7fff, I always get 32'h7fffffff when the target is halted. Can Ozone configure the right value to regs in ETM/TPIU component of Cortex-M3 automatically? As no matter what trace pins width I use the TPIU_CSPSR keep the default value, but when I use the "Cortex-M Trace Reference Board" bought from Segger, the register is…