Search Results

Search results 1-20 of 124.

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Hi Hugo, Thank you for your inquiry. From what we can see, the J-Link seems to be defective. Could you please provide us with the serial number of this J-Link? I am asking because the the S/N you have added to your forum profile is from a unit which is out of support and warranty. For such a unit we recommend to make use of our trade-in program: segger.com/purchase/trade-in-program/ Best regards, Fabian

  • Hi, Thank you for your inquiry. Please note this is not a support forum, but a community forum. For more information please refer to my signature. Regarding your issue: There is no issue known to us regarding the LPC55S69 series. I am not entirely sure if I understand you correctly. What you mean with "LPC55S69 0A" and "LPC55S69 1B" ? Is this referring to an evaluation board revision? If so, which evaluation board are you using exactly? Could you give the latest Software and Documentation Pack v…

  • Hi Mehmet, Thank you for your inquiry. The "x" is just a place holder for a letter or for a number (in this case a letter). There are multiple STM32F051x4 devices, we do support: forum.segger.com/index.php/Att…5b0a127ca53d829304e84fec4 Does this answer your question? Best regards, Fabian

  • Hi, Thank you for your inquiry. Such an issue is not known to us. Our Cortex-M Trace Reference Board uses the same chip and there have been no issues reported. It is most likely that this issue is connected to your custom board. Do you experience the same problem on an evaluation board? Best regards, Fabian

  • Hi, we will be looking into this. I will come back to you as soon as we have news. Best regards, Fabian

  • Hi, Thank you for your inquiry. If you are unsure whether a specific device is supported or not, please refer to this list here: segger.com/downloads/supported-devices.php It contains all devices supported by J-Link. Best regards, Fabian

  • Hi, Thank you for your inquiry. There should be no issues with reading the registers with J-Link + J-Link Commander. The base address should be mentioned somewhere in the PDF you are using (memory map, register category). If you cannot find it, please contact TI support about this. Best regards, Fabian

  • Hi, Do you have any peripheral flash connected to the chip at address 0x90000000? Could you please check, that there are no flash banks enabled in the J-Flash project, that are not accessible? You can do so here: forum.segger.com/index.php/Att…5b0a127ca53d829304e84fec4 Best regards, Fabian

  • Hi, Do you have the possibility to test the J-Link EDU Mini on another board or another J-Link you can connect to the board with? Unfortunately, there is not much more we can do for you, as long as we are not able to reproduce this with. Best regards, Fabian

  • Hi, Did you set the RTT Viewer to use "existing session" + "auto reconnect"? If not, does it work when using RTT Viewer with these options enabled? Could you please provide us with a screenshot of the RTT Viewer's "Configuration" dialog? Best regards, Fabian

  • Hi Thomas, Sorry for the delay in response. We have pretty busy days right now (preparations Embedded World, etc.). We looked at this again. The issue is in the HAL.c and not in the way how the memory accesses are executed. To access the DBGMCU registers from CPU space (your application), you are supposed to use 0xE00E1000, see STM32H7 reference manual: forum.segger.com/index.php/Att…5b0a127ca53d829304e84fec4 (Taken from RM0433) Therefore we suggest that you correct the HAL-init to use the right…

  • Hi Radhika, Thank you for your inquiry. When using Open Flashloader, you do not need to have position independent code. The flash loader is downloaded into the RAM area specified in the application. The Open Flashloader is designed to be used with the J-Link debug probes. It will work with the J-Link Plus. Best regards, Fabian

  • Hi Radhika, Thank you for your inquiry. Reg 1.: As I can see in the image you attached, you are doing this already ("[..] Loader = [..]"). You actually have to provide a flashloader for each memory area. For more info, please refer to this page: wiki.segger.com/Open_Flashloader#.3CFlashBankInfo.3E Reg 2.: wiki.segger.com/Open_Flashloader#General_Procedure Best regards, Fabian

  • Hi, Thank you for your inquiry. Does this problem still occur with the latest version of the J-Link Software and Documentation Pack? You can download it here: segger.com/downloads/jlink/#J-…twareAndDocumentationPack NOTE: Please also update the J-Link DLL of Keil via the J-Link DLL Updater included in the Pack mentioned above. If the problem still persists after updating: 1) Do you use custom hardware or an evaluation board? In the latter case which one? 1.2) If custom hardware, do you experienc…

  • Hi, We will announce this feature in our news letter as soon as it is added: segger.com/notification/subscribe.php?prodid=7,94 Best regards, Fabian

  • Hi, 1) So you were able to connect to the device with another debug probe? 1.1) If so, which one? 2) Did you you set the device into any low-power mode or did you lock the device in any way? 3) Could you provide us a datafile (e.h. .hex) of the application running on the target? Best regards, Fabian

  • Hi, We fixed the issue. The fix is part of version V6.62a and later. Best regards, Fabian

  • Hi, Does erasing with the J-Link Commander work when using the command "exec EnableEraseAllFlashBanks" (w.o. quotations)? After erasing the target with the J-Link Commander, does the problem still persist with J-Flash? Best regards, Fabian

  • Hi, Thank you for your inquiry. Could you please follow the troubleshooting article on the page linked below? wiki.segger.com/J-Link_cannot_…the_CPU#Target_connection Best regards, Fabian

  • Hi, Thank you for your inquiry. Such an issue is not known to us. 1) Could you please follow the troubleshooting article on the page linked below and send us a screenshot of the entire J-Link Commander output? wiki.segger.com/J-Link_cannot_…the_CPU#Target_connection 2) Could you please send us a J-Link log file? How to enable: wiki.segger.com/J-Link_DLL#Enable_J-Link_Log_File 3) Do you use custom hardware or an evaluation board? In the latter case which one? 3.1) If custom hardware, do you exper…