Search Results

Search results 1-20 of 20.

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Drivers 6.14-6.54. KEIL does not detect the STM32F030F4 processor. When change the debugger from J-Link to ST-Link, the processor is detected. The oscilloscope does not detect SWD activity. The cause of the malfunction - in the KEIL settings, the processor is selected as "STM32F030F4Px" and this name is written in the settings file "project.uvprojx" in the parameter "<TargetCommonOption> <Device> STM32F030F4Px </Device> " As a result, J-Link does not find this type of processor and puts "ARM7" (…

  • Quote from u37: “Dear Nino, see the picture. The "i++" fragment is executed on it, and the graphical representation of SES shows that part "i--" is executed. It is right? ”

  • Thank you, you explained very well what is happening! Tell me when will you fix this error? While writing a program, some modules may not be connected, but your separation of blocks into active-inactive should work. Or have to write code in the blind. Literally "blind" - the text is already poorly visible. Made a new project (made in KEIL 5.23 with import into SES 4.18). The project is compiled into SES and executed. forum.segger.com/index.php/Att…e82032f20ae2a9243e902ba32 forum.segger.com/index…

  • I use SES to export KEIL projects. When viewing texts in SES I found out that definitions disappear. If the definition is made not in the file itself, then this definition disappears. By iterating, I discovered that a defect occurs (for example) when connecting the standard CMSIS file - "core_cm0.h". If you remove it, the definition works fine. If enabled, the definition disappears. I made a simple test - in your example I added a few lines - the file main.h with the definition and include "core…

  • In error with Control Panel - I changed the log settings and more. Now this defect is not manifested. Let's assume that the "I" was mistaken. When I can clearly determine the conditions of occurrence, I'll write separately. Thank you.

  • Hello, Leon. If you are interested in testing the problem, then I did the following test - I blocked working with the JLinkLog.txt file (the error of creating a file in the dll was simulated). Now the debugger works without a problem with the time, the photo is attached. Increase the limit of 100000000 is not necessary. Please, remove the log file altogether.

  • Hello. There are two debuggers - Base and devboard ST-Link-> J-Link. All the defects are approximately the same, I did not notice a difference in behavior. There are two problems. Problem number 1. If you start debugging, open the Control Panel J-Link, then after ~ 20 minutes the debugged processor falls off in J-Link. How to repeat the test? Start debugging, open the Control Panel and go to dinner. When you come, you will be waiting for a surprise. The defect is stable. Problem number 2. Debugg…

  • Thank you for your help, the problem is solved.

  • Thank you for your help! In the project settings, "none" is specified in the description of the register file (svd). If there is a reference to .svd, the peripheral registers will appear. The registers description file (STM32F302x.svd) is specified in the KEIL project settings (<SFDFile> $$ Device: STM32F302C8 $ SVD \ STM32F302x.svd </ SFDFile>). The location of the SVD catalog is also described (<PackID> Keil.STM32F3xx_DFP.1.4.0 </ PackID>). Do I need to enter it with my hands? But that's not a…

  • Thank you for your help! The point is that in KEIL there is a representation of the periphery in debug mode. Different people use ARM differently. Someone makes "windows" with a nice GUI, and I use processors to solve simple hardware problems. For example, the previous project was in the hardware filter to smooth the movement of the CNC (processor f030). Now we need to make a motor controller. All these are "hardware" devices. They require a clear and reliable operation of the equipment (periphe…

  • Hello Nino. Once again - thank you for your help. Excuse me, can I be straight (honestly)? KEIL works correctly with its settings. SES correctly build on the settings that are imported. But, SES can not make a rebuild (solution). The file sct already exists, is present in the Objects directory. In order to eliminate the error, you must: forum.segger.com/index.php/Att…e82032f20ae2a9243e902ba32 a) go to KEIL on the linker tab, remove the checkbox from "Use Memory Layout .."; b) click "Edit"; c) cl…

  • Thank you for your help! As expected, I'm to blame. Video: sendspace.com/file/ykq9zl Unfortunately, the project is compiled once, on the second compilation solution there is an error.

  • "You seem to be changing your setup each time you post." You demanded the alignment of the project and equipment. I took the native hardware of the debug board. Video: sendspace.com/file/eu8oqs

  • рукалицо Hello. I made a clean project in KEIL with the native devices of the debug board (MCU STM32F030). The variable is shown in the "Watch1" window and as a memory in the "Memory1" window. If the program is stopped, the correct value is displayed in the two windows. If the program is started and stopped, the new value of the variable is displayed correctly in both windows (Watch1 and Memory1). If the program is running, the values ​​in the Memory1 window change, and in the Watch1 window the …

  • Hello. Processor STM32F103 and STM32F303. The defect is the same. The JLink-STlink debugger is described in more detail in my previous topic. However, this is not so important. I took the JLink-OB for a while, the defect completely repeated. To get a defect, set the output of the variables "Twice a Second", or any "*** Second". There are no problems in KEIL. Absolutely no problems.

  • In KEIL (5.23), a simple program is generated. Then the project was imported into SES (3.28a). The program is compiled and run in debug mode, one variable is output to the output window (watch1). Two pictures. First, the program is stopped (stp.png) The data is displayed normally. If you start and then stop, then the data will be normal. If the program is run, then - see the second picture (run.png) Data is not output. An error message appears. Similar problems occur in other windows (eg memory)…

  • Up

  • Hello. Debugger 32F0308DISCOVERY (ST-Link STM32F103; MCU STM32F030). The project can be anything, even a "demo" example created VisualGDB as "primitive" when creating a new project.

  • [SOLVED] JLink-ST-Link = bug

    u37 - - J-Link/Flasher related

    Post

    Up

  • There is a firm "VisualGDB". They allow you to debug the MCU through the debugger, including JLink. I took converted ST-Link and tried to debug their program. They have fallen. See for yourself: sysprogs.com/w/forums/topic/no…variables-through-j-link/