Search Results

Search results 1-20 of 111.

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Hi, Thank you for your inquiry. Does this problem still occur with the latest version of the J-Link Software and Documentation Pack? You can download it here: segger.com/downloads/jlink/#J-…twareAndDocumentationPack NOTE: Please also update the J-Link DLL of Keil via the J-Link DLL Updater included in the Pack mentioned above. If the problem still persists after updating: 1) Do you use custom hardware or an evaluation board? In the latter case which one? 1.2) If custom hardware, do you experienc…

  • Hi, We will announce this feature in our news letter as soon as it is added: segger.com/notification/subscribe.php?prodid=7,94 Best regards, Fabian

  • Hi, 1) So you were able to connect to the device with another debug probe? 1.1) If so, which one? 2) Did you you set the device into any low-power mode or did you lock the device in any way? 3) Could you provide us a datafile (e.h. .hex) of the application running on the target? Best regards, Fabian

  • Hi, We fixed the issue. The fix is part of version V6.62a and later. Best regards, Fabian

  • Hi, Does erasing with the J-Link Commander work when using the command "exec EnableEraseAllFlashBanks" (w.o. quotations)? After erasing the target with the J-Link Commander, does the problem still persist with J-Flash? Best regards, Fabian

  • Hi, Thank you for your inquiry. Could you please follow the troubleshooting article on the page linked below? wiki.segger.com/J-Link_cannot_…the_CPU#Target_connection Best regards, Fabian

  • Hi, Thank you for your inquiry. Such an issue is not known to us. 1) Could you please follow the troubleshooting article on the page linked below and send us a screenshot of the entire J-Link Commander output? wiki.segger.com/J-Link_cannot_…the_CPU#Target_connection 2) Could you please send us a J-Link log file? How to enable: wiki.segger.com/J-Link_DLL#Enable_J-Link_Log_File 3) Do you use custom hardware or an evaluation board? In the latter case which one? 3.1) If custom hardware, do you exper…

  • Hi, Thank you for your inquiry. Cross trigger functionality is not yet supported. This is planned for Q2/Q3 this year, but will only be available for Ozone initially. Does this answer your question? Best regards, Fabian

  • Hi, Thank you for your inquiry. I gave this a quick try on the "RobotDyn SAMD21 M0" evalboard and everything works as expected: forum.segger.com/index.php/Att…b338d105d74b2786978b143ec Were you able able to connect to the device before? Are you using an erased chip or is there an application running on it? As far as I can see in the guide, the reset pin is not connected to the interface. You could try to connect the reset pin to the debug port, so that the "connect under reset" can be executed. …

  • Hi, Thank you for your inquiry. Could you please provide us with the serial number of the Flasher you are using and explain to us in which exact setup you are using it? Is it possible for you to provide us with a .dat file this is reproducible with and one with which everything is working as expected? Best regards, Fabian

  • Hi Richard, This cannot be accomplished with eclipse, but you could use J-Flash for it. This requires the reset pin to be connected to the debug interface of the J-Link. In J-Flash, there is an option to start the application via reset pin after downloading the application. All information on how to use J-Flash and how to set the required option can be found in the J-Flash Manual (UM08003). Does this answer your question? Best regards, Fabian

  • Hi, We are still not entirely sure what you want to do. From what we understand: You want to use the J-Link to get to a certain point of your application. Then you want to end the debug session and have your program run from this point to (for example measure power consumption) without the debug logic being enabled. Is that correct? This is currently not possible with J-Link. We see two possible ways to get what you want: 1) Measure the Power consumption from a certain defined point, with and wi…

  • Hi, Thank you for your inquiry. Unfortunately this device does not follow the ARM specification, because it has a high CPU speed. It is the same problem as with the ATSAM70: wiki.segger.com/ATSAME70 We will implement this natively for the SAM50 devices as well, in the future. If you need it before then, you will have to set up your own J-Link Script file. Please find further information about this in the J-Link Manual (UM08001). Best regards, Fabian

  • Hi, Glad to see that you found a solution! If there are no further questions, I would like to close and archive this thread. Best regards, Fabian

  • Hi, You are welcome! Good to hear that everything is working as expected now. Best regards, Fabian

  • Hi Victor, Glad to hear that you found the source for the issue. So if I understand you correctly, this is resolved now and we can consider this thread as closed? Best regards, Fabian

  • Hi Sébastien, No worries. We will consider this thread as closed now. Best regards, Fabian

  • Hi Victor, Thank you for your inquiry. It looks like you are writing to 0x00000000, not to 0x10000000. Are you trying to download a .bin file? If so, you will have to add the starting address of where to download the file as well: Syntax: loadfile <filename> [<addr>] Example: loadfile %pathToFile%\somedata.bin 0x10000000 If this does not solve the problem: Could you please send us a screenshot of the full commander output? Could you please send us a J-Link log file? How to enable: wiki.segger.co…

  • Hi, Thank you for your inquiry. I think there is a misunderstanding here. J-Flash is not able/supposed to program RAM. Also, what ever is written to the RAM, will be lost after reset anyway. It looks to me like you have a memory dump (.hex-file) and want to program the application in it to your target. The RAM data of the memory dump was written from the target application which is placed in the flash area. Therefore, it should not be necessary to program the RAM, since it will be written by the…

  • Hi, Thank you for your inquiry. Such an issue is not known to us. Could you please tell us which XPlained Pro board you are referring to? There are multiple boards with that name. Could you please send us a screenshot of the full J-Link Commander output? Could you please send us a J-Link log file? How to enable: wiki.segger.com/J-Link_DLL#Enable_J-Link_Log_File Best regards, Fabian