Search Results

Search results 1-20 of 1,000. There are more results available, please enhance your search parameters.

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Hello, Thank you for your inquiry. Such an issue is not known to us. Could you provide more information about your setup? What version of Ozone are you using? Does it work when using the latest one? What host OS are you running Ozone on? Does the issue appear only with a specific target device or with any? Best regards, Nino

  • Hello Jean-Louis, see here for debugging dual core: STM32H745 Dual Core Development/Debugging Regarding the linker you can specify separate memory maps and linker files for both projects. Just make sure they do not overlap. More information about the linker can be found in the SEGGER Linker manual in Embedded Studio under Help->Contents->Using SEGGER Linker->SEGGER Linker user guide Best regards, Nino

  • Hello, Thank you for your inquiry. A how to debug and setup multi core projects in Embedded Studio is explained here: wiki.segger.com/NXP_LPC43xx_se…4350_with_Embedded_Studio Best regards, Nino

  • Hello, Thank you for your inquiry. Such an issue is not known to us. How did you move your application from Keil to ES? Did you use the imported or did you do the setup manually? Did you consider the following troubleshooting steps? wiki.segger.com/Port_Projects_…kbench_to_Embedded_Studio For reference could you give the CPU support package sample solution in Embedded Studio a try? 1. Install the CPU support package for the STM32F103VC series. 2. Go to Tools->Show Installed Packages->STMicroelec…

  • Hello, You are right, good catch. The Timestamps checkbox should not be there and has no functionality for tracing via trace buffer. This will be removed for the next Ozone release. Quote from thomask77: “If it's not on the same timeline, data samples and trace really should not be shown to be correlated. ” We had to find a compromise here to be able to show all graphs in one window. So this is the compromise we decided on. We will check if this can be documented better to avoid confusion. Best …

  • Hello, Thank you for your inquiry. Currently only one symbols file can be loaded at a time: [SOLVED] [Ozone] Possibility to load symbols from multiple .ELF files? But it is already on our feature wishlist so in future you will be able to load as many symbol files in Ozone as you want as long as they are not overlapping. Best regards, Nino

  • Hello Thomas, Thank you for your inquiry. 1: That is expected as with 3.10 the timeline was joined with the data graph and power graph which both have their own accurate timebase. Now with tracing via buffer there is no timestamp information available. So we chose the tradeoff here that a user can set the CPU clock in the trace settings and Ozone then approximates that each instruction is 1 cycle. This is of course rarely the case and the timeline may appear warped. In your sample the average in…

  • Hello, How to use external tools e.g. PC-Lint with Embedded Studio is explained here: [SOLVED] Installing PC Lint The file format is explained here: studio.segger.com/ide_external_tools_file_format.htm Best regards, Nino

  • Hello, Thank you for your inquiry. I assume you are using the J-Link Commander, is this correct? The J-Link Commander itself does not provide such functionality currently. But you can purchase the J-Link SDK which comes e.g. with the J-Link Commander source as reference so you can implement such functionality in your own tool. More information about the SDK can be found here: segger.com/products/debug-prob…nk/technology/j-link-sdk/ Best regards, Nino

  • Hello, Great to hear that it is working reliably with Ozone. We are happy about any new Ozone user we can win for us This thread will be considered solved now. Best regards, Nino

  • Hello Udo, Thank you for your inquiry. There are no technical restrictions in the non commercial/evaluation version of Embedded Studio. This sounds like a connection setup issue. What target device are you looking to connect to? Is it a custom board or eval board? If eval which one? Is connection working using J-Link Commander? wiki.segger.com/J-Link_cannot_…ty_using_J-Link_Commander Best regards, Nino

  • Hello, Great to hear that you are up and running again. As you correctly found out the Flash must be erased before programming new data. This is common on most Arm microcontrollers. Production Programming mode does all required steps automatically. We will consider this thread as solved now. Best regards, Nino

  • Hello, Thank you for your inquiry. True Studio is not a SEGGER product so unfortunately we can't offer support here. The J-Link in this setup is simply a receiver of commands from the IDE. So if a particular window is not doing what it should it is usually an issue with the IDE itself, so we suggest contacting Atollic support in this regard. To take the IDE out of the equation could you give our debug software Ozone a try? segger.com/products/development-tools/ozone-j-link-debugger/ It works wit…

  • Hello, We were able to fix the issue. To be notified when the new updated version of Ozone is available you can subscribe here: segger.com/notification/subscribe.php?prodid=178,7 Best regards, Nino

  • Hello, Thank you for providing the project. This is reproducible and we are currently investigating. Keep you posted. Best regards, Nino

  • Hello, Thank you for your inquiry. The default buffer size is 512 bytes. But the MTB can be configured to use more RAM if available for tracing. How to configure this is explained here: wiki.segger.com/MTB_specifics Best regards, Nino

  • Hello, Good to hear that the RTT linking errors are gone. The remaining errors are explained by the linker output. In your main.c you are using HAL functions that are undefined. Make sure to include all needed files. Please understand that we are not allowed to assist you further here as this remaining issue is not related to SEGGER products. For questions about uVision and how to setup generic projects we recommend contacting Keil support. Best regards, Nino

  • Hello Thomas, Thank you for your inquiry. Such an issue is not known to us. Could you provide an example project for reproduction? Best regards, Nino

  • Hello Markus, Thank you for your inquiry. Yes this is possible with SEGGER Linker. A how to is shown here: wiki.segger.com/Placing_extern…mbols_at_specific_address This would also work with gcc linker. However it would be about 30 lines of code instead of 3. Best regards, Nino

  • Hello Stefano, According to your map file the base address of the elf file is 0x8000000. So not sure what the error should be. If you just want to flash and debug the firmware at 0x8020000 then make sure the bootloader image is not part of the elf file. Alternatively if you want to keep the bootloader and FW in one image you can set the PC and SP in AfterTargetDownload and AfterTargetReset as explained here: wiki.segger.com/Debug_on_a_Target_with_Bootloader With the difference that you want to l…