Search Results

Search results 1-16 of 16.

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Hi Sven, attached you find: a) your required files b) example of Screenshot correct with 5.36 und a faulty screenshot with 5.50 Unfortunately I am unable to provide you a demo example. What hardware should I use? My whole project would definitely not compile in your environment.... So the thing is very simple: The instruction GUI_BMP_Serialize() can not be configured with parameters. There is nothing I can do wrong on my side. The fault is perfectly reproduceable: 5.36: OK 5.50 not OK I would th…

  • Hello to all, We updated from 5.36 to 5.50 recently. In 5.36 the GUI_BMP_Serialize() instruction works fine. With 5.50 the colors of the resulting Bitmap are pretty faulty, they have way to much of green color. We downgraded the software to 5.36: Colors are correct again. What can we do to use the latest version? Best regards Andy

  • Hello to all, With emWin 5.36, all works fine. However since we updated to emWin 5.46 the GUI_BMP_Draw() function does not display a bitmap correct anymore. It is gray with some blue curved lines in it. This is the source code of a callback function to draw the elements: void cbMsgBoxBack(WM_MESSAGE * pMsg) { u16 ScrWidth; switch (pMsg->MsgId) { case WM_PAINT: ScrWidth = InitMsgBox(pMsg); GUI_DispStringHCenterAt(strGet(Nach_MessFirst1_t), 60 + (ScrWidth-60)/2, 5); GUI_DispStringHCenterAt(strGet(…

  • [SOLVED]Pen size don't work

    Andy_AN2 - - emWin related

    Post

    Hello Jens, I had the same problem! If you draw with GUI_DrawLine() it works, but if you use GUI_DrawVLine() or GUI_DrawHLine() it doesn´t work due to some very strange reason Hope that helps Andy

  • Hello to all, I want to change the frame color of a standard framewin. I used this code in GuiConf.c: #define FRAMEWIN_FRAMECOLOR_DEFAULT 0x555555 #include "GUI.h" I expected emWin to accept this define and NOT to set it internally back to 0xAAAAAA. But it doesn´t work. How can I use the configuration options macros properly? Thanks for any help Andy

  • Hello to all, we use EmWin 5.30. When we check the map file, every available font in emWin is linked and uses memory. According to the documentation only the default font plus the additional fonts we use are linked. How can we avoid to have all the other fonts linked? Thanks a lot for help Andy

  • Problem solved

    Andy_AN2 - - emWin related

    Post

    Hello , meanwhile I found the solution for my problem. In emWin 5.22 it was not critical when I used HEADER_SetBkColor outside of the callback function of the header. The header widget obviously kept this setting , when I did a GUI_Clear in the call back function the color set by HEADER_SetBkColor was used. However in emWin 5.30 this is different. Using HEADER_SetBkColor has no effect. I must use GUI_SetBkColor() before using GUI_Clear() in the callback routine to have the background color prope…

  • Hello to all, In my application I used emWin 5.22. I have a ListView and I set the background color of its header with HEADER_SetBkColor(). Everything works fine, no problem. But with emWin 5.30 I am not able to set header background color with HEADER_SetBkColor anymore. The color is always black. It also does not work with GUI_SetBkColor() in the header callback routine. But setting the Header Text color works fine at the same places where I try to set the header background color. So why can I …

  • Good Morning, Adrian thank you for your answer! Actually I just found it in Widget_Edit.c by myself..... Please One question with blinking cursor. I use MDK_ARM from Keil with RTOS. The RTOS provides timer functions. In order not to interfere with RTOS I did not configure GUI_X_GetTime() in emWin. How can I get a blinking cursor in this environment? Have a nice day Andy

  • Hello to all, I have a very simple problem: I want to show the static default cursor in the Edit widget without any blinking. I use emWin 5.22. The Edit widget contains and displays 3 characters already. The source: hEdit = EDIT_CreateEx(10, 5, MaschNamePixelWidth, 30, hClientWin, WM_CF_SHOW,0,0,MaschineNameLen); EDIT_SetFont(hEdit,StdFont); EDIT_SetText(hEdit,&M[MIdx].Name[0]); //von der aktuellen Maschine den Namen anzeigen EDIT_SetCursorAtChar(hEdit,2) The text is therafter displayed correct …

  • Hello all, I use: GUI_SetLineStyle(GUI_LS_DASH); GUI_DrawVLine(100,0,50); However the line is continous. I read back the LineStyle, it is 0x01 = GUI_LS_DASH What can I do in this case? best regards Andy

  • Hello Adrian, thanks for your reply. I think the case is very simple. The GUI_BMP_Serialize() does NOT take care of color conversion table setting! It seemes to fixed to GUICC_M565. I have emWin 5.22 I provoke the fault like this: With setting COLOR_CONVERSION GUICC_M565 both LCD and BMP-Output have the same colors. (I just swapped my colors manually to work correct with this) Then I change the setting to COLOR_CONVERSION GUICC_565: the LCD has blue and red swapped but the BMP-Output is still th…

  • Hello Adrian, I know the different color conversion tables GUICC_565 and GUICC_M565. I explain my problem again: When I work with built in colors from emWin like GUI_RED a have to work with GUICC_M565 to have the color shown as red. So far so good. But I after a while I got external colors supplied from a designer. These colors are from common color schemes available elsewhere in the world. When I implemented these colors I realized that Red and Blue was swapped in the LCD. Therefore I changed c…

  • Hello to all, I have a general problem regarding the color definintion in emWin 5.22. In gui.h the standard colors are defined. for example: #define GUI_RED 0x000000FF However, everywhere else in the world Red and Blue is swapped that means plain Red should be: #define RED 0x00FF0000 Here a link to common color definitions: en.wikipedia.org/wiki/Web_colo…erting_RGB_to_hexadecimal Why is emWin 5.22 doing it the other way round? However I solved the problem in using the GUICC_565 color conversion …

  • Hello Adrian, thank you for your answer regarding the return value of WM_SelectWindow(). Using WM_GetActiveWindow() I verified that the active window is actually the client area of the frame window. So WM_SelectWindow() works. But the framewindow is still displayed only with headline in the header window but no text in the client area. I managed meanwhile to get the text into client area with callback functions. But this a lot of code overhead for doing this simple job. I would very much appreci…

  • Hello together, I just want to write some text in the client area of a frame window. The parent of the frame window is WM_HBKWIN (Desktop). I first retrieve the handle of the client window and therafter set it as the active window to receive text: handle = WM_GetClientWindow(hFrameWin); //at this stage the handle of the child of framewin (client area) is valid handle = WM_SelectWindow(handle); //at this stage the handle equals to WM_HBKWIN!! GUI_DispStringAt("Text",10,180); However the WM_Select…