Search Results

Search results 1-20 of 36.

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Ozone FreeRTOS Awareness Issues

    TxCodeMonkey - - General

    Post

    Please checkout forum.segger.com/index.php/Thr…n-Segger-Embedded-Studio/ cheers, thomas

  • Nino, I hit upon the slowness in SES again. It is in a project that we have not been concentrating on much, as it was fairly stable. We are working with a nRF5252840 and the project in question is our modified bootloader/DFU. (SES 4.22 and up to date Windows 10) I see the following a fair bit. forum.segger.com/index.php/Att…f4616081b3139751c117824f8 Now the thing is, I can't seem to find that memory range in the nRF52840 specs or in my project files, or in the nRF52 SDK. Any guidance would be ap…

  • Nino, Glad to hear the let you out of the office I very much appreciate your work on this board. Thanks to your management team for allowing you to have the time to participate this broadly with your user community. cheers, thomas

  • Nino, in the middle of a few things, but I just checked and the delta seems to have tightened up a bit. My PC has been rebooted since I first posted. I will collect more data when I can, and give a better test case that you should be able to reproduce. Many thanks, thomas

  • Hello, again, this is not a large issue. Using OZone 2.70, on Windows 10, attached to a JLink -Ultra +, when the target is disconnected (power loss) during an active debug session I can not exit OZone. Even when answering in the affirmative if I want to leave the session, I have to go to the task manager to stop the process. thanks again for your consideration, thomas

  • awneil, I fully understand that. I was referring to errors that do have specified line numbers. The context of my previous comment was centered around cursor/window focus in general, and not in terms of exact linker errors.

  • Nino, We missed you, hopefully your time away from the forum was good. As always, thank you for your response. I also like the task view, but it is not clickable on the error. In general, it would be cool if there was a bit more precision with cursor focus. I have, in effect 3 monitors. The compilation output view is in a separate window on a different monitor than the primary window. When you click on an error, if would be cool for cursor/mouse focus to be moved to the primary window at the lin…

  • Hello, I use SES feeding into OZone, and one of the issues that I stumble upon occasionally is when I Windows switch focus to OZone when SES is linking OZone crashes. I do have auto re-program turned on. Windows 10 and the latest revisions of SES and OZone. I will say not having to switch SES from editing tool to debugger and back saves a significant amount of time. IDE's might be good, but switching modes from development to debugger is a waste of time.

  • I found to get consistent results with the nRF52 and RTT I had to change the following definition to 0. #define NRF_FPRINTF_FLAG_AUTOMATIC_CR_ON_LF_ENABLED 0 We here are using the NRF_LOG* calls and have made the SEGGER upgrades. edit: I will add, the primary reason for the change was to remove additional blank lines from the terminal in OZone. We do not add \n to the log output.

  • awneil, take a step back and look at the bigger picture. The linker is properly creating the CORRECT errors. Yes, the linker has it correct. The problem is SES is not displaying the error in a easy to see manor. I have no idea why you are over reaction to an obvious error in my code. The original cause for my hunt was a missing typedef. And this the linker assumed I was trying to create an overlapping variable in multiple object files. Again, the link did the correct thing. Have a tool simply sa…

  • While appreciate being pedantic, my code example clearly did not have the extern qualifier.

  • One of the things that I've noticed is linker errors tend to be pretty stealthy. In this case I accidentally added the declaration of a variable in an include file that was included in 10 files. I reproduced the issue with adding the following to that header. Source Code (1 line)This is the output. You have to turn on "Show build info" and "Echo command lines" to get that amount. forum.segger.com/index.php/Att…f4616081b3139751c117824f8 Otherwise, you get the following forum.segger.com/index.php/…

  • Hello, I updated to SES:4.22 and OZone 2.70 and I am still seeing an issue where debugging is significantly slower. And by slower, I mean, in OZone when you press F5,F11, or F10 it instantly acts, and you hit the next breakpoint or goes to the correct statement. In SES it can take a few seconds, especially F5 (go). I am running an up to date Windows10 Pro (Version 10.0.17763 Build 17763) system with 16G RAM with about 8GB physical memory free. I am using a JLink Ultra+. Any clues on what to look…

  • I should add, here is some information about SWD multi-drop, not chaining. About 3/4 down the page developer.arm.com/docs/ddi0480…dp/jtag-and-swd-interface

  • Hello, we are preparing for production, we've done some searching and have hints of daisy chaining SWD targets. But have not hit with anything specific. Hoping someone here can me with the definitive answer to the questions 1) Is it possible for the nRF52840 to be chained with SWD 2) Is the J-Link capable of chaining SWD many thanks, thomas

  • Quote from awneil: “This has come up a few times before. One thing that I've found to "release" it is to unplug any dev kits or J-Links ... forum.segger.com/index.php/Thr…Power-Fail-Unrecoverable/ forum.segger.com/index.php/Thr…uilding-in-the-Title-Bar/ forum.segger.com/index.php/Thr…-failed-attempted-at-GIT/ ” Awneil, interesting, if/when it happens again, I will try unplugging the J-Link. There must be something in Windows 10 [and possibly Lenova], I have seen other hangs with USB. But only wi…

  • I'm still having the intermittent issue where SES locks up, and when I go into the task manager and attempt to restart SES I get forum.segger.com/index.php/Att…f4616081b3139751c117824f8 So far the only remedy appears to remove the SES configuration directory and reboot. Please let me know what I need to capture to assist you in determining the root cause. As well, I must admit, I am rather intrigued at what SES is doing that resetting the system appears to be the only solution to this. Temporary…

  • Please pass along the URL to the Ozone forum?

  • Nino, Again, thank you so much for listening to us. I, for one, really appreciate how responsive y'all are to the customers! On topic, in Ozone, 2 simple things would be awesome in my daily life. And of course, if they are there, but can't find them, please point me in the correct direction. 1) Add the keyboard short <ctrl>-W to close the current source file tab. Currently you have <alt>F4, but that is not standard, and I can not find a way to change that. 2) As with the "Source Files" view, it …

  • Nino, thank you. I don't have time today, but I will add more detail, hopefully, tomorrow. cheers, thomas