Search Results

Search results 1-20 of 1,000. There are more results available, please enhance your search parameters.

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • ST-Link On Board feedback

    SEGGER - Nino - - General

    Post

    Hello, Thank you for your feedback. We will discuss this internally and improve the tool where needed. Best regards, Nino

  • Hello, Thank you for your inquiry. On the J-Link EDU Mini you will find a 1 printed next to the header. This is the side Pin1 is on. On your cable you will find a red marking. This is also the side where Pin 1 is located. If you match them you should not have any orientation issues. The debugger should not be damaged by flipping the debug interface. The target device might depending on the board design. Best regards, Nino

  • Hi Joe, quick update. The latest J-Link software version should have not fixed return values for SetupTarget. Best regards, Nino

  • Hello, Thank you for your inquiry. The App Core is currently not supported as it is not directly accessible via the debug port. Only Com core is supported. Best regards, Nino

  • Hello, This is still *not* at support forum! Please familiarize yourself with the forum rules before posting. Bumping threads will only slow down our answering process as threads with oldest activity will be answered first. So you are really not helping yourself here. If you have a valid support request and are in support period with the affected SEGGER product feel free to open a support request via our official support channels. You can find all needed information in my signature. If your prod…

  • Hello, Thank you for your inquiry. We were able to reproduce the behaviour and are working on a fix. The return value for SetupTarget is indeed not being evaluated at the moment. Sorry for any inconvenience caused. Best regards, Nino

  • Hi Alex, Quote from almost_linear: “Do I need to populate the SEGGER_SYSVIEW_X_GetTimestamp() function instead of using the DWT (0xE0001004) cycle counter on its own? ” This is optional. The cycle counter is usually accurate enough. If I understand correctly you worry about the measurement of 3 us instead of 0.5 us. This is expected. As written on our website the overhead for a RTT write is ~1us. When entering and exiting an ISR you have two write commands. Now put in the mix that some more data…

  • Hello, Thank you for providing the Commander Session. It appears that your application has write protected parts of the Flash memory which leads to the error behaviour. We will investigate if we can improve our Flash algorithm so it can clear such locked areas. This will most likely be added with the next couple of J-Link software versions. To stay up to date you can subscribe here: segger.com/notification/subscribe.php?prodid=7 Generally we recommend not to lock your device before debugging is …

  • Hello, The generic components are usually detected automatically by J-Trace PRO via the ROMTable. But the ROMTable for this device seems incomplete so it needs to be added manually. Such an example script can be found attached. Keep in mind that the addresses you use must be accessible by the DAP. Otherwise the device might crash during initialization. You need to set ETB, ETM and TPIU base address so the generic init can work. Unfortunately the target device reference manual does not specify wh…

  • Hello, Thank you for your inquiry. Such an issue is not known to us. If you did not change your setup and your application everything should still be working. For the unlock to work the reset pin must be connected to J-Link. Could you check if the reset line is correctly wired? Should that still not work could you provide a J-Link log file for investigation? wiki.segger.com/Enable_J-Link_log_file Best regards, Nino

  • Hello, Thank you for your inquiry. The Mediatek 6765 is currently not supported by J-Link: segger.com/downloads/supported-devices.php As such chips are usually not designed to be debugged by a external debug probe but rather to have a Linux running on top of it there are currently no plans to add support for this particular device. However you can try to add support yourself. I assume that the error message comes from some targetspecific init steps needed before the core can be accessed. This ca…

  • Hello, Thank you for your inquiry. Try "power off perm". This is usually the default J-Link is shipped with. Just make sure to not do a power on at some point again and the power supply pin will stay low. Best regards, Nino

  • Hello, Great to hear that you are up and running again. When updating J-Link software make sure no software is open that is using the J-Link dll. Otherwise the installation will partially fail. To solve the eclipse issue try running the JLinkDLLUpdater again while Eclipse is closed. Then the DLL should reappear. If that does not work simply copy the JLink dll to the eclipse installation folder where it was before. Best regards, Nino

  • Hello, We received your inquiry via our support system in parallel as well. Please do not use multiple different channels for the same topic when communicating with us as in the worst case this will lead to lost information between the channels and a slower response time. This thread will be closed now and the topic will be continued in our support system. For everyone else stumbling across this thread: - The attached picture does not show any trace pins as the picture shows a Arm 20-Pin debug h…

  • Hello, Thank you for your inquiry. Such an issue is not known to us. Could you verify functionality with J-Link Commander? Try the following sequence: connect reset halt erase loadfile "path to hex,bin etc." Does this work? If not could you provide a screenshot of the session? Best regards, Nino

  • Hello, Thank you for your inquiry. I just tested the latest J-Link software package for Windows. After installation all usual files could be found in the install folder including JLinkARM.dll and RTTViewer. So it appears that either the download of the installer was not successful on your PC or the installation could not be completed correctly. To verify the validity of the download package you can download the MD5 signature of the file and compare it to your downloaded file with our validity ch…

  • Hello Jose, Automation features are reserver to our professional debug probes of J-Link Plus or higher. J-Link EDU does not come with that feature set as such functionality is usually not needed in a educational environment. Best regards, Nino

  • Hello, Thank you for your inquiry. The other thread was abandoned due to inactivity of the OP. So far issues regarding GDBServer and SVC were not reproducible or the solution was outside of our softwarere. Nonetheless if you can provide us with a reproducer that works out-of-the-box on an eval board we could take a look. Could you provide a J-Link log of a failing session? wiki.segger.com/Enable_J-Link_log_file Does the issue appear when using Ozone instead? segger.com/products/development-tools…

  • Hello, Quote from kvn: “OK, that's good, but the MCO output of ST-LINK is in high impedance too and does not feed the STM32H743 MCU with HSE clock! I checked it. It's really true. How to debug app in this case? ” Please refer to ST Support in this case as this is not our product. As it stands for now ST informed us that there is no need to provide us(SEGGER) with information and the license to reflash the ST-Link V3 as all boards allegedly can be used with an external probe. Should that not be t…

  • Hello, Thank you for your inquiry. As user grantch stated the target device is supported with the Flashs listed. So programming should work. If debugging works in Flash depends on the target specifics. This information can be found in the target specific reference manual. Best regards, Nino