Search Results

Search results 1-20 of 26.

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Hello, The J-Link RTT Viewer does not support character encodings other than ASCII. Currently, there are no plans to support other character encodings. You may create your own application which interprets RTT data to suit your own needs. This can be done by using a) the TELNET channel of the J-Link software, for more information please refer to wiki.segger.com/RTT#TELNET_channel_of_J-Link_software or b) the J-Link SDK, for more information please refer to segger.com/products/debug-prob…nk/techno…

  • Hello, We found the issue that caused RTTClient to fail when connecting to a running J-Link debug session. We have fixed this internally already. A release version of the J-Link software package that contains this fix is planned for Friday this week (19th July). Thank you very much for your patience and for reporting this issue.

  • Hello, We are aware that the current version of the J-Link RTT Client is not working correctly on Ubuntu. We are working on a fix for this as of right now. I will get back to you as soon as I know when a fix for this will go live. Sorry for any inconveniences caused by this.

  • Hello, Quote: “when i connected my j-link after upgrading to 6.46 the fw was updated too, could have defected it maybe ? ” No, I do not think so. If you can't see logs (I assume you are talking about RTT output) in any of our software, this may have several reasons. In order to investigate this behavior, could you please answer the following questions? 1) Did you make sure that your target is running an application that makes use of RTT? For example, using SEGGER_RTT_printf(..)? 2) Are you using…

  • Hello Jacob, You are right, that behavior is not intentional and it has been fixed already. It was caused by the different behavior, depending on where the application was executed from. This will be fixed with the next release of the J-Link software package. Stay up-to-date regarding J-Link: segger.com/notification/subscribe.php?prodid=7,94

  • Hello Jacob, Could you please tell me how you start the J-Link RTT Viewer? I was able to reproduce the error you describe when executing the J-Link RTT Viewer from a directory which is different from the directory that the J-Link RTT Viewer resides in. Have you tried executing the J-Link RTT Viewer from its directory? For example by calling cd [...]/JLink_Linux_V646g_x86_64/ ./JLinkRTTViewerExe

  • Hello, Thank you for your inquiry. We are sorry to hear you are having issues with one of our products. Are you referring to the [...] button for "Specify Target Device" (Please see the attached screenshot for reference)? I just tried this on ubuntu 16.04 and the device selection dialog worked as expected. Same goes for ubuntu 18.04. Could you please tell me if you do anything else before clicking the [...] button, or do you just open RTTViewer and click the button immedieately?

  • Hello maximevince, Sorry to hear that you are facing issues with our software. Could you please tell me which application exactly you are referring to? You are mentioning JLinkExe (J-Link commander) as well as RTTClient. The thread you linked to refers to the RTTViewer. Additionally, could you please tell me what you are doing with that application (e.g. what do you do to see the "slow" behavior?). Thank you very much in advance and sorry for any inconveniences caused by this.

  • Hello Joe, Thank you for your inquiry and for reporting this issue to us. Your command line is correct. A bug was introduced with the most recent version (V6.46d) that causes --autoconnect to crash the RTTViewer. This bug has already been fixed internally. The fix will be part of the next release of the J-Link software package, which is planned for Friday this week (14th June 2019). We are sorry for any inconveniences caused by this. If you are interested in a preliminary version of the J-Link R…

  • Hello kjhuebner, Thanks for your reply. It's great to hear that you are up and running now. Thank you very much for the feedback on the J-Link RTT Viewer.

  • Hello kjhuebner, Thank you for your inquiry and your feedback regarding the J-Link RTT Viewer. Could you please tell me which version of the J-Link RTT Viewer you are using? Recently, there have been a couple of updates and improvements regarding the output speed and more of the RTT Viewer. One of those updates included the change from word-wrap to a horizontal scrollbar. Could you please give the current version of the J-Link RTT Viewer (V6.44i) a try? You can find the download here: segger.com…

  • Hello rum, I am glad to hear that you are up and running now. We're aware of the manuals being misleading in this way and will improve them in the future.

  • Hello rum, In the command line that you posted, you are using a different symbol than an ASCII minus. If you look closely: forum.segger.com/index.php/Att…4fd65bd88ba141cbd7f4846ff You can see that those symbols are different, which is why they were parsed incorrectly. Could you please make sure to only use the standard ASCII minus symbol (0x2D) for command line parameters? Here is a corrected version of your command line: "C:\Program Files (x86)\SEGGER\JLink_V642\JLinkRTTViewer.exe" --autoconnec…

  • Hello rum, I asked for a screenshot to ensure that there are no typos or similar in the command line, but I can exclude this now. I know you are using multiple J-Links, thank you for the heads-up. We highly appreciate you using our products. I managed to reproduce the issue you are facing and am currently trying to pinpoint the exact issue. As soon as I have a fix or work-around ready, I will get back to you. I expect to find and resolve the problem tomorrow. Thank you for your patience.

  • Hello rum, Could you please attach a screenshot of the entire command line that you use to start the J-Link RTT Viewer? Thank you.

  • Hello rum, You are correct. That dialog should not appear when using the command line option "--autoconnect". The bug regarding an "unspecified" script file has been fixed with the current version of the JLinkRTTViewer. Could you please give the current version, V6.42, a try? segger.com/downloads/jlink/#J-…twareAndDocumentationPack

  • Hello rum, Sorry for the delay in response. I tried reproducing the error you are facing, with no success. The setup you described worked on my end: - Connect to J-Link via J-Link commander (you are using a debugger) - Start JLinkRTTViewer with "--autoconnect --serialnumber <S/N> --connection sess" --> JLinkRTTViewer starts without any additional dialog and attaches to J-Link using the existing session Quote: “I cannot get passed dialog window ” Exactly which dialog are you referring to? a) The …

  • Hello rum, Thank you for your inquiry. Sorry for the delay in response. Currently, the command line parameters for the J-Link RTT Viewer support the use of one dash for the abbreviated version of a command line option (e.g. -a for autoconnect) as well as the use of two dashes for the written-out option (e.g. --autoconnect for autoconnect). Could you please try the following command line? "C:\Program Files (x86)\SEGGER\JLink_V640\JLinkRTTViewer.exe" -–autoconnect --serialnumber <YourSerialNumber>

  • Hello jev, Thank you for your inquiry and sorry for the delay in response. Could you give us an example of the issue that you are describing (e.g. a brief recording of RTTViewer and a code snippet producing the RTT data)? This behavior is definitely not intentional, 72 samples/sec should be displayed rather quickly using the J-Link RTTViewer.

  • Hello Wolfgang, Yes, this behavior is known. At the moment, the current way of handling formatted data is slowing down the output rate. We are working on improving this handling and increasing the update speed that way. J-Link RTT Viewer V6.32i can be used as a temporary workaround. We are sorry for any inconveniences caused by this.