Search Results

Search results 1-9 of 9.

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Hi Sven, Thanks for your responses. My BSP_TS_GetState() always returns the last 'touch' position, so when the button is released, it will always be the last touch position. However, you pointed me to the solution. The touch driver starts returning a very large Y value after 60 seconds or so, so it will never match a button on the screen. I still don't know why the touch driver is acting up, but I'll find it. Thanks again for your help, Lee

  • k_TouchUpdate() is called in a timer IRQ every 100ms or so. C Source Code (35 lines)

  • Hi Sven, Not sure what you mean about a short example. Do you want me to post the project as a zip file? I have cut it down considerably, but it still compiles out to a 234K image. It includes FreeRtos and a number of ST libraries for SDRAM, touch screen, etc. Two things. 1) The same source code (the full one), works when compiled with the IAR compiler. 2) It seems that I get both CLICK and RELEASE notifications during the first 65 seconds or so, but after that, only CLICK (along with some other…

  • After a little more checking, I found that if I bring up a dialog box with an OK and Cancel button, and then just let it sit for a minute, the first message I get when I press either OK or Cancel is WM_PID_STATE_CHANGED, followed by WM_TOUCH and WM_MOUSEOVER_END. The dialog box remains displayed (no WM_DELETE). Then I press the Cancel button and get WM_NOTIFY_PARENT, WM_NOTIFY_PARENT, WM_NOTIFY_CHILD_HAS_FOCUS, WM_NOTIFY_CHILD_HAS_FOCUS, WM_TOUCH_CHILD, WM_NOTIFY_PARENT, WM_TOUCH_CHILD, WM_NOTIF…

  • After porting a project from the IAR environment to the Atollic Studio environment, I have run into an odd problem that I'd like to solicit your advice. When the project starts, the touch screen works fine, with the IRQ calling GUI_TOUCH_StoreStateEx() with new coordinates and evrything works fine (I receive the correct button press messages). After about 65 seconds (I've timed this many times), the touch IRQ continues to call the GUI_TOUCH_StoreStateEx() function with new coordinates, but I get…

  • Hi Sven, That did the trick, thanks! Although I found that at least in my setup there are two definitions of GUI_USE_ARGB - one in GuiConf.h and the other in GuiConfDefaults.h. I had already changed the one in GuiConfDefaults.h, but I guess I missed the one in GuiConf.h - or maybe it was the other way around. At any rate, I'm happy. Thanks, Lee

  • This sounds like an interrupt handler problem. I had a similar issue and resolved it, but I don't really remember what I did. It does seem that it had to do with the interrupt handler for the touch screen driver. Good Luck, Lee

  • Hi, I hope you can help with this. I am having trouble selecting the correct drivers and color conversion configuration. It seems no matter what combination I try, something is wrong. I am using the LTDC_PIXEL_FORMAT_ARGB8888 pixelFormat specifier on my layer config, and the driver library is the STemWin_CM4_OS_wc32_ot.a or STemWin_CM4_OS_wc32_ot_ARGB.a driver. The GUI_DRAW_BMPM8888I Bitmap was created with CVTBMP 5.44 using the True Color with Alpha, r/b swapped, alpha inverted option The GUI_D…

  • Hi, I am re-creating an old stemWin project, written using IAR by programmers no longer with the company, to the Atollic TrueStudio. I used CubeMX to create a simple window based on the Discovery32F429I board, which is a single layer, 565-based setup. I then modified the project drivers to work for my larger, 2 layer board. The "Hello World" displays fine, but I have the following issues. 1. I can't seem to get anything to display on layer 1. If I use GUI_SelectLayer(1) before writing, it does n…