Search Results

Search results 1-20 of 1,000. There are more results available, please enhance your search parameters.

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • SAMA5 ETB trace

    SEGGER - Nino - - J-Link/Flasher related

    Post

    Hello, I moved the inquiry to a new thread as this question is not related to the other. Both J-Links support ETB trace on the SAMA5 target device. Do you get any error message? Which version of Ozone are you using? Do you get any error messages? Best regards, NIno

  • Hello, Quote from DawidS: “I know Ozone - the last version I used didn't had the ability to search in ETM Trace log which made Ozone almost useless for us ” Could you elaborate how you can do this in Keil? I just tested the latest uVision version and their instruction trace window was not searchable whatsoever. If you are looking to dump the trace data and search it with an editor or similar you can do so in Ozone by right clicking the instruction trace data in the instruction trace window and s…

  • Hello, Thank you for your inquiry. 1: Will be fixed in a future SystemView source release. 2: Is not reproducible with the currently available SystemView sources: segger.com/downloads/jlink/systemview_target_src Which version are you using? Quote from rise.cai: “If the LGPL license will protect the sample.c and config.c under SystemView/Sample and SystemView/Config doc? ” You can find the licensing terms in the files headers. Quote from rise.cai: “Is there a way to fix the BUG by myself? ” Curre…

  • Ozone on debian buster segfault

    SEGGER - Nino - - General

    Post

    Hello, Attached you can find an example SWO project that contains an Ozone project which will output the SWO stream in Ozone terminal. Could you give that a try? I tested it with our STM32F103 Nucleo Board that we have in house and everything is working as expected. Best regards, Nino

  • Hello, Thank you for your inquiry. Happy to see your interest in SystemView. Currently we do not offer a public repository for collaboration and there are no plans to add such an interface. So the correct approach for now would be to either post us your suggestions in this forum or contact us via e-mail etc. and we will review them between our projects. Best regards, Nino

  • Hi JLuc, Thanks for verification. This explains why the build is failing with the new version as the new Linker script is referenced now where the regions are renamed to be more consistent. By adjusting the memorymap file or memory segments settings in your project as described above should fix this issue. Best regards, Nino

  • Ozone on debian buster segfault

    SEGGER - Nino - - General

    Post

    Hello, Great to hear that you are up and running again. Quote from billium: “If I can find out how I'll mark as solved. ” Don't worry I will take care of it. Quote from billium: “One point though, if I use JLinkSWOViewer I can see my ITM_Print(0,"hello") but although the terminal now has 'SWO Active' I do not see anything when the processor is running. (All it is doing is sending ITM print messages every second) ” All you have to do is enable SWO in trace settings in Ozone. Make sure that the st…

  • Hello, We received your inquiry vie our support system as well. To keep all information at once place this thread will be closed now. Best regards, Nino

  • Ozone on debian buster segfault

    SEGGER - Nino - - General

    Post

    Hello, Thank you for your inquiry. The issue should be fixed with Ozone V2.62f. Could you give it a try? Best regards, Nino

  • Hi, G4 support will be added with the next J-Link software beta planned this week. To get a notification when it is available you can subscribe here: segger.com/notification/subscribe.php?prodid=7,94 Best regards, Nino

  • Hello, Thank you for your inquiry. The J-Link software package for ARM hosts comes without support so please understand that we can't put time into this issue. Alternatively we recommend using an external PC that is connected to the Raspberry via Network and use a Telnet Client on the external PC to access the RTT data via port 19021. To enable this RTTTelnetAllowNonLocalClient must be set in the Raspberry instance. More information can be found in the J-Link user guide UM08001. Best regards, Ni…

  • Hi, We have now ordered the boards and will investigate this when they arrive. Best regards, Nino

  • Hello Long, Please understand that we can't assist you further here as it would leave the assist scope of our forum as it is user responsibility to debug user made setup issues. We provided you with a working example project for reference which you can use for further investigation. Best regards, Nino

  • Hello, Quote from Asinus: “Where do I have to correct this? In an existing file or in project optinons or where? ” You can do so in the project options in category Linker. There you can right click the entry and select open. Or if you right click your project in the project explorer in the context menu you should see "Edit Linker Script" at the bottom. EDIT: Sorry this was how to edit linker scripts but they are correct. You need to edit the memory map or memory segments settings instead. In pro…

  • Hello, Thank you for your inquiry. It is possible that some markers are missing from the elf files depending on the compiler version. Could you provide the elf file for reproduction? Best regards, Nino

  • Hi Ewout, Thank you for your inquiry. Currently the conversion tool is not available for ST-Link v3. The reason is simply because there was yet no eval board out there that had a ST-Link V3 on board. This seems to be the first board to our knowledge. I tried to find it in the usual electronic supply shops but it seems like it is not available publicly yet. Could you point us to the shop where you purchased it from? We will then order some and see if the conversion tool can be expanded. Best rega…

  • Hi, Thank you for providing the project. With it the issue was reproducible. It will be fixed with the next Embedded Studio release. For now try not to merge strings. Sorry for any inconveniences caused. Best regards, Nino

  • Hello, Thank you for your inquiry. Such an issue is not known to us. Do you have string merging enabled in project options under Linker->Merge String Constants? If yes could you disable this and report back if that changes anything? Could you provide an example project for reproduction purposes so we can investigate if the Linker behaviour can be improved? Best regards, Nino

  • Hello, Thank you for your inquiry. Was this an existing project or did you create a new one? If you created a new one could you tell us which steps you took? To correctly solve this issue check your memory map or memory segments projects option (depending on which you are using) and make sure that FLASH is renamed to FLASH1 and RAM to RAM1. Best regards, Nino

  • Hello, Thank you for your inquiry. This behaviour is expected as Cortex-M targets only support data breakpoints with masked conditions e.g. ==. So this is unfortunately a limitation of the target device you are using as explained in the Embedded Studio manual. Best regards, Nino