Search Results

Search results 1-15 of 15.

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Program hang at GUI_Exec1()

    rowel - - emWin related

    Post

    Hi. It looks like this memory related program crash (hard fault) has finally been fixed. For the sake of those that may encounter the same problem, we now have a stable system by changing the GUI_LANG_GetText() calls into GUI_LANG_GetTextBuffered() calls. We have a limited (640K internal) memory but a lot of text resources, and GUI_LANG_GetText() seems to be eating the remaining memory. Best Regards, Rowel

  • Program hang at GUI_Exec1()

    rowel - - emWin related

    Post

    Hi. We implemented the Bus Error Interrupt routine to handle invalid memory access. From a different screen (so maybe this is from a different cause), we had the following backtrace. --- bus_error_isr() GUI_ALLOC_LockH() GUI_MEMDev_Delete() WM_InvalidateDrawAndDescs() WM_invalidateRect() --- As with the previous backtrace, the issue cannot be reproduced 100%. Sometimes it works, sometimes it doesn't. I hope someone can give me a hint. Thank you very much. Best Regards, Rowel

  • Program hang at GUI_Exec1()

    rowel - - emWin related

    Post

    Hi. I received the following backtrace information from an engineer working with the project. --- _$_RemoveHoles() _$s_a_memory$1() /* function pointer? */ _$s_a_memory$1() /* function pointer? */ 0x01 GUI_ALLOC_GetFixedBlock() GUI_LANG_GetTextEx() <application function> APPW_ProcessActions() WM_OBJECT_WINDOW_cb() --- Anyone have any idea? Best Regards, Rowel

  • Program hang at GUI_Exec1()

    rowel - - emWin related

    Post

    Hi, We are testing a GUI application created using emWin(v6.26c)/Appwizard on a Renesas RX65N-based board . The program freezes at GUI_Exec1() and we don't know the reason why. The GUI application itself has no problem using the windows simulation environment (compiled using Visual Studio 2022). The MaxUsedBytes for this application shows around 25KB for the simulation environment. The Renesas RX65N-based board configuration is set to use(EMWIN_GUI_NUM_BYTES) 40KB for emWin and the MaxUsedBytes …

  • Hi Sven, With the latest version of AppWizard (V138_632d), I can confirm that the sample code is working (bitmaps are changing). Very nice. Unfortunately, I'm stuck with the older version. But I hope those who can use the latest version (including the future me) will find this info helpful. Thank you very much. Best Regards, Rowel

  • Hi Sven, Thank you for the reply. I tried to run your sample code using the following environment, but the images does not change on TIMER signal. (The TIMER signal itself runs and so is the slot routine) Environment: --- AppWizard V1.24_6.22 Microsoft Visual Studio Professional 2022 (64-bit) - Version 17.4.4 Windows SDK Version 10.0.22000.0 Platform Toolset v143 --- I also tried to add a button that will do the same job, but I got the same output. Does the APPW_DoJob() API work for older (V1.24…

  • Hi everyone, I would like to know if there is any special procedure to create an "alpha channel, compressed" image format. I created a sample application to test this format but there was a problem when setting the color to black. The play function of AppWizard shows the expected output (left : black triangle, right : white triangle). forum.segger.com/index.php/Att…0ef05d39cdef2aa4b5384fe14 But running the same application inside Visual Studio simulation shows the left black triangle with just a…

  • Hi everyone, I'm using AppWizard for an embedded application where an image object's bitmap (10 patterns ) will change after some specific signal. I'm using 10 separate interactions (Job = SETBITMAP) for that, each checking for an appropriate condition using code. Now, the image object must also be initialized depending on settings. I would like to avoid using another 10 INITDIALOG interactions (with the same Job and condition as above). Is there a way to use a common function to set bitmap? Can…

  • AppWizard Runtime Error (SimError)

    rowel - - emWin related

    Post

    Hello Florian, Many thanks for your prompt reply. We are using AppWizard V128c_6.26c (Compiled 14:2208 Jun 8 2022) included in Renesas FIT Module (for RX65N). I think I found the problem (but not the reason). It seems to be related to the alignment setting of a particular Text Object. That particular object was connected (concatenated) to another text object previously but is now pointing to another object. I changed the alignment setting and it is now working again. Thank you for all your suppo…

  • AppWizard Runtime Error (SimError)

    rowel - - emWin related

    Post

    Hi. My simulation environment (Windows 10) is now displaying an error message showing the following. "Disposing does not work in _DisposeWindow()." forum.segger.com/index.php/Att…0ef05d39cdef2aa4b5384fe14 I would appreciate it if someone can tell me the reason for this problem. Thank you very much. Best Regards, Rowel

  • Hi. I have read the AppWizard manual and it seems like if you want to control an AppWizard object's properties (other than text and values) from code, you have to use AppWizard's Variables. It's useful on simple applications, but I personally believe that method won't scale on large embedded projects. Some AppWizard objects like Button is said to be similar to emWin button widget but it's not clear if you can use the Window Manager (WM) APIs on them. Is there any document where I can find the in…

  • Hello Sven, Thank you for the very specific answer. Very helpful Best Regards, Rowel

  • Hi, I'm using a library version of emWin, but I would like to ask if there is a way/option to make emWin use an external SDRAM instead of internal RAM. For the application part, I think I can use compiler/linker options (#pragma or something). Thanks in advance. Best Regards, Rowel

  • Hello Florian, Thank you for the reply. Since texts will always be in English language and there will be a lot of text, I'm planning to implement it like the following. - For the screens that support multiple languages, I will set the application language dynamically based on the user selected setting. - For the screens that are fixed to English language, I will set the application language to English. Do you think there will be any problem with this approach? Best Regards, Rowel

  • Hi. I'm evaluating emWin/AppWizard using a Renesas board. I have a case where strings (text) will always be shown in English regardless of language settings. When using AppWizard it seems like I need to add the same text for all languages. Is there a default language/text concept in AppWizard where the default will be used when text from other languages are not defined? Thanks