Search Results

Search results 1-10 of 10.

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Is there a way to invoke the "Edit/Format" command on a file from outside of SES? Is there a command line function (similar to emBuild) that can be used for this? I'd like to use the formatting feature on a regular basis on all the files in a solution, making clicking on the menu selection or using the keyboard shortcut on each individual file impractical. Russ

  • Nino, You missed the point of the question. To get a license file, I must first provide a MAC address to which it will be locked. If a PC has multiple MAC addresses, how do I determine which one to provide? Russ

  • We are using node-locked licensing for our multiple copies of SES. Unfortunately, many of the PCs have more than one ethernet port, and thus more than one MAC address. I've seen one PC with FOUR different MAC addresses! Twice now, I have provided a MAC address to obtain a license, only to discover that SES is using a different MAC address for validation, so the license doesn't work. Then I have to put in a request to get the license regenerated with the correct MAC address. How can I accurately …

  • We are designing a new card to be debugged using a J-Trace Pro (Cortex-M) and I have a question about J-Tag connectors: Are there any reasons to consider including connectors for both the large grey "Target" cable and the small black "Target+Trace" cable? Or does the "Target+Trace" cable provide 100% functionality and thruput? Russ

  • Thanks for the info. I look forward to the future update. Russ

  • For now, I am tracing with a J-Trace Pro (Cortex M) and the Cortex M Reference Board included with it. I am simply exploring what we will be able to do (and how) in the future when we have our custom ASIC (which is under development). We will (eventually) be performing automated overnight testing. I would like to be able to record trace data on the fly, triggering a halt of the trace when an anomaly is detected. We would then perform post-mortem analysis in the debugger on the anomaly using the …

  • I am trying to figure out how to record trace data from a unit under test and then play that data back for post-mortem debugging. In section 3.11.11 of the Ozone documentation (2.60 Revision 3), it shows a field at the bottom of the Trace Settings dialog for setting the "Trace File". However, in my Ozone (V2.60i), that field does not exist. I have hunted for hours trying to find an equivalent setting in Ozone or SEGGER Embedded Studio, with no success. Then, if I did succeed in generating a trac…

  • After much experimentation and frustration, I have determined that the Stack Usage window does not work properly if EITHER of the following is true: - Compiler used is clang - Linker used is SEGGER Russ

  • Today, I tried the following steps: 1. Removed all user data (Tools/Admin/Remove All User Data) 2. Used Windows Control Panel to uninstall SES 3. Restarted the PC 4. Installed SES for ARM 4.10a (64-bit) 5. Launched SES - "Hello" project opened automatically with default window layout and settings 6. Built "Hello" project - Successful build 7. Run "Hello" project on simulator - Expected output received in Debug Terminal window 8. Stopped debugger 9. Opened Stack Usage window - Window is empty exc…

  • I'm unable to get the Stack Usage window to display anything. I am using Embedded Studio for ARM V4.10a (64 bit) and have a project that compiles cleanly using the Clang compiler and assembler and the SEGGER linker. Unfortunately, all the Stack Usage window every displays is "No Symbols". This is also true with the default "Hello" project. I have tried uninstalling then reinstalling SES to restore all settings to defaults, but still no joy. Am I missing a step? Russ