Search Results

Search results 1-20 of 1,000. There are more results available, please enhance your search parameters.

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Hello, We received your inquiry in parallel via our support system. As your probe is in valid support period we would keep further discussion in the support ticket. So this thread will be closed now to avoid duplicate or lost information. Best regards, Nino

  • Hello Jan, Thank you for your inquiry. Currently such feature is not available. But it is already planned for a future Embedded Studio release. To get automatically notified when new versions release with their release notes you can subscribe here: segger.com/notification/subscribe.php?prodid=196 Best regards, Nino

  • Hello, I just gave this a try with a RP2040 and it appears that the automatic RTT search range for the RP2040 is not complete in J-Link software. Which is most likely the cause of the issues you are seeing and why we could not see any issues with other Cortex-M target devices. We will add the remaining RAM sections of the RP2040 to the automatic RTT search ranges as well. But for now you need to set the RTT Control Block address manually via SystemViews recorder settings. Just to make sure that …

  • Hello, Thank you for your inquiry. Ozone currently only supports displaying channel 0. Multi channel setups are generally not recommended. Instead we recommend using virtual terminals: wiki.segger.com/RTT#SEGGER_RTT_SetTerminal That way you only need to allocate one buffer and can still differentiate to up to 16 virtual terminals. This can be used currently in e.g. J-Link RTT Viewer which you can run in parallel to Ozone: wiki.segger.com/J-Link_RTT_Viewer Just make sure RTT display is disabled i…

  • Ozone Timeline

    SEGGER - Nino - - Ozone related

    Post

    Hi, this should be fixed since Ozone V3.24e Best regards, Nino

  • Hello Jonas, Thank you for your inquiry. Currently it is not possible to change the git commands from ES. But we will add this to our feature wishlist so it might be part of a future release. To get notified when new Embedded Studio versions are released you can subscribe here: segger.com/notification/subscribe.php?prodid=196 Best regards, Nino

  • Hello Adrian, Thank you for your inquiry. We noticed that you asked this question via our support system as well. Please try to stick to one communications channel so no information is lost between channels. To answer the question, it is currently not possible to include files in the linker as we do not see a use case here. We will continue your inquiry further via the support ticket. This thread will be closed now. Best regards, Nino

  • Hello, Thank you for your inquiry. Could you elaborate what you mean exactly with an example? Do you want to export the symbol information of a vector via an I/O channel or do you want it displayed in one of the symbol windows (local, global, watch)? Best regards, Nino

  • Hello Fausto, These are the solution options. Could you mark your project in the project explorer and try to open options then? Do you see the additional input files option then? Best regards, Nino

  • Hello, Thank you for your inquiry. You can set the library in project options under Additional Input Files. Best regards, Nino

  • Hello, OK so we were able to reproduce that SystemView does not start if you open J-Link Commander and do no target connection. But that is expected as the J-Link Commander in that configuration is the "main session". Now SystemView expects the main session to do all RTT init related things for the J-Link. However this only happens when a target connection is done. So if you connect to your target with J-Link Commander, let the application run with command "go" and then start SystemView, can you…

  • Hi Aleksander, For reference here is what I used for testing: wiki.segger.com/SEGGER_Semihosting This is our own implementation of all necessary Semihosting functions for easy use in applications. Feel free to use it in your project as well. Attached you can find a sample project that grabs the command line from Ozone via semihosting. It is not exactly what you are trying to do as you want to pass the arguments to Ozone, but it shows that it is generally working as you can see in the screenshot …

  • I just noticed that you started the same inquiry in parallel via our support system. To avoid lost information between the channels this thread will be closed now. For future inquiries please try to stick to one contact channel. Best regards, Nino

  • Hello, Thank you for the reproducer. With it the issue is reproducible for us. It is indeed a display error in Ozone and will be fixed. To get notified when new Ozone version appear including their release notes you can subscribe here: segger.com/notification/subscribe.php?prodid=178,7 Best regards, Nino

  • Hello, Unfortunately the highlighting issue on elf reload is still not reproducible for us. Could you provide a short video clip showing the behaviour to make sure that we do not something different when reproducing? Best regards, Nino

  • Hello, Thank you for explanation. Is this reproducible on an eval board? If yes, could you provide the elf file for reproduction and name which eval board was used? Best regards, Nino

  • Hello, Well that is because it was not fixed yet. You can see all fixes in the release notes of Ozone. As long as it does not appear in the release notes, the issue will naturally still persist. No point in posting the same over and over again. To get a notification with the release notes when a new Ozone release appears you can subscribe here: segger.com/notification/subscribe.php?prodid=178,7 The issue is known and will be fixed. But due to the complexity of the issue we can't name a fixed sch…

  • Hello Kaj, Thank you for your inquiry. Such an issue is not known to us. Is J-Flash SPI disconnected after Flashing or is the connection still enabled? Best regards, Nino

  • Hello Alexsander, Thank you for your inquriy. The error message is reproducible for us. But it is simply a wrong error message. Strings are of course also supported but Ozone console incorrectly prints "invalid setting value". In your source code you should still see the string being passed to your target application. Can you confirm? The error message will of course be fixed so it does not appear if strings are used. Best regards, Nino

  • Hello, Thank you for your inquiry. We do not ship any examples for Cortex-R4. But you can use the existing example configs as reference to create your own. For FreeRTOS you can find the Cortex-M sample for reference. For embOS there are also a couple of Cortex-A samples that will be similar to what you need for Cortex-R. All other needed information can be found in the SystemView manual. A generic guide on how to instrument FreeRTOS to enable SystemView is explained here: wiki.segger.com/FreeRTO…