Search Results

Search results 1-20 of 1,000. There are more results available, please enhance your search parameters.

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Hi Aleksander, For reference here is what I used for testing: wiki.segger.com/SEGGER_Semihosting This is our own implementation of all necessary Semihosting functions for easy use in applications. Feel free to use it in your project as well. Attached you can find a sample project that grabs the command line from Ozone via semihosting. It is not exactly what you are trying to do as you want to pass the arguments to Ozone, but it shows that it is generally working as you can see in the screenshot …

  • I just noticed that you started the same inquiry in parallel via our support system. To avoid lost information between the channels this thread will be closed now. For future inquiries please try to stick to one contact channel. Best regards, Nino

  • Hello, Thank you for the reproducer. With it the issue is reproducible for us. It is indeed a display error in Ozone and will be fixed. To get notified when new Ozone version appear including their release notes you can subscribe here: segger.com/notification/subscribe.php?prodid=178,7 Best regards, Nino

  • Hello, Unfortunately the highlighting issue on elf reload is still not reproducible for us. Could you provide a short video clip showing the behaviour to make sure that we do not something different when reproducing? Best regards, Nino

  • Hello, Thank you for explanation. Is this reproducible on an eval board? If yes, could you provide the elf file for reproduction and name which eval board was used? Best regards, Nino

  • Hello, Well that is because it was not fixed yet. You can see all fixes in the release notes of Ozone. As long as it does not appear in the release notes, the issue will naturally still persist. No point in posting the same over and over again. To get a notification with the release notes when a new Ozone release appears you can subscribe here: segger.com/notification/subscribe.php?prodid=178,7 The issue is known and will be fixed. But due to the complexity of the issue we can't name a fixed sch…

  • Hello Kaj, Thank you for your inquiry. Such an issue is not known to us. Is J-Flash SPI disconnected after Flashing or is the connection still enabled? Best regards, Nino

  • Hello Alexsander, Thank you for your inquriy. The error message is reproducible for us. But it is simply a wrong error message. Strings are of course also supported but Ozone console incorrectly prints "invalid setting value". In your source code you should still see the string being passed to your target application. Can you confirm? The error message will of course be fixed so it does not appear if strings are used. Best regards, Nino

  • Hello, Thank you for your inquiry. We do not ship any examples for Cortex-R4. But you can use the existing example configs as reference to create your own. For FreeRTOS you can find the Cortex-M sample for reference. For embOS there are also a couple of Cortex-A samples that will be similar to what you need for Cortex-R. All other needed information can be found in the SystemView manual. A generic guide on how to instrument FreeRTOS to enable SystemView is explained here: wiki.segger.com/FreeRTO…

  • Hello, Thank you for your inquiry. Generally you can automate nearly all Ozone GUI actions via the project script. All GUI actions that can be scripted are also logged in the Ozone console, so you can simply copy paste the call from there to your Ozone project script. In this case function Window.Add ("Watched Data 1", "<YourVariable>"); can be used. For more information about the scripting see the Ozone manual. Best regards, Nino

  • Hello, Such an issue is not known to us. In all our test setups goto definition/declaration work as expected. Could you provide a simple example project for reproduction? Quote from ppedro: “Another problem, I guess it is related to this one, it's difficult to debug. In some functions I can step over or step into, but most of them not, I am getting assembler. If I set a breakpoint somewhere in the code where these two function are not able to step, it breaks on. ” If there is no source file or s…

  • Hello Jacek, We received your inquiry via our support system in parallel. This thread will thus be closed now to avoid duplicate or lost information between the channels. For future inquiries please make sure to only use one channel. Best regards, Nino

  • Hello, ok thank you for clarifying. Currently only UTF-8 chinese symbols are supported. There are no plans to add other language standards right now. Best regards, Nino

  • Hello, Could you provide a short clip which shows what you are doing with step by step instructions how the recreate the behaviour? We need to be able to recreate the issues you are seeing reliably, otherwise there is not much we can do here. Best regards, Nino

  • Hello, Thank you for your inquiry. Please note that Embedded Studio V3.34 is out of support and maintenance for many years now and the V5.xx releases are very different. A general migration guide from V4 to V5 can be found here: wiki.segger.com/Migrating_proj…_Embedded_Studio_V4_to_V5 For V3 to V5 even more additional steps might be required. But as the difference between V3 and V5 is so large we recommend to create a new project with V5 and add the additional sources manually to your project as…

  • Hello Ken, Thank you for your inquiry. We are not aware of such tool that would be available. While we see the appeal of having a sensor and function output visualized in 3D space, such tool would only be useful to a very small fraction of our customer base so currently there are no plans to create such tool. Should you be interested in creating such software yourself the J-Link SDK could be used: segger.com/products/debug-prob…nk/technology/j-link-sdk/ It is the same SDK that was used to create…

  • Hello Lee, unfortunately the project does not open due to missing Nordic SDK projects. See error message attached. Could you provide a reproduction project without external dependencies? Best regards, Nino

  • Closed due to being a duplicate of this: IDEA: Need 3D graphic debug tool for Segger IDE Please do not open multiple threads with the same content and topic across multiple topics, so it is easier for other forum users to follow discussions. We will keep the thread in the General subforum for now as it is not apparent if it is ES related at all. Best regards, Nino

  • Hello, Quote from FunDeckHermit: “It was said that the bug would have been fixed in the upcoming release. ” Could you elaborate where this was said? I could find no reference to this neither in the Forum nor our support system. In my last post I asked for a reproducer. Could you provide one? Without it we can't investigate this request further. So could you answer the following questions? How are you adding the svd file to your project exactly? Could you share your .jdebug file that you try to r…

  • Hello, Could you provide a screenshot of the errors you are getting? How did you include your library? Is it a source library or do you only have the compiled .a file? If the latter you need to set it in project options as "Additional Input Files". A guide on how you can add third party sources to your basic Embedded Studio project is explained here with the example of adding FreeRTOS Sources: wiki.segger.com/How_to_create_…ject_with_Embedded_Studio But the principle is always the same, no matte…