Search Results

Search results 1-9 of 9.

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Hello Nino, the problem occured while testing a project with Ozone which had been edited and compiled in emStudio, so I started with focus on Ozone. It is an old Keil project which I imported into emStudio, so I had the chance to compare Ozone's reactions with these two compilations. And yes, the issue has been resolved by updating emStudio to version 5.40 which might have included an update of the compiler, too. Best regards, Detlef

  • Hi Nino, with today's installation of emStudio 5.40 the Problem is solved. Please see the attached screenshot : The disassembly shows the same compilation, only the blockmarkers for lines 53 and 55 are placed one line earlier. Best regards Detlef forum.segger.com/index.php/Att…7dd8a3bab6802ef08d53d786c

  • I wrote some senseless lines to get closer to the problem (see attachment). Mind you, everything is working fine. But you're upset when single stepping shows the wrong statement.

  • Hello Nino, thanks for your reply. Ozone-Version is 3.22. The code snippet shows just some lines of a complete (well-running) function with about 80 lines. I compile it with Keil-ARM , load the axf with Keil+JLink+SWD into the STM32F051, debug the named lines with Keil and stepping is ok. For some reason Ozone is not able to download this axf so I have to "Attach to running program", but stepping is ok, too. (JLink reports an unspecified download error) Using the same sourcefiles in emStudio for…

  • Hi, a snippet of my c-code looks like this: ---------------------------------------------------------------------------------------------------------------- if (tempa == 0) { Ergebnis = 0; } } Wait_ms (100); ---------------------------------------------------------------------------------------------------------------- With a breakpoint on the if statement the contents of tempa is 9 (= correct in this case). Next singlestep stops @ Ergebnis = 0 which pretends that tempa is 0 (= obviously not cor…

  • Hi Nino, that's exactly what I wanted to explain: I'm excusively using the external Keil/ARM compiler with inherited settings and I expect to get the same output. Regards Detlef

  • Hi, with a CubeMX-project for Keil, the uVision5-ARM-Compiler hex-output is about 41k long, using about 15k of Flash memory. I imported this Keil-project in emStudio. All I had to change manually was the name of the scatter file in "External Build - Link Command". The emStudio hex-output has 101k which is about 36k of Flash memory though the same compiler with inherited settings had been used. Which settings should I use to reduce the memory usage ? With uVision there is a removal of unused sect…

  • Ozone, is it a bug ?

    keyboardwizard - - General

    Post

    Hi, attached please find 7 screenshots. The program was edited and compiled with Keil uVision 5 and downloaded through a J-Link ultra+. Ozone had then been attached with "attach and hold program" and then restarted the program. Steps 1-2-3 are normal single-step, starting at the first BP in line 455. With step 4 I want to rerun some lines with another tTK-value (0x02). In step 7 comparison of R4 (= 0x02) with #4 results in "R4 is greater than #4" , which is "2 is greater than 4". This does not h…

  • Ozone, suggestions

    keyboardwizard - - General

    Post

    Hi, I like Ozone, would like it even more if you could take to the following: 1) The memory-table can show 32Bit addresses, that is 4GB. My STM32F103 has 512kB so the slider is absolutely unusable. Can you shrink the range to the actually used uC or let the user manually preset it ? 2) The Source Viewer functions "Collapse All" and "Expand All" are related to disassembly only. Could you implement a function like "Collapse All C/C++ Functions " ? 3) It would be very nice if the find-function woul…