Search Results

Search results 1-15 of 15.

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Hi, I've attached a demo project.

  • Hi, I've imported an IAR project, with no configuration modification, while linking I got 'Relocation R_ARM_ABS32 to weak symbol '****' is invalid' error. segger-as: version 2.10 segger-cc: version 10.6.2 segger-ld: version 3.04 The functions are defined as weak : __attribute__ ((weak)) void tud_cdc_rx_cb(uint8_t itf) No matter the weak function is implemented or not, this error is generated. Linker command: "C:/Program Files/SEGGER/SEGGER Embedded Studio for ARM 5.10a/bin/segger-ld" --add-regio…

  • Hello, I know STM32G0 can be unlocked when launching a debug session, but is there any command to unlock it explicitly ? I can't find it in STM32 Unlock tool, nor with the command unlock <DeviceName>.

  • Hi, As you can see the memory viewer of Embedded Studio, it failed to access memory at address 0x0. This is not an intended behavior, as the Flash content of 0x08000000 (or system memory, depend on boot0 pin) is mapped at address 0x0 at boot time (refer to RM0444, section 2.5 Boot configuration, page 58). So this is definitely not a IAR issue. forum.segger.com/index.php/Att…e3bde13a41d47df3b341ceaaa Best regards,

  • I found the corrupt of the NMI interrupt, it's cause by SRAM parity check I enabled previously in another project. Since by default RAM is not erased at startup, parity error could occur. So I reset option bytes. Following are 2 memery map at address 0 using ST-Link+IAR & J-Link+Embedded Studio. forum.segger.com/index.php/Att…e3bde13a41d47df3b341ceaaa forum.segger.com/index.php/Att…e3bde13a41d47df3b341ceaaa

  • In the attachment there are: - iar fail.log : J-Link log of the failing session with IAR, we can see the MemMap error message. - ozone.log : Same error when debugging iar output file with OZone. - test.zip : Iar output file. - embedded studio.zip : embedded studio log. No MemMap error, but as soon as I click run MCU enters NMI. Both STM32G071CBT6 minimal system board (no peripherals, only 10uF + 100nF decouple capacitors) and NUCLEO-G071RB(on board ST-Link disabled by jumper) are tested.

  • I've reached IAR support, using their demo project same error occurred. Seems like not an issue of IAR ?

  • Thanks for your reply. In fact I link my application to 0x08000000, same error occurred with sample code shipped with STM32Cube. Here is my linker script: Source Code (33 lines)Another bug is as soon as RTT client is opened, MCU goes into NMI interrupt. I'm also going to ask technical support of IAR, since maybe they did something wrong.

  • Hi, This error occurred I click debug, but debug function actually works. Probe: J-Link V10 EDU 6.40b IDE: IAR 8.32 MCU: STM32G071CBT6 forum.segger.com/index.php/Att…e3bde13a41d47df3b341ceaaa Do you need more error log ?

  • Sorry, it's just a program 1st time initialisation issue

  • Hi, Using J-link v6.20g with MKM34Z256, primask is not cleared after the execution of a script. Strangely I even tried add __enable_irq() in my code, but primask is always 1. :( Source Code (18 lines)

  • I have a task running at 1Hz and several IRQs running at higher speed. In the context window I was shocked that the frequency of this task is about 5/6 Hz and run count is added by 5 or 6 every second, then I found out that's because the execution of this task is interrupted 5 or 6 times by IRQs, as they are displayed in the timeline. I feel these two information is very misleading, as in most case what we care is the real run count/ frequency of a task, and how many time a task is interrupted b…

  • Hi, For ISRs, we can use SEGGER_SYSVIEW_RecordEnterISR() combine with SEGGER_SYSVIEW_SendSysDesc("I#15=xxxxxxx"); to trace them easily. But for function calls, in order to display them correctly, we need to write a description file, which is not always practical. So what I done is hacked the ISR record function: Source Code (1 line) I know it's not a good idea to modify sources files of SystemView directly, could you provide a easy way to record function call like this ?

  • Hi, Using the 6.14c software, I noticed that when I click debug in the IAR, the virtual com port already opened not work anymore. In order to let it work, I must choose another baudrate. Step to produce the issue: 1. Make a loopback connection on VCP and connect SWD to the MCU 2. Use Tera Term to test the vcp port, it should work. 3. Click download and debug in IAR 4. VCP port not work anymore even if I close and relaunch Tera Term 5. Change the baud rate in Tera Term and VCP works until next de…

  • Hello, I'm evaluating emFile with STM32F4 and IAR compiler. In my project I'm using USB to mount nand flash and display new files after USB is ejected. However, I found FS_GetVolumeFreeSpace() didn't give me the newest free space after some files are created or deleted, in my case there are only two ways to get the actual free space: 1.Reset the MCU, so the file system is also reinitialized. 2.Format the flash, it gives the correct space. Anyway to solve this? Thanks,