Recent Activities

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • SEGGER - Nino -

    Replied to the thread Ozone's parser does not detect EntryPointSP in .srec file.

    Post
    Hello, Thank you for your inquiry. When calling Elf.GetEntryPointPC works only on elf files as the name of the function suggests. So setups with an srec will not work that way. You will need to use other script functions to detect the entry point from…
  • SEGGER - Nino -

    Replied to the thread Bug found in File.Open() based on wiki code.

    Post
    Hello, Thank you for your inquiry. Indeed the Wiki does not seem to be up to date anymore. We will make sure this is corrected. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Feature request: Detect wrong encoding of .jdebug file.

    Post
    Hello, Thank you for your inquiry. This has been added to our improvement list so in future such characters are detected correctly. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Ozone v3.22 to v3.22e freezes when opening some .elf files.

    Post
    Hello, Thank you for clarification. I just gave this a spin on a macBook with the same Big Sur version and the issue was reproducible. We will investigate further and fix it accordingly. The "main symbol not found" message should have no impact…
  • Hi, the compression seems to appear for me for the embedded video only. Strange. Anyhow, just gave this a try on a macbook with the M1 chip and the latest big sur version a try and indeed the issue is reproducible. We will investigate further and fix…
  • Kaferalgo -

    Posted the thread QSPI indirect flashing SAM V71 + ISSI IS25LP064.

    Thread
    Hello everyone, I need to write to the external QSPI fash indirectly using J-Flash. The standard RAMcode works on the deveopment board but the circuit I'm using is a bit different and needs GPIO PA26 to be involved in the QCS Chip Enable. Is there…
  • SEGGER - Fabian -

    Replied to the thread J-Link Debug Fails.

    Post
    Hi, From the logfile I can tell that you are using J-Link software that is actually pretty old. Could you please update the J-Link Software? You can find the latest version of the J-Link Software Pack here:
  • ph99004 -

    Replied to the thread J-Link Debug Fails.

    Post
    Fabian, Thank you for your kind reply. Attached is the log file, per your request. I am using the Jlink within the Eclipse-based NXP Kinetis Design Studio, Version: 3.2.0. I use it to program NXP/Freescale Kinetis MCUs. I am connected with a 10-pin…
  • danngreen -

    Replied to the thread Ozone v3.22 to v3.22e freezes when opening some .elf files.

    Post
    I'm using macOS Big Sur (11.2.3). And it happens also on my macbook, same OS. I tried adding a stub symbol for main() but it still crashes. Also that error might just show up for you because the default Ozone settings are to break at the symbol "main".…
  • That's odd you see a compressed video, the video is crisp when I play it on youtube, and youtube says the resolution is quite high (2160p60). Perhaps you need to manually select the resolution (click on the gear icon on the youtube video, and select a…
  • SEGGER - Nino -

    Replied to the thread How can I put 4 bytes at __FLASH_segment_end__ ?.

    Post
    Hello, Yes this behaviour is expected as the linker generated sections can only be placed after everything else is placed. So unfortunately "last section" placement will not work for your use case. What you could do is either place the CRC at a fixed…
  • SEGGER - Nino -

    Replied to the thread Ozone v3.22 to v3.22e freezes when opening some .elf files.

    Post
    Hello Dan, Thank you for your inquiry. That sounds odd indeed. I just gave it a try with V3.22e on my Windows dev PC and for me it was working as expected: C Source Code (4 lines)Ozone complains that no main symbol was found and obviously the referenced…
  • Hello Dan, Thank you for your inquiry. Seems like youtube compression got the better of your video :/ But if I understand you correctly, the issue is, that when using the GoTo address in disassembly the cursor will only stay there when the debug session…
  • SEGGER - Nino -

    Replied to the thread Understanding & customizing the FreeRTOS plugin script...

    Post
    Hello, Thank you for your inquiry. Quote from v01d: “So if I see <nnnn> / N/A, does this mean <nnn> == Is calculated Free stack space, and N/A for the unknown total stack size .? ” Correct. Quote from v01d: “And, how can I expand the…
  • SEGGER - Nino -

    Replied to the thread Building with GitHub Actions.

    Post
    Hello, Thank you for your inquiry. While we do not have any samples for GitHub Actions specifically, IIRC this is the automated build and test framework of GitHub, correct? In that case you can use emBuild, our command line build utility, which comes…
  • SEGGER - Fabian -

    Replied to the thread segmentation fault on linux ARM.

    Post
    Hi Guillaume, Could you please provide us with a reproducer for this? Best regards, Fabian
  • SEGGER - Fabian -

    Replied to the thread J-Link Debug Fails.

    Post
    Hi, Thank you for your inquiry. There is no such issue known to us. At first glance, this does not necessarily look like a J-Link related issue. What Device are you trying to debug exactly? Could you please send us a J-Link log file? How to enable:
  • Hi, Thank you for your inquiry. We are not aware of any issues related to the STM32F1 series and JTAG. I just gave this a quick try and it seems to be working without any issues on an STM32F10X-128K-EVAL board (STM32F103V8):
  • SEGGER - Fabian -

    Replied to the thread Program address offset in JFlash.

    Post
    Hi Priya, Thank you for your inquiry. I am sorry, but I do not quite understand what you are trying to achieve. Could you please explain in more detail? In general: 1) .bin files do not contain any address information, so when opening them in J-Flash…
  • Hi, Good to hear that you were able to resolve the issue. We will close this thread now. Best regards, Fabian