Recent Activities

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Hello, Thank you for your inquiry. I assume you are using the J-Link Commander, is this correct? The J-Link Commander itself does not provide such functionality currently. But you can purchase the J-Link SDK which comes e.g. with the J-Link Commander…
  • SEGGER - Fabian -

    Replied to the thread STM32WB50 support.

    Post
    Hi Robson, Thank you for the information. I will keep you posted. As a side note: You can also implement support for the device yourself via Open Flashloader. For more information please follow this link: wiki.segger.com/Open_Flashloader Best…
  • thomask77 -

    Posted the thread Trace timeline accuracy.

    Thread
    Hi! I am using Ozone 3.10b and a STM32H743 @ 480MHz. 1) I've set up ETF trace according to wiki.segger.com/STM32H7#Tracing_on_ST_STM32H743 In the trace settings dialog, I set the source to Trace Buffer, and CPU Frequency to 480000000. When I do a…
  • robson -

    Replied to the thread STM32WB50 support.

    Post
    Hello Quote from SEGGER - Fabian: “We added the device to our list. ” Awesome. That is all I wanted to hear. Quote from SEGGER - Fabian: “ Unfortunately, it is not clear when we are able to add support for this device exactly, because of other,…
  • Mark_C -

    Posted the thread GUI_SetOrientationEx leads to slow redrawing and GUI page change.

    Thread
    Hello, I have developed a GUI with STemWin libraries for a 4.3" display. Now I need to rotate all the application upside down so in my code I called the function GUI_SetOrientationEx in the following way: Source Code (11 lines)Compared to the plain GUI…
  • SEGGER - Nino -

    Replied to the thread [SOLVED] Live Expressions - Failed to evaluate expression.

    Post
    Hello, Great to hear that it is working reliably with Ozone. We are happy about any new Ozone user we can win for us ;) This thread will be considered solved now. Best regards, Nino
  • SEGGER - Fabian -

    Replied to the thread [SOLVED] JLink fails to connect to i.MX6ULL on i.MX6ULL EVK.

    Post
    Hi Stefan, Thank you for your inquiry. We received your email via our support system and we will get back to you there, since you are still in support period. We will close this thread to keep communication to one channel, to make sure no information…
  • icwiener -

    Replied to the thread [SOLVED] Live Expressions - Failed to evaluate expression.

    Post
    Hi Nino, thank you for your input. In Ozone, all values seem to be shown fine. I tried about 10 debug runs and every variable's value was shown in each run (amazingly fast, btw :)). Thanks, now I know where to look. :)
  • stroese -

    Posted the thread [SOLVED] JLink fails to connect to i.MX6ULL on i.MX6ULL EVK.

    Thread
    Hi! I'm trying to connect my JLink to the NXP i.MX6ULL EVK. Unfortunately this fails for now. Here the current log: $ JLinkExe -device MCIMX6Y2 -if JTAG -speed 1000 -JTAGConf -1,-1 SEGGER J-Link Commander V6.60d (Compiled Jan 9 2020 17:47:03) DLL…
  • Hello, Is it is possible to learn J-Link Serial Number by Command Line Interface. In the other words, return J-Link Serial Number which are connected to PC by usb when entered correspondig terminal command. I need this corresponding terminal command.
  • SEGGER - Fabian -

    Replied to the thread STM32WB50 support.

    Post
    Hi, We added the device to our list. Unfortunately, it is not clear when we are able to add support for this device exactly, because of other, pressing paid projects. Until when would you require support for this device? Do you use custom hardware or an…
  • robson -

    Replied to the thread STM32WB50 support.

    Post
    Hi Fabian, Thanks for your response! I will wait then. I am aware of the supported devices list. STM32WB55 is supported, but STM32WB50 is not.
  • v01d -

    Replied to the thread How to set JLink to never power the board.

    Post
    Hey Fabian, will do asap with photo & details, but i'm on something else this week and/or few days.
  • SEGGER - Florian -

    Replied to the thread ListView Maximum Rows.

    Post
    Hi, there is no real limit to how many rows you can add to a listview. The only actual limits would be your memory or the line count variable (unsigned int, therefore max. would be about 4 billion). Best regards, Florian
  • SEGGER - Fabian -

    Replied to the thread [SOLVED] r (reset) triggers flash write trace ....

    Post
    Hi, Sorry for the confusion caused. We will consider this thread as closed now. Best regards, Fabian
  • SEGGER - Fabian -

    Replied to the thread STM32WB50 support.

    Post
    Hi, I will ask internally if and/or when support is planned for this device and will report back to you then. On a side note: A list of all supported devices can be found here: segger.com/downloads/supported-devices.php Best regards, Fabian
  • SEGGER - Nino -

    Replied to the thread Error reported: Faild to connect to target.

    Post
    Hello Udo, Thank you for your inquiry. There are no technical restrictions in the non commercial/evaluation version of Embedded Studio. This sounds like a connection setup issue. What target device are you looking to connect to? Is it a custom board or…
  • SEGGER - Nino -

    Replied to the thread [SOLVED] Problem while programming STM32F103RG.

    Post
    Hello, Great to hear that you are up and running again. As you correctly found out the Flash must be erased before programming new data. This is common on most Arm microcontrollers. Production Programming mode does all required steps automatically. We…
  • SEGGER - Fabian -

    Replied to the thread How to set JLink to never power the board.

    Post
    Hi, I received the messages. Could you please also provide 2) and 3) as well? Best regards, Fabian
  • htsmith19 -

    Posted the thread ListView Maximum Rows.

    Thread
    Hi all, For a ListView widget, is there a limit on the number of rows you can add to the table? Is it configurable via an API or is it a fixed limit based on platform/memory limitations? Thanks,