Recent Activities

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • SEGGER - Florian -

    Replied to the thread ukrainian fonts convert.

    Post
    Hi, what exactly didn't work? There's nothing wrong with your pattern file, it worked for me. Did you disable all characters before reading the pattern file? When the font was successfully generated, it just has to be added to the project. Then,…
  • SEGGER - Florian -

    Replied to the thread TTF FONT SIZE problem.

    Post
    Hi, you probably ran out of memory. The TTF fonts are created in RAM. The larger the font, the more memory is needed. So, the font size isn't really limited, but obviously your font can't exceed the memory limit. Best regards, Florian
  • Hi, Thank you for your inquiry. Since your J-Link is still in support period, could you please open a support ticket for this issue? Please find all required information in my signature below this message. This thread will be closed now to avoid…
  • arat -

    Replied to the thread ukrainian fonts convert.

    Post
    Thank you for the fast reply, I have generated .c file using attached pattern .txt with Antialiased 4bpp and 16 bit unicode . it dint work . And I have generated in Antialiased 4bpp and 8bit ASCII + ISO 8859 and changed script to Cyrillic. in this…
  • SEGGER - Florian -

    Replied to the thread ukrainian fonts convert.

    Post
    Hi, you can do that with the FontConverter. You have to load a font into the tool that contains the Ukranian letters, select the letters you want to have in your C file and save the result as a C file. Best regards, Florian
  • arat -

    Posted the thread ukrainian fonts convert.

    Thread
    how to generate .c file for ukrainian alphabet .
  • lukma -

    Replied to the thread [SOLVED] Problem with restoring original FW on embOS/IP switch board.

    Post
    Dear Community, I've downgraded the JLink driver version to V6.50b - the result is the same. Can somebody confirm if this procedure works for recent JLink on Ubuntu/Debian? Thanks in advance.
  • SEGGER - Florian -

    Replied to the thread Prompt screen.

    Post
    Hi, have a look at the routines GUI_MEMDEV_BlendWinBk(), GUI_MEMDEV_BlurAndBlendWinBk() and GUI_MEMDEV_BlurWinBk(). The manual also has screenshots for these routines. Best regards, Florian
  • JanBurg -

    Replied to the thread Overlapping Windows.

    Post
    Thank you, Alex. Using WM_AttachWindow() is a smart way to solve the problem. In the meantime I also found a less elegant solution. I replaced the dropdown in the menu bar by a text item which at a click opens a new window with the dropdown on top of the…
  • vikramtathe -

    Replied to the thread Prompt screen.

    Post
    Hello, As mentioned in the image, I wanted to design prompt screen attached previously. I was trying to design and blur the background screen but I am unable to do this. I have created two text boxes and two buttons separately. Could you please let me…
  • sukjin -

    Posted the thread TTF FONT SIZE problem.

    Thread
    Hello,I use emwin V5.48 in Novoton N9H20 MCU with 480x800 LCD. Use GUI_TTF_CreateFontAA to create 1 font size. It works when the font size is set to 170 or less. If the font size exceeds 170, it will not be displayed on the screen. - Even if the font…
  • SEGGER - Florian -

    Replied to the thread Multiple Buffering.

    Post
    Hi, there is so such display driver called GUI_DRVControl. Only GUIDRV_Lin supports multibuffering. All of the other display drivers use a cache instead. Best regards, Florian
  • Hello, I tried to reproduce your behavior but for me the arc remained consistent (see attached file). Can you send me your code or a sample so I can reproduce your error? Best regards, Florian
  • vadim.b -

    Posted the thread [bug] Ozone V3.10g: expansion indicators in source window.

    Thread
    Hello, The expansion indicators are always shown in Source window after start of Ozone. Steps to reproduce: 1. Start Ozone 2. Tools -> Preferences -> General -> Source Viewer -> Show expansion indicators -> set to "no" Expansion indicators will…
  • Hello Fabian, thank you very much for the help. and yes you are right, i see that my program is being flashed starting at 0x20010000. i got this hifive1-revb board second hand, and i was assuming that by default running "make upload" would flash at…
  • vadim.b -

    Posted the thread [bug] Ozone 3.10g: display format of the variable.

    Thread
    Hello, The display format of a variable named 'value' can not be changed, at least in Local Data window. Steps to reproduce: 1. Add the following function to your project, add a call to the function. Source Code (7 lines) 2. Compile, run on an ARM…
  • omer faruk -

    Now follows SEGGER - Schoenen.

    Follow
  • omer faruk -

    Now follows SEGGER - Arne.

    Follow
  • bio_med -

    Posted the thread Multiple Buffering.

    Thread
    Hi, Can someone tell me if Multiple buffering is included in GUI_DRVControl driver? What are all the drivers that have multiple buffering as a part of it? Appreciate any help! Best regards, BMD
  • Haia_Boosa -

    Posted the thread Problem with running STemWin on STM32F103ZET from external SRAM.

    Thread
    Hi everyone I'm using STM32F103ZET to run STemWin532 GUI. In the first step i configured everything for running from internal RAM and program worked fine and GUI displayed components like progress bar and ...., but when i changed linker command file to…