Recent Activities

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • SEGGER - Nino -

    Replied to the thread ST-Link On Board feedback.

    Post
    Hello, Thank you for your feedback. We will discuss this internally and improve the tool where needed. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Plugging in J-Link mini backwards.

    Post
    Hello, Thank you for your inquiry. On the J-Link EDU Mini you will find a 1 printed next to the header. This is the side Pin1 is on. On your cable you will find a red marking. This is also the side where Pin 1 is located. If you match them you should…
  • afedotov77 -

    Replied to the thread Failed to measure CPU clock frequency.

    Post
    Hi Fabian, Additional information. I observe switch on the red LED on the J-Link PLUS during 3-5 seconds. Red LED switches after start donloading program from Ozone BR, Andy
  • manjunath -

    Posted the thread Not able to load binary file into Flash - ADuCM362.

    Thread
    Hello I tried to load *.bin file to ADuCM362 controller through SWD using J-Flash, it will connect to target but I not able to load executable into flash. It is giving programming failed @ address 0x00002338 (Block verification error). Please suggest…
  • LexaGb -

    Replied to the thread PROGBAR doesn't change colors.

    Post
    Hello, to remove the progress value from the bar just call this with the empty string value: PROGBAR_SetText(hProg, ""). Alex.
  • mattb351 -

    Replied to the thread Open loader elf file requirements.

    Post
    So to be quite specific, I have: “… SEGMENTS: Type Offset Virtual Physical File Sz Mem Sz Flags Align ---- ------ ------- -------- ------- ------ ----- ----- 0: load 0x34 0x2000'0000 0x2000'0000 0x10a0 0x10a0 0x4 R
  • Torsten Robitzki -

    Replied to the thread unreliable flash upload with J-Trace and SAM4S.

    Post
    Hi Fabian, the J-Trace Pro is less than half a year old. If it helps to speed up this use, I will also open a ticket within your support system. The original message, that flashing with the J-Commander works flawless, was not quite correct. I can see…
  • stephrdev -

    Posted the thread Problems using JLink EDU with GD32VF103CBT6 based controller.

    Thread
    Hi! I tried to use the JLink EDU (V10.10) with the recently released Sipeed Longan Nano - RISC-V GD32VF103CBT6 Development Board. Not sure if this is a shortcoming of the EDU version (I hope not :( ) Or maybe just a software or configuration issue? Some…
  • minchingho -

    Replied to the thread Can watchdog be paused when MMD is used for debugging?.

    Post
    Hi Fabian, When will JLINK_MONITOR_OnPoll be called? If I stopped at a breakpoint for very long time, will the watchdog still be fed from this function? The CPU I used can not pause the watchdog, but keep feeding it. I have seen several reset even when…
  • Pieter Eggermont -

    Replied to the thread PROGBAR doesn't change colors.

    Post
    Quote from SEGGER - Schoenen: “Another way to change the look of the widgets is to overwrite their callback function or set a skinning/owner-draw function (if available). ” I have trobubles setting those settings. I do not manage to edit a progress…
  • phryniszak -

    Posted the thread stm32g431 J-Link error "Failed to measure CPU clock frequency".

    Thread
    Hi All, I try to start work with relatively new chip STM32G431, but Ozon stopped working with "Jlink reports unspecified download error" I tried to use jlink command line and erase chip but it also fails. In log I can see "Failed to measure CPU clock…
  • SEGGER - Fabian -

    Replied to the thread unreliable flash upload with J-Trace and SAM4S.

    Post
    Hello, Keep in mind, that this is not a support forum, so answers might be delayed. If you are still in the support period, you can also open a ticked in our support system. Please refer to my signature for more information. We are working on the…
  • SEGGER - Fabian -

    Replied to the thread Missing "Connect to running target" option?.

    Post
    Hello Dave, Sorry for the delay in response. Please find the Wiki article here: wiki.segger.com/STM32CubeIDE Best regards, Fabian
  • xhale -

    Posted the thread ST-Link reflash issues.

    Thread
    Hi, I recently attempted to convert the ST-Link from a STM32F411RE Nucleo board to a J-Link using the latest STLinkReflash utility. It appears to be functional as a J-Link however I have noticed some errors or odd behaviour: 1. The Nickname (and…
  • afedotov77 -

    Replied to the thread Failed to measure CPU clock frequency.

    Post
    Fabian, answers is below 1) Does this replacing firmware error also appear when you are using J-Link Commander (jlink.exe)? Message about replacing firmware does not always appears and Yes, this message also appear when I using J-Link Commander. 2)
  • SEGGER - Fabian -

    Replied to the thread Failed to measure CPU clock frequency.

    Post
    Hi Andy, Could you please answer the following questions?: 1) Does this replacing firmware error also appear when you are using J-Link Commander (jlink.exe)? 2) Could you send us a picture of the whole Commander output? 3) Is the J-Link connected to the…
  • cowens -

    Replied to the thread Pass ID CODE verification via command line.

    Post
    Quote from SEGGER - Fabian: “Hi, Thank you for your Inquiry. Unfortunately, there is currently no such command-line option. We will put it on our requested features list, but cannot say when it will be implemented. If you require this feature short…
  • I think this arch drawing helps explain why SWD /2-wire seems to work but not JTAG 4-wire .. I've seen at least few posts on Segger forum about problems with this IcePick. May be this was resolved somewhere already?
  • SEGGER - Fabian -

    Replied to the thread Can watchdog be paused when MMD is used for debugging?.

    Post
    Hello Min-Ching, Thank you for you r inquiry. The watchdog is not paused by our software. You have to implement the feeding/pausing of the watchdog yourself as part of the poll function. You can find further information about this topic in the J-Link…
  • afedotov77 -

    Replied to the thread Failed to measure CPU clock frequency.

    Post
    Fabian, I don't see any difference environment (debugger, scheme, chips and software SEGGER for debugger) between last successful experience and bad experience (when appeared problem). I updated J-Link software up to latest version, but it had fixed…