Recent Activities

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • kwrtz -

    Posted the thread Register will not be shown after importing CUBEMX Project.

    Thread
    I imported a CUBEMX project with Eclipse import. The porject works like it should. But when I do the debugging, only the CPU and VPF register are shown. What can I do, that all registers will be shown?
  • SEGGER - Nino -

    Replied to the thread RTT slow not usable anymore.

    Post
    Hi, little update in this regard. In the latest J-Link software version V6.44c the RTT Viewer should be back to old speeds and according to our measurements even faster. Could you give it a try and report back your findings? Best regards, Nino
  • nicastellanos -

    Replied to the thread Ozone Breakpoints not setting correctly.

    Post
    Hi, Thank you for the response, let me clarify slightly. The issue I have is occurring when I try to use the "step over current subroutine" function on Ozone. I have attached another example to hopefully better clarify. In ozone if I were to use the…
  • r_mota -

    Posted the thread Flasher ARM stand-alone fail.

    Thread
    Hi there, I am trying to use flasher ARM stand-alone mode in a LPC1227/301, but i cannot get it to program. Using J-FLASH V6.44b i can connect, erase and program the device. But if i download config & data file in to flasher, exit J-flash and press the…
  • Sue -

    Replied to the thread Plotting graphs.

    Post
    Good morning Sven, I managed to get your example code of WIDGET_GraphXY.c and learn from it about the GUI_POINT. This part interests me a lot : ... _aPoint[0].x = (int) (100 - r * cos(Rad)); _aPoint[0][i].y = (int) (100 + r * sin(Rad) * Deg /
  • delphes -

    Replied to the thread NXP RT1052 with only External Flash and Segger Jlink.

    Post
    Hello, Yes I did, but still have problem. Best Regards
  • SEGGER - Schoenen -

    Replied to the thread Draw jpeg over widgets.

    Post
    Hi, If you change the MainTask() in the example you have posted to something like below, do the NumFreeBytes decrease further and further or do they stay at one level? C Source Code (16 lines)You can simply watch the variable GUI_ALLOC__Context. Their…
  • andrefleitao -

    Posted the thread Program multiple TM4C boards.

    Thread
    Hi. I was searching for a way to program several TM4C microcontrollers with only one programmer using a command line program under Linux. Found Texas Instruments XDS programmers that support daisy chaining JTAG interface via their CCS software. Now i…
  • sanjeev majumdar -

    Replied to the thread Draw jpeg over widgets.

    Post
    Thanks for the reply Sven. GUI_JPEG_Draw() does really fail sometimes and returns 1 but there is no error code defined in emwin manual for this api. For example, when we are trying to overlay a jpeg on a button, we have registered a callback to the…
  • dsula -

    Replied to the thread can't connect to Syntacore SCR1.

    Post
    Thank you for your reply. I've seen the segger wiki post regarding the SCR1. I also downloaded the SCR1/Arty SDK and tried to use it with the Segger studio. It doesn't work. What does this error message mean? ****** Error: CPU-TAP not found in JTAG…
  • SEGGER - Nino -

    Replied to the thread can't connect to Syntacore SCR1.

    Post
    Hello, Thank you for your inquiry. Generally all cores that follow standard RISC-V RV32 implementation are supported by J-Link. Quote from dsula: “I've taken up this issue with Syntacore and according to them J-Link is NOT compatible with SCR1 (as…
  • SEGGER - Nino -

    Replied to the thread Telink single-wire support?.

    Post
    Hello, Thank you for your inquiry. From the google links I could not find what core type the Telink chips are. Generally they are currently not supported. If they are Arm cores then you could add support yourself with our Open Flashloader interface. If…
  • SEGGER - Nino -

    Replied to the thread Ozone Breakpoints not setting correctly.

    Post
    Hello, Thank you for your inquiry. We are not exactly sure what you mean from the example you provided. Could you provide a bigger snipped where one can see where the BP is actually set? What behaviour would you expect? What steps do you take when…
  • SEGGER - Nino -

    Replied to the thread j-link not connect to Renesas RX210.

    Post
    Hello, Thank you for your inquiry. Please be aware that this forum is a community forum so there is no guarantee to receive a response here. We tried to reproduce the reported behaviour but everything was working as expected in our example setup. See…
  • Hi Hans, We received this inquiry via Supportsystem as well. To keep all information in one place this thread will be closed now. For everyone else, the minimum recommended RAM size is 5-6 kB. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread [SOLVED] QSPI Flash on custom IMXRT1021 board.

    Post
    Hello Dave, Thank you for your inquiry. Please be aware that this is no official support forum so there is no guarantee to receive a response here. If you are entitled to support see my signature for more information. Quote from dmarples: “I can't say…
  • SEGGER - Nino -

    Replied to the thread Is it possible to use J-Link EDU to debug Nuvoton's N76E003 over SWD?.

    Post
    Hello, Thank you for your inquiry. What is the actual name of the target device you are looking to debug? Is it on our public supported devices list? segger.com/downloads/supported-devices.php If not but it is one of our supported core types you can add…
  • Hello, Thank you for your inquiry. The folder you are trying to write to is write protected by admin rights. Simply select another saving location for your project file and you should not see this error message anymore. Alternatively operate J-Flash…
  • SEGGER - Nino -

    Replied to the thread [SOLVED] JFlash resets QSPI bit in IS25LP128 flash chip.

    Post
    Hello Hans, We received your inquiry via Supportsystem as well where the topic has been solved. A fixed version will be available with our next J-Link software beta. This thread will be closed now to avoid double information. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread [SOLVED] Ozone loads elf file very slowly.

    Post
    Hello Hans, Thank you for your inquiry. We received your inquiry via our Supportsystem as well. To avoid double information this thread will be closed now. Just a quick info to other readers. We were able to improve the load time in this case to around…