Recent Activities

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Hello, Thank you for your inquiry. The current SystemViewV2.52f_Src files from our website are faulty in regards to the RTT files. For now we recommend using the RTT files shipped with the latest J-Link software version. The SystemView shipping files…
  • SEGGER - Nino -

    Replied to the thread [SOLVED] GCC support missing in SEGGER_RTT_ASM_ARMv7M.s.

    Post
    Hello Thomas, Thank you for your inquiry. The issue is related to your other thread so this one will be closed: Recording stops with "Invalid packet received" when using assembly version Best regards, Nino
  • Boris -

    Replied to the thread Writing MSP432P401R BSL Flash.

    Post
    it looks like the MSP432P401V has BSL/Info memory supported: "TI", "MSP432P401V", "Cortex-M4", { {0x00000000, 0x00080000}, {0x00200000, 0x00001000}, {0x00202000, 0x00006000} }, {0x20000000, 0x00010000} But my problem is, I can't add that extra memory…
  • Boris -

    Posted the thread Writing MSP432P401R BSL Flash.

    Thread
    Hello, I like to flash the BSL / Info Memory of an MSP432P401R directly with J-Link. TI Code Composer Studio has an option for that and probably an own flash loader. J-Link with -ExpDevList shows me that only the main flash is configured: "TI",…
  • elektroll -

    Posted the thread PC of target system has unexpected value after programming sector.

    Thread
    Hello, i've get this error while trying to read a Flash (S29GL512N) attached to the EMIFS interface of an OMAP5912 (ARM9 based) using J-Flash. It aborts after reading 20 or 30 sectors with the error shown here:
  • LexaGb -

    Replied to the thread Emwin image draw.

    Post
    Hello, functions GUI_MEMDEV_CopyToLCD...() ingnore the alpha channel. If you want to consider the transparency then use GUI_MEMDEV_WriteAt() instead of GUI_MEMDEV_CopyToLCDAt(). Alex.
  • DG12 -

    Replied to the thread J-Link command enhancement - trivial but very helpful null:= step.

    Post
    To prevent backward compatibility problems with command scripts what about adding a command line flag (simply since there is already a significant list of flags) like -stepOnEnter. I think this would be useful for most users. Thank you for you
  • jev -

    Posted the thread J-Link target power.

    Thread
    I'm feeding my target hardware from the J-Link Pro when debugging. The 5V output is regulated down to ca. 3V using an LM317T. The hardware connected to it is known to peek at ca. 10 mA. However... the J-Link Control Panel however says:
  • TestJoe -

    Posted the thread Operating System hangs after undocking window.

    Thread
    Hi, I'm using Embedded Studio V4.12 x64 for a while and today my operating system (Windows 10) was unusable if I undock a file window while holding the left mouse button and moving the file window to other screen position. I had to enter the task…
  • jev -

    Replied to the thread RTT slow not usable anymore.

    Post
    I had this same problem, see [ABANDONED] RTT Viewer 6.40 slow? (never got a notification from the forum software therefore I had not seen it was answered). We noticed the behavior depends on the host machine in use. We had this problem on several laptops…
  • Giteh -

    Posted the thread J-Link Base sets debug bit for PIC32 microcontroller.

    Thread
    Hello, I want to ask if problem described in link below is solved? [SOLVED] J-Link Base sets debug bit for PIC32 microcontroller Maybe some new filmware for J-Link Base or some other J-Link Programmer solves it? I will be gratefulfor any answer. Best…
  • anuj.tanksali -

    Replied to the thread Emwin image draw.

    Post
    Hello, Thanks for the solution. The above solution works but am facing an issue with transparency of memory device. I have written the code as follows GUI_MEMDEV_Select(hMemHalf); GUI_SetBkColor(GUI_TRANSPARENT); GUI_Clear(); This does not work. i see…
  • Hi, We are using the Segger Emulator JLink Pro for programming our hardware TMS570LS0714 (ARM Cortex-R4F) and using the IDE IAR EWARM 8.22. However, when we are trying to Download and Debug using the IDE IAR EWARM 8.22 , we are getting an error message…
  • Gossamer -

    Replied to the thread Register definition file causing issues.

    Post
    Hi, Attached is the svd file. Issue happens as soon as I attach the svd file and do the first debugging over SWD. I dont even enable any of the peripherals in the register viewer. Didnt try JTAG, as I dont have compatible board. Removing the svd file,…
  • akira -

    Replied to the thread J-Link DLL Updater cannot find my installed Keil uVision.

    Post
    Thanks. I can update. :)
  • roblabla -

    Posted the thread J-Link EDU Jetson TX1 support.

    Thread
    Hello, I am currently looking for an affordable JTAG debugger to debug some open source software on my Jetson TX1. The Jetson TX1 uses Cortex A57 and Cortex A53 cores in a BIG.little architecture. I was wondering if the J-Link EDU supports this, but I'm…
  • PMOR -

    Replied to the thread JLink: avoid the "update firmware" dialog.

    Post
    Small update. We temporarily solved the issue by downgrading to JLink_V600.
  • Veit_Kannegieser -

    Posted the thread Memory zone/background memory access.

    Thread
    Hello, i am trying to get RTT working with our devices, which have Cortex-A9 and Cortex-R4 based controllers on them again. jlink.exe showsSource Code (4 lines) for both. Questions: 1) are the "zone"s of jlink.exe memory commands that zones?, if yes,…
  • mati1485 -

    Posted the thread Displaying BMP file on LPC54628.

    Thread
    Hi, Currently I'm using LPC54628 development board and trying to display any image (BMP in general). I have 32x32 bmp image converted to C file. This is code generated from Bitmap Converter. C Source Code (76 lines) I' d like to simply display it…
  • DSmidgit -

    Replied to the thread J-FLASH not reading external memory LH75401.

    Post
    Hello Nino, I tried your sugestion but I just get the message shown in the image below. forum.segger.com/index.php/Att…49f3de602be255f0014f2b37c But when i check the memory is not erased. It looks like erase does not do anything because the ERasing…