Recent Activities

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • anuj.tanksali -

    Replied to the thread Emwin Bitmap converter 8bpp conversion.

    Post
    Hello, Thanks for the reply. I will try to remove the transparency and check. But if need transparency then it will not work with 8 bit? Regards, Anuj
  • anuj.tanksali -

    Posted the thread Widget Icon view behavior.

    Thread
    Hello, When i create the Widget Icon view using resource table i don't see the text displayed under the icons. But when i use createEx function to create the widget icon view then the text under the icons is visible. //resource table {…
  • SEGGER - Schoenen -

    Replied to the thread Emwin Bitmap converter 8bpp conversion.

    Post
    Hi, I guess this is related to the transparency. You could try to modify the image with a tool like GIMP or Photoshop to remove the transparency. Regards, Sven
  • anuj.tanksali -

    Replied to the thread Emwin Bitmap converter 8bpp conversion.

    Post
    See attached png file Thanks Anuj
  • Hi, I have just tried using ST-Link just a moment ago and it works flawlessly. Weird thing is that J-Link started working after using ST-Link, but I have been here before...I get to work and at some point I get the same behaviour as above. Earlier I…
  • awneil -

    Posted the thread Enhancement Request: Print Selection.

    Thread
    The 'Selection' option in the 'Print' dialogue is permanently disabled - even when there is a selection. Please enable this option! Does anyone actually print entire source files these days? But printing just a selection is often useful.
  • Have you tried it with an ST-Link? If you get the same with an ST-Link (or other debug probe), that would suggest that it's not to do with the J-Link ...
  • Hi everyone, I am running j-link base with latest firmware (2019 Mar 21) to debug STM32F415RG, using Atollic TrueSTUDIO ver 9.1.0 (Eclipse Neon). Sometimes the debug session runs with no problems, but most of a time a get an error when I try to run the…
  • martin_st -

    Posted the thread MKL28 v6.44f problem.

    Thread
    Hello, it seems that there is problem with NXP MKL28Z512xxx7 support in software v6.44f. I'm unable to connect neither with J-Link EDU nor with onboard OpenSDA (Segger firmware). J-Flash Lite says "ERROR: Could not connect to target.", Ozone is little…
  • gawied -

    Posted the thread J-Scope and IAR elf output (.out).

    Thread
    Hi I am trying to use J-Scope (V5.10d) with an .elf file generated using IAR EWARM V8.32.4, it is actually an .out file. When using the New Project Wizard, after selecting the .elf file, the program crashes. Does J-Scope support the elf format…
  • awneil -

    Replied to the thread Give "friendly" names to JLinks?.

    Post
    OK - thanks. So where do the "nicknames" currently get displayed? As a further suggestion, how about making the picture representative of the actual JLink? At the moment, it the always seems to be a JLink-PRO. How about actual pictures of Base, Plus,…
  • SEGGER - Nino -

    Replied to the thread J-Link Flasher -- erase flash.

    Post
    Hello, Thank you for your inquiry. Quote from rseedle: “VTref=0.000V ” This indicates that the target device is not powered correctly or that the reference voltage is not fed back to the J-Link on Pin 1:
  • SEGGER - Nino -

    Replied to the thread Qualcomm Atheros IPQ8065 - Error: CPU-TAP not found in JTAG chain.

    Post
    Hello, Thank you for your inquiry. The IPQ8065 is currently not supported by J-Link which is why you don't see it in the device selection. FYI the core is a Cortex-A15, not ARM7 (ARMv7 and ARM7 have different meanings). So with a bit of luck connection…
  • rseedle -

    Posted the thread J-Link Flasher -- erase flash.

    Thread
    I am trying to erase the flash on my NXP MK64FN1MOXXX12 in J-Link Commander. Any ideas what I am doing wrong ? SEGGER J-Link Commander V6.44f (Compiled Apr 12 2019 17:17:37) DLL version V6.44f, compiled Apr 12 2019 17:17:02 Connecting to J-Link…
  • owain-incus -

    Replied to the thread Debugging bootrom and application at same time.

    Post
    Also assuming I have selected my application to debug; where is it specified the type of reset that will be done when I hit the reset button of the debugger. I assume I want to have a real hard reset causing control to come up via bootrom. Is this the…
  • SEGGER - Nino -

    Replied to the thread Give "friendly" names to JLinks?.

    Post
    Hello, Thank you for your inquiry. You can set a Nickname to your J-Link via the J-Link Configurator. However the nicknames will currently not be displayed in the default USB selection window (the screenshot you posted). We will put this request on our…
  • SEGGER - Nino -

    Replied to the thread Connect STLInk to jtrace connector.

    Post
    Hello Julien, Thank you for your inquiry. If I understood you correctly you are looking for something like this: segger.com/products/debug-prob…/19-pin-cortex-m-adapter/ Is that correct? If yes it can be ordered in our webshop. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Best way to send a binary file with RTT to the MCU?.

    Post
    Hello Tim, The RTTViewer and RTTClient are not meant to be used that way. However you can use the J-Link SDK and create your own application that would allow something like that: segger.com/products/debug-prob…nk/technology/j-link-sdk/ Best…
  • Hello, Thank you for your inquiry. Such an issue is not known to us. Please be aware that this forum is not our official support channel. As you seem to be working for a silicon vendor we suggest using our official support channel. For more information…
  • SEGGER - Nino -

    Replied to the thread [SOLVED] JlinkScript for TI RM4x processors.

    Post
    Hello Chris, Thank you for your inquiry. We can provide you with the init script used by J-Link software for reference but not in this public forum. I will send you a PM with further information. For future support related inquiries we suggest using…