Recent Activities

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • SEGGER - Schoenen -

    Replied to the thread Updating GUI_App.c not working.

    Post
    Hi, Do you get out of GUI_Delay()? I could imagine that the timing related functions are not correctly implemented and GUI_Delay() waits forever. Search for GUI_X_Delay() and GUI_X_GetTime(). GUI_X_GetTime() has to return a 1ms tick, either provided…
  • kraiskil -

    Replied to the thread Profiling CortexM0 with Ozone.

    Post
    Hi, thanks for confirming this. I looked into SystemView and RTT. If I understand correctly, I can get coarse-grained function execution times recorded with it, but only if I manually instrument the source code of the functions to monitor? While…
  • Pieter Eggermont -

    Posted the thread LISTVIEW - different styles.

    Thread
    Would it be possible to have, in a listview, 2 different styles on the rows? I mean, one row with an icon and text -> different column width definitions and the other row with other column definitions? See attachment for a better view of what I mean :)
  • sagerchr -

    Posted the thread Updating GUI_App.c not working.

    Thread
    Hej, i´m running stm32f469i-Discovery Board with CubeMX generated code in SW4STM32. When i run the source code below i will just get something like when i execute the code below: ---------------------------------- |Hello…
  • thomask77 -

    Posted the thread ST-Link Reflash Utility for ST-LINK V3E ?.

    Thread
    Will there be a ST-Link Reflash Utility for the new ST NUCLEO boards?
  • Hello Kevin, You are welcome. As the initial question has been answered this thread will be closed now. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Ozone 2.70a: unable to get Project.RelocateSymbols() working.

    Post
    Hello, Thank you for your inquiry. We were able to reproduce the issue. There was an error in how the command was handled. It will be fixed in the next Ozone version. There will be two limitations when this command may be used. 1. it must be called…
  • Hello, Thank you for the response! >Please not that this is *no* support forum! Also the J-Link that you are using is out of support period for over a year. So please understand that we can't offer prioritized assistance in such a case... Wow! I…
  • Hi Nino, Many, many thanks for saving me much time on this! Kevin
  • Hello, Please not that this is *no* support forum! Also the J-Link that you are using is out of support period for over a year. So please understand that we can't offer prioritized assistance in such a case... The dropping of data over Channel 1 with…
  • Hello Kevin, Thank you for your inquiry. We use the Samtec FTSH-110-01-F-DV in our designs. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread [J-Trace] [Texas Instruments AM335x] Compatibility.

    Post
    Hello, Thank you for your inquiry. Generally that target device should be tracable with our J-Trace PRO Cortex probe. Could you name the S/N of your probe for verification? For that particular device we do not have a trace example project yet so you…
  • SEGGER - Nino -

    Replied to the thread linker creates loadable section even when I say load ="no".

    Post
    Hello, Thank you for your inquiry. It is correct that the linker will create a section there, but it will not be downloaded. It is just information for the linker not to place code there. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread [SOLVED] Cylic Update of local/global variables.

    Post
    Hello, Great to hear that you are up and running again. This thread will now be marked as solved. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Profiling CortexM0 with Ozone.

    Post
    Hello, Thank you for your inquiry. Cortex-M0 devices unfortunately lack any kind of hardware tracing capability. That is why nothing happens in Ozone. Optional trace features are implemented in Cortex-M0+ and higher. Nonetheless we provide SEGGER RTT…
  • SEGGER - Nino -

    Replied to the thread [SOLVED] Stack pointer is setup to incorrect alignment.

    Post
    Hello Peter, Good to hear that you are up and running again. It appears that I-Jet simply ignores the error and works around it. We on the other hand will tell you if the IDE tells J-Link something "illegal" to do ;) This thread will be marked as solved…
  • Karim -

    Replied to the thread Polygon Rotation.

    Post
    Thank you Alex. I think I got. The pivot point is set by how we define the polygon points. Thank you very much about that sample code and your guidance.
  • LexaGb -

    Replied to the thread Polygon Rotation.

    Post
    Yes, we could say that, I suppose. I would say, the term of the origin point is applicable when drawing the polygon. Rotation of the polygon is doing in relative coordinates. When we are drawing rotated polygon we set the origin point again for drawing…
  • Karim -

    Replied to the thread Polygon Rotation.

    Post
    Thank you Alex. It was a very good sample code. As I understood we can set the origin point by using GUI_DrawPoint() function. And after that the rotation will be done according to that point. Did I understand correctly?
  • LexaGb -

    Replied to the thread Polygon Rotation.

    Post
    Hello, the coordinates of polygon are considered related to the origin point when drawing the polygon. When rotating the polygon the origin point is the pivot point of the polygon that can be inside and outside the polygon depending on its…