Recent Activities

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Pieter Eggermont -

    Replied to the thread LISTVIEW - different styles.

    Post
    Hi Alex, Thanks for the support in my issue. The window I want to create got 2 different Row styles, each 2 columns but with different content. As you can see one row style got left small icon and right a text. Depending on the amount of "warnings" or…
  • LeoWu -

    Posted the thread emWIN + freeRTOS + NXP i.MXRT.

    Thread
    Hi Segger, I am porting emWIN to freeRTOS on NXP i.MXRT MCU, i encountered some problems and need your help. when my code execute "WM_CreateWindowAsChild", a port of RAM memory will be used by this function ex: 0x806FC000 but I have checked…
  • bgolab -

    Posted the thread j-link edu mini (V6.52e) - CPU could not be halted.

    Thread
    Hi, I wonder what would be a reason for stopping the communication with the target MCU after 4-5 sec. I use Keil uVision 5.28. The log below contains the relevant information. Running with Code Size Limit: 32K Device "STM32L031K6" selected. JLink…
  • SilT -

    Posted the thread How to make Flash Placement file..

    Thread
    Hello, I am a hardware engineer and not very familiar with software or firmware other than the very basics. I am trying to move a project from the Keil IDE to SES. I am working with Nordic's NRF52832 for this project. This project complies, flashes,…
  • joechan -

    Posted the thread jLink Ultra+ is not programming faster than jLink plus.

    Thread
    I have used the JLink plus to program the Nordic 52832, the image size is about 500K. I use the J-Flash V6.20b software and the default settings. It takes about 10 seconds for the "Program and Verify". I then purchased the JLink Ultra+, hoping it will…
  • Hakan -

    Posted the thread Delete old bitmap,display new bitmap.

    Thread
    Hello, I want to delete the previous bitmap and show the new bitmap. I used the callback function, but I couldn't. How can I do it. my code not work. static void _cbDialog(WM_MESSAGE * pMsg) { switch (pMsg->MsgId) { case…
  • thomask77 -

    Replied to the thread ST-Link Reflash Utility for ST-LINK V3E ?.

    Post
    Here's the user manual: st.com/content/ccc/resource/te…lations/en.DM00493601.pdf There is no 10 pin connector for the target processor. Of course, all STM32 pins are available on pin headers, so you could use jumper wires to connect an external J-Link…
  • LexaGb -

    Replied to the thread LISTVIEW - different styles.

    Post
    Hello, not exactly clear what you want, but if you need "Warning Description" instead of the header then just place another widget (text or image...) over the header. If you need to do something more complicated, exactly a row with "one column style"…
  • godmode -

    Replied to the thread [J-Trace] [Texas Instruments AM335x] Compatibility.

    Post
    Hello, My J-Trace probe SN: 932000322 I have configured pins as TPIU, enabled the clocks but I do not see 150MHz clock on TRACECLK pin which should be outputted from traget (not J-Trace)? All trace pin configuration is compiled and run from flash. How…
  • Hello, Quote from unebonnevie: “Wow! I didn't know that! What are my alternatives to get support? ” You could get a new probe so the support period gets reset. For that we offer a trade in program: segger.com/purchase/trade-in-program/ Quote from…
  • SEGGER - Nino -

    Replied to the thread ST-Link Reflash Utility for ST-LINK V3E ?.

    Post
    Hello, Quote from thomask77: “Sad to hear that. The small NUCLEO-32 boards do not have the MIPI-10 connector. ” That is interesting. ST assured us that all ST-Link V3 boards will have the 10 pin connector for external probes which was the reason…
  • LexaGb -

    Replied to the thread Dropdown widget issues.

    Post
    Hello, quite simple. C Source Code (35 lines)Alex.
  • Electrons4me -

    Replied to the thread Dropdown widget issues.

    Post
    @EmWin support, I did not get any replies from you so I'm assuming that LexabGb is correct and I have to put all my own drawings and text in the callback. Would you have an example where I could see how you do this so I can replicate? @LexabGb, thanks…
  • Hoxford -

    Replied to the thread J-Link Debugging the R5 core on the Xilinx Ultrascale+ XCZU7EV7.

    Post
    After further evaluation, the memory access problems are due to the Ultrascale+ XCZU7EV7 DDR memory requiring a init procedure before it can be accessed. I'm working on creating a jlink init script using the Xilinx SDK's init process as a guide. Once I…
  • thomask77 -

    Replied to the thread ST-Link Reflash Utility for ST-LINK V3E ?.

    Post
    Sad to hear that. The small NUCLEO-32 boards do not have the MIPI-10 connector. Also, I think the Reflash-Utility was a great marketing tool for both Segger and ST.. at least that's how I tested Ozone/SystemView and convinced my company to buy some…
  • scotty -

    Replied to the thread J-Scope issues.

    Post
    Hi Arne, today, I found the time to evaluate the beta version 6.11m of J-Scope. My investigations showed some differences related to version 5.10d. (Compare the above mentioned items.) 1) OK, the problem with the floating pointer numbers is solved. I…
  • crivelma -

    Posted the thread LISTVIEW_SetItemBitmap.

    Thread
    Hi all. I have an issue regarding the creation of a page with emWin that is using LISTVIEW_SetItemBitmap. I want to put all bitmap on flash filesystem and load them one by one with LISTVIEW_SetItemBitma. The fact is that the function require a (const…
  • sagerchr -

    Replied to the thread Updating GUI_App.c not working.

    Post
    Hey, i tried without calling the GUI_Init() mulltiple times. I didn´t helped. Just to make sure that no hardware configuration problems are present i can tell that i followed these steps to create the source code.
  • SEGGER - Schoenen -

    Replied to the thread Updating GUI_App.c not working.

    Post
    Hi, Is GUI_Init() beeing called multiple times? You Do this in your appliaction. I know that in some ST examples GUI_Init() is getting called before MainTask(). Call it just once. Regards, Sven
  • Pieter Eggermont -

    Replied to the thread STM32F7XX.

    Post
    We had indeed a duplicate :) Case closed :)