Recent Activities

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Hello, we currently do not have an API in the Flasher Portable Plus to read an IDCODE from a file. Such an API is under development, but it does not have a high priority and I cannot give you a schedule. If you are interested in a faster development…
  • SEGGER - Nino -

    Replied to the thread Example for Interrupt in empower board.

    Post
    Hello, How to enable interrupts on your target device can be found in the corresponding target reference manual from NXP. This is a target specific questions which we can't provide information for. For Guides and Examplecode there are literally millions…
  • SEGGER - Arne -

    Replied to the thread I2C programming EEprom with Flasher ATE.

    Post
    Hello Bjarne, it is possible to directly program this EEPROM using the Universal Flashloader: segger.com/products/production…e/#universal-flash-loader (24C512 should work) It is also possible to indirectly program the EEPROM, but this requires a…
  • SEGGER - Nino -

    Replied to the thread How to use precompiled libraries.

    Post
    Hello Roger, Thank you for your inquiry. The Additional Input Files approach is the correct one. From the error message it appears that the target device you are using does not have a floating point unit but with the library you are trying to generate…
  • Hello, Good to hear that connection is working now. J-Link Remote Server has only a timeout if server replys take longer than 5 s. So if the ping between Client->Tunnel->Remote Server is more than 5 seconds it can come to timeouts but only after a…
  • SEGGER - Nino -

    Replied to the thread Error starting process.

    Post
    Hello, Thank you for your inquiry. Your gcc path in Embedded Studio has a mix of backward and forwardslashes. Try using forwardslashes only. Does it work then? Best regards, Nino
  • Hello, Thank you for your inquiry. Such an issue is not known to us. Could you provide the serial numbers of the J-Links you are using? Are you using the remote server in tunnel mode or in local LAN? How is your connection sequence? - J-Link1…
  • SEGGER - Fabian -

    Replied to the thread Jlink base probe can't connect LPC55s69 1B.

    Post
    Hi, Thank you for your inquiry. Please note this is not a support forum, but a community forum. For more information please refer to my signature. Regarding your issue: There is no issue known to us regarding the LPC55S69 series. I am not entirely…
  • SEGGER - Nino -

    Replied to the thread [SOLVED] Use -include in project.

    Post
    Hello, Thank you for your inquiry. We received your inquiry via our support system in parallel. We will continue discussion there as you are in valid support period and this thread will be closed. Please try to stick to one communications channel in…
  • pyang -

    Replied to the thread [SOLVED] Use -include in project.

    Post
  • SEGGER - Fabian -

    Replied to the thread JLink Supported STM32F051x4 MCU.

    Post
    Hi Mehmet, Thank you for your inquiry. The "x" is just a place holder for a letter or for a number (in this case a letter). There are multiple STM32F051x4 devices, we do support: forum.segger.com/index.php/Att…8dea81f3cce0e17ab1b917bb3 Does this answer…
  • SEGGER - Fabian -

    Replied to the thread JlinkExe erase Command fails with RAM check.

    Post
    Hi, Thank you for your inquiry. Such an issue is not known to us. Our Cortex-M Trace Reference Board uses the same chip and there have been no issues reported. It is most likely that this issue is connected to your custom board. Do you experience the…
  • awneil -

    Replied to the thread Start with SES stm32f103vc.

    Post
    Does the code build? If yes, Can you download it? If yes, Does it run? Can you use the debugger to see what's happening ?
  • awneil -

    Replied to the thread [SOLVED] Use -include in project.

    Post
    can you be more specific? eg, link to the GCC documentation of that option
  • grobot -

    Posted the thread How to use precompiled libraries.

    Thread
    Hi, I'm a new user of Embedded Studio using it mainly for Nordic Semiconductor BLE devices. Now I'm trying to add the BSEC library from Bosch Sensortec to my project. But it won't work. The BSEC is a precompiled library which I added here: Project
  • icwiener -

    Posted the thread Ozone Data Sampling Number Formatting Inconsistent.

    Thread
    Hi, Ozone 3.10d here. In the Data Sampling view the numbers formatting is inconsistent. The small gap for thousands is there for some columns but e.g for the Average column, it is missing. The Changes column is weird as well. See screen shot. Best…
  • evorontsov -

    Replied to the thread Analog status LED on display.

    Post
    Dear Florian, thanks for answer. Initially I thought about using "LED" within dialog window. Tried to use gif/png pics, but finally I modified project and use GUI_FillCircle function for that. Best regards Evgenii
  • icwiener -

    Posted the thread Ozone Data Sampling Change Counter becomes negative.

    Thread
    Hi, Ozone 3.10d here. when a debugging session with Data Sampling lasts a bit longer, the "# Changes" counter overruns and starts counting negative numbers towards 0. The reason is that the Changes field seems to have the same data type as the watched…
  • JennieZhang -

    Posted the thread Jlink base probe can't connect LPC55s69 1B.

    Thread
    Hi support, the probe is: segger.com/products/debug-probes/j-link/models/j-link-base/ This tool can connect LPC55S69 0A without issue, but can't connect 1B version. Using Jlink commander to test the connection, run SWD command, it failed. Jlink driver…
  • icwiener -

    Replied to the thread Cannot quit Ozone after J-Link lost connection to target.

    Post
    Hi, now using 3.10d I just had this happeing to me right in the middle of a debugging session. No lost connection, no Windows hibernate. Ozone just stopped sampling data and now I can neither stop debugging nor quit the application. There is no output…