Recent Activities

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Hello again! When using the assembly version V2.52f of SEGGER_RTT_WriteSkipNoLock, SystemView V2.52d stops with an "Invalid packet received" error. When SystemView recording starts for the first time, I get *some* correct records until the error…
  • SEGGER - Nino -

    Replied to the thread J-Trace and IAR.

    Post
    Hello Gawie, Yes IAR will utilize the 64 MB on board buffer so depending of the target speed and created trace data this can be enough to reconstruct the last couple of seconds. Best regards, Nino
  • Niob -

    Posted the thread Loadbin not working on ATSAMR21E19A.

    Thread
    Hello, I'm unable to use loadbin on an ATSAMR21E19A. I'm able to manually write and read memory but not using loadbin. Logs: Source Code (56 lines) Brainfuck Source Code (57 lines)Binary was compiled using Atmel Studio 7 and also flashing directly…
  • thomask77 -

    Posted the thread GCC support missing in SEGGER_RTT_ASM_ARMv7M.s.

    Thread
    Hi! I just downloaded the new SystemView 2.52f, and tried to compile it using a GCC toolchain. Apparently, the assembly file misses support for GCC. The easy fix is to just use the same settings for clang and GCC: C Source Code (1 line) Otherwise, a…
  • gawied -

    Replied to the thread J-Trace and IAR.

    Post
    Hi Nino Thanks for your prompt response. Am I correct that the J-Trace has a 64 MB on-board trace buffer? If so, can one get IAR EWARM to work with that? The first J-Traces, without streaming trace, made use of a on-board buffer and it work quite well…
  • DSmidgit -

    Posted the thread J-FLASH not reading external memory LH75401.

    Thread
    Hi, I have a custom board with an old LH75401 processor and 2Mb of external Flash. When I try to connect to it soetimes connects but most of the time it does not. When it does it connects really slow. Even when i set j-flash to automatic speed. I can…
  • SEGGER - Nino -

    Replied to the thread [SOLVED] SFR display not working for register arrays of nRF52840.

    Post
    Hello Dirk, Great to hear that you are up and running again. As the initial inquiry has been solved this thread will be closed now. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Sow to determine MAC address used for SES License.

    Post
    Hi Russ, Oh OK, I assumed you already gave our sales team the MAC addresses, sorry for the confusion. When choosing the "right" MAC address we recommend choosing a physical one which is build into your PC, like the Ethernet controller or build in…
  • SEGGER - Nino -

    Replied to the thread [SOLVED] Ozone.

    Post
    Hello, Thank you for your inquiry. We received your inquiry via e-mail in parallel. For future inquiries please try to use only one contacting channel, otherwise it can happen that information gets lost between channels which can lead to unnecessarily…
  • SEGGER - Nino -

    Replied to the thread J-Trace and IAR.

    Post
    Hello, Thank you for your inquiry. IAR unfortunately does not support any streaming trace features. For the best trace experience we recommend using Ozone the J-Link debugger. It can be used for free with a J-Trace PRO and works with IAR output formats.…
  • dzabel -

    Replied to the thread [SOLVED] SFR display not working for register arrays of nRF52840.

    Post
    Hi Nino, thank you for spending all the time on this issue! It seems I had a different version of the nRF CPU Support Package installed. It looked different from your image, for example, it had a subfolder "Registers", but lacked the register files you…
  • JimJamUrCode -

    Replied to the thread SWIPELIST not scrolling reliably.

    Post
    Hello again, As I was prepping a demo of this problem, I found the issue... Source Code (10 lines)When I first built this project, I implemented the GUI_Tick() function in a portion of code that STM32CubeMX destroyed when rebuilding my project. It went…
  • gawied -

    Posted the thread [SOLVED] Ozone.

    Thread
    I am new to Ozone and am busy checking it out with my brand new J-Trace for Cortex-M - yeah!!! Worked through your tutorial and got every thing setup - all is well and looks great. My question: Is it possible to load and debug more than one .elf (.out…
  • gawied -

    Posted the thread J-Trace and IAR.

    Thread
    I just want to find out if IAR EWARM 8.32.2 supports streaming trace with J-Trace Pro for Contex-M, as I am having difficulty to set it up.
  • ewright -

    Replied to the thread undefined reference to `IMAGE_SetPNG'.

    Post
    Thanks for the response. I was pulling in png images using the guibuilder. the png package fixed the error. Why is the PNG not included by default? Is it not recommended or not popular?
  • schmalr -

    Replied to the thread Sow to determine MAC address used for SES License.

    Post
    Nino, You missed the point of the question. To get a license file, I must first provide a MAC address to which it will be locked. If a PC has multiple MAC addresses, how do I determine which one to provide? Russ
  • SEGGER - Nino -

    Replied to the thread Issue related to debugging GHS compiled elf on S32K.

    Post
    Hello, Thank you for your inquiry. Native J-Link support in GHS debugger has been removed by Greenhills a while ago. So at this current point in time we can't give any assistance with Greenhills setups as they are no longer supported. For any setup…
  • SEGGER - Nino -

    Replied to the thread JLink OB on Nordic nRF52 Dongle on Mac.

    Post
    Hello, Thank you for your inquiry. Quote from Mron: “I've seen this as an old issue that was fixed about 4 years ago with nRF51 Dongles. Any help is appreciated. ” If that is the case then it should work with nRF52 as all eval boards known to us…
  • JimJamUrCode -

    Replied to the thread SWIPELIST not scrolling reliably.

    Post
    I have just checked the version of emWin, in this project it’s 54401. I will try to reduce the timing of my interrupts to be closer to the 25 milliseconds you have in your PIDConf. Right now my interrupt fires about once every 15 milliseconds. Today…
  • SEGGER - Nino -

    Replied to the thread J-Link support for ZGM130S037HGN.

    Post
    Hello, Thank you for your inquiry. We can't find any information about the ZGM130S037HGN. Could you provide a reference link? What Coretype is it? Currently supported devices can be found here: segger.com/products/debug-prob…pported-cpus-and-devices/