Recent Activities

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • LexaGb -

    Replied to the thread Text not displaying after hiding widget.

    Post
    Works on my side, at first glance, in simulation version 5.44. Maybe additional code from your project affects the text visibility. Your new code using TEXT widgets instead of drawing text in WM_PAINT of the dialog. This updates the contains of the TEXT…
  • bio_med -

    Replied to the thread Text not displaying after hiding widget.

    Post
    Alex, Thank you for your help with that. I tried it out. I still can't see the text after progress bar. I don't understand why. But I gave this following code a try and it works. Source Code (95 lines)
  • LexaGb -

    Replied to the thread Text not displaying after hiding widget.

    Post
    Hello, function for displaying text GUI_DispStringAt() is the drawing function and you should use any drawing functions in WM_PAINT message handler of your dialog. When you use GUI_Delay() from WM_INIT_DIALOG it calls dialog update and you see the…
  • bio_med -

    Posted the thread Text not displaying after hiding widget.

    Thread
    Hi all, I am trying to create a splash screen for one of my projects. I am using widgets to display logo, progress bar and then trying to display test after hiding widget with logo and deleting progress bar. For some reason I don't see any text being…
  • SEGGER - Nino -

    Replied to the thread Timestamp from PC.

    Post
    Hi, Indeed. When using the nRF52-DK it is even easier as the J-Link OB that is used on that board comes with the CDC feature out of the box as you already suggested. So you can directly communicate with the device via the COM port that is opened:
  • SEGGER - Nino -

    Replied to the thread Internal flash memory erased using J-Link Commander.

    Post
    Hi, This would of course be only a one time pop up which would then be saved for future sessions for that device in the current setup context. Best regards, Nino
  • awneil -

    Replied to the thread Timestamp from PC.

    Post
    Looks like a cross-post from the Nordic forum: devzone.nordicsemi.com/f/nordi…-time-from-pc-to-nrf52840 :?:
  • awneil -

    Replied to the thread Internal flash memory erased using J-Link Commander.

    Post
    Quote from SEGGER - Nino: “we are going to improve J-Link softwares behaviour in future so you are prompted with a pop up asking you which areas are considered active and should be erased when a simple erase is called ” Hmmm ... that could quickly…
  • SEGGER - Nino -

    Replied to the thread Ozone ETM trace limit.

    Post
    Hello, Quote from rabbitlennon: “If I buy SDK now, can I get a free update with that feature? ” J-Link SDK comes with 6 months of free updates. After that the license needs to be renewed. Quote from rabbitlennon: “Any way to give a distinct…
  • SEGGER - Nino -

    Replied to the thread Timestamp from PC.

    Post
    Hello Bar, Thank you for your inquiry. You have several options here. 1. Arm Semihosting with operation SYS_TIME. 2. Create an IO option on your target device that shows as com port. If you want to do this in software and your target device has USB you…
  • SEGGER - Nino -

    Replied to the thread [SOLVED] Ozone on debian buster segfault.

    Post
    Hello, Great to hear that you are up and running again. We will consider this thread as solved now. Best regards, Nino
  • Le0 -

    Replied to the thread STM32 and mass erase.

    Post
    Hello. I double checked and couldn't really find any instance where we would randomly change these bytes. Is JLinkExe looking just at these option bytes or others also? Bits 7:0 RDP: Read protection level0xAA: Level 0, read protection not active0xCC:…
  • Kusum Swarankar -

    Replied to the thread Cursor is not moving if only space is entered.

    Post
    HI, This is not the problem. I was using the cursor right aligned so i was not able to see the space taking. Thank you.
  • bar -

    Posted the thread Timestamp from PC.

    Thread
    Simple question. Is there a way to get a timestamp, directly from the PC threw the debugger, or the com port? I want to use it to start a RC calander RThanks Bar.
  • Timur -

    Posted the thread J-Link RTT output completely stops working after running for a long time.

    Thread
    Our project uses an EFM32WG940F256 microcontroller on a custom board. This board is connected via SWD to a J-Link device, which is connected via USB to a computer that runs Linux. We have a relatively big "bare-metal" program on the MCU which outputs…
  • Kusum Swarankar -

    Posted the thread Cursor is not moving if only space is entered.

    Thread
    Hi, I have created one alphanumeric keypad window. it has edit widget. if i am typing only space here i.e first input itself is space and continue typing space, cursor is not not moving. but internally it is storing in the edit buffer. whereas if i type…
  • billium -

    Replied to the thread [SOLVED] Ozone on debian buster segfault.

    Post
    Hello Nino Thanks a lot for this. Yes it works in both the Ozone terminal and the standalone viewer. After trying this I found I had my system clock wrong. I think that it worked in the standalone SWO viewer made me think the STM32 settings were…
  • rabbitlennon -

    Replied to the thread Ozone ETM trace limit.

    Post
    Quote from SEGGER - Nino: “You can get around this by exporting the instruction trace data after each stop. This can also be automated. See here for more details: wiki.segger.com/Automated_Tests_with_Ozone ” Thanks for the guide. I used…
  • 40490FDB -

    Replied to the thread SAMA5 ETB trace.

    Post
    I have two SAMA5D2 Xplained boards, tried them both. I have tried all combinations of open and closed JP1 and JP2. I have installed Ozone on another PC, still not working. I also have two SOM1-EK dev kits, might try running the trace example on…
  • Bit -

    Replied to the thread TTF FONT issue?.

    Post
    Hi, Look at your picture, like the simulator used. The simulator is normal, the microcontroller display is abnormal. Using other fonts also has the same problem. Attach a font file. thanks a lots.