Recent Activities

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • plainSpeak -

    Replied to the thread printf prevents UART app working when debugger not connected.

    Post
    Removing the lines from thumb_crt0.s made no difference to printf However I could no longer find the HELPER lines in the disassembler window showing that the modified files had been compiled Back to the drawing board! Rob
  • plainSpeak -

    Replied to the thread printf prevents UART app working when debugger not connected.

    Post
    Thankyou for this suggestion; I hit a snag. _DoInit is a called through macro INIT() in Segger_RTT.c. However in my configuration INIT() is not called; I cannot add breakpoints in the INIT() block. Not sure why. RTT is enabled in debug options. And…
  • Emin -

    Replied to the thread How to set image as background of TreeView widget item.

    Post
    Hi Alex, I had tried to implement your code to my treeview but i could not succeed. I have a few questions. I will be appreciate if you answer me kindly. Before the questions i will inform you about my application; I use key reaction to control widget…
  • Jordan -

    Posted the thread RTT viewer connected but no output with STM32H743.

    Thread
    Hi, I used RTT files from JLink version 6.42c (working fine on a STM32F407 project) now i tried the same files on a STM32H743 _SEGGER_RTT symbol is placed into RAM section 0x2000.0000 but no output is visible on RTT viewer any ideas? Thanks... just…
  • jev -

    Replied to the thread printf prevents UART app working when debugger not connected.

    Post
    Huh, sounds like it doesn't take the settings from sdk_config.h. do you define USE_APP_CONFIG by any chance? Let's check if something weird is happening: 1. Load your application in the SES debugger. 2. Set a breakpoint on _DoInit. 3. Run until the app…
  • DSmidgit -

    Replied to the thread J-FLASH not reading external memory LH75401.

    Post
    I can, somehow, connect with J-commander and the read the external FLASH. But I cannot erase or write it. When I try I get Unspecified error -1. Is there a command to erase external FLASH and write the new content? To connect I used the following…
  • Hello, Thank you for your inquiry. Such an issue is not known to us. Generally our software stays backwards compatible so if you use the exact same settings in both versions it should keep working. You seem to be working for a silicon vendor, in this…
  • SEGGER - Nino -

    Replied to the thread J-Link command enhancement - trivial but very helpful null:= step.

    Post
    Hello DG12, Thank you for your feedback. We will discuss internally if this could be implemented in future. However currently we see the issue that it could break backwards compatibility to customers using commands scripts which could result to…
  • SEGGER - Nino -

    Replied to the thread j-link list breakpoints.

    Post
    Hello, Did you try to open the mentioned web control link in your folder? Quote from Wiki: “A web version is also available via localhost:19080/ on all platforms. ” Which J-Link software version are you using? Could you try the latest one? Best…
  • SEGGER - Nino -

    Replied to the thread J-Link support for ZGM130S037HGN.

    Post
    Hello, Quote from cvicens: “The problem is that I don't have an .elf loader file. Where would I get the appropriate file for my device? ” You need to write your own. How is explained here: wiki.segger.com/Adding_Support…ng_SEGGER_Embedded_Studio There…
  • SEGGER - Nino -

    Replied to the thread J-FLASH not reading external memory LH75401.

    Post
    Hello, Thank you for your inquiry. The LH75401 is an ARM7 which have some specialties when it comes to connection speeds. Setting it to automatic speed will not work as the automatic speed will most likely be to fast. We recommend using a connections…
  • marcopazzi -

    Posted the thread SPINBOX and Set Hours use.

    Thread
    Hello to anyone, I'm quite new in emwin library, so I've a question. I thought to use spinbox for set hours and minute (12:00), I would not use (for graphical space) une spinbox for hous and one spinbox for minutes, I would use only one spinbox for sets…
  • Niob -

    Replied to the thread [SOLVED] Loadbin not working on ATSAMR21E19A.

    Post
    Issue is resolved. Had nothing to do with JLink. NVMCTRL_BOOTPROT was set to 0x02, set to 0x07 to overwrite bootloader.
  • pgherardi -

    Replied to the thread emVNC client.

    Post
    Any news ?
  • timurlocumi -

    Replied to the thread RTT slow not usable anymore.

    Post
    Sorry I did not get the Email Notification that you have replied. Regarding your questions: We have been using RTT Viever Mainly. And what ever is used within Segger Embedded Studio to show the RTT output. Both very laggy. Alternative for us is UART…
  • Barak14 -

    Replied to the thread RTT slow not usable anymore.

    Post
    I have been using the latest v6.42d and there is still a lot of lag in the RTT viewer compared to say v6.32i Actually I ran another test, 6.32i RTT Viewer is about 1000% faster than anything released after that - 6.42d and 6.43a are both hopelessly…
  • plainSpeak -

    Replied to the thread printf prevents UART app working when debugger not connected.

    Post
    Jev Belated thanks for the sound advice. Unfortunately it did not fix it. I found a similar suggestion from Nordic: devzone.nordicsemi.com/f/nordi…default_mode-blocking-app I get the same problem when I include the lines below in in sdk_config.h. The…
  • Please use the updated image of fail connection
  • Dear All We are using a simulation of A9 core based on Cadence Palladium, its identical to working with an actual A9 core except for speed. When connecting using 642d, the connection fails. See attached image for details. However When connecting using…
  • DG12 -

    Posted the thread J-Link command enhancement - trivial but very helpful null:= step.

    Thread
    As there seems to have been recent activity in the j-link application, I re-issue this request perhaps more nearly. When using j-link from the command line (like Mac OS terminal), pressing enter (without any other characters rather than moe, men, set,…