Recent Activities

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • icwiener -

    Posted the thread Cannot quit Ozone after J-Link lost connection to target.

    Thread
    Hi, when I am connected to a target and debugging in Ozone via J-Link Pro, and then the target is shut down or the connection is lost for some other reason, Ozone is stuck and cannot be used anymore. - Debug.Stop(); has no effect - trying to quit the…
  • bio_med -

    Posted the thread Reading from SD card.

    Thread
    Hi, I am trying to display images from SD card using SPI. I saw several example code but none of them seem to work. I have included emFile and emWin paths under build settings. Also, when I was trying to use sample codes that are available on this…
  • t2ft -

    Replied to the thread GUI_Init() never returns (again) [SOLVED].

    Post
    Thank you for the clarification. Now since I know what I have to look for, the search items "GUI_Init()" and "CRC" in the ST-Communinty Formum shows up the appropriate answers. Shame on ST that they did not point out their use of CRC checks more…
  • satheesh -

    Posted the thread Trace HW not present - ARM cortex M4.

    Thread
    Hi, I am working on ARM Cortex M4 development board provided by Vorago technologies. I am using keil IDE with Jlink/J-trace Cortex. When I enable the "Trace"(look in attachement for settings), the debugging session is getting terminated with an error …
  • SEGGER - Nino -

    Replied to the thread Trace timeline accuracy.

    Post
    Hello, You are right, good catch. The Timestamps checkbox should not be there and has no functionality for tracing via trace buffer. This will be removed for the next Ozone release. Quote from thomask77: “If it's not on the same timeline, data…
  • thomask77 -

    Replied to the thread Trace timeline accuracy.

    Post
    Hi! I haven't checked on 2) yet. But regarding ETF-Trace: forum.segger.com/index.php/Att…3c779f82e2f2fd26ed3ab126c Does that mean, that the Timestamps checkbox does not work for ETF? Then I think that the combined Data sampling/Instruction trace…
  • victorp -

    Posted the thread S32K144 d-flash programming failure.

    Thread
    I work with the S32K144 device. I have a program linked against the lower half of FlexNVM (address range 0x10000000:0x10008000), and flash it with the J-Link loadfile command. When the FlexNVM is configured as D-flash only (no eerpom), everything works…
  • SeMoZi -

    Posted the thread STM32G431CB / Flash issue.

    Thread
    Hello, I am using J-Flash V6.60f to flash a STM32G431CB (SWD interface) with a given .hex file. Everything goes well until "Restoring" (message at the end of the message): ... Start of restoring - ERROR: Timeout while restoring target, RAMCode did not…
  • SeMoZi -

    Posted the thread STM32H750 - Writing DTCM.

    Thread
    Hello, I am using J-Flash V6.60f to flash a STM32H750VB with a given .hex file (with no access to source code / project). When I try to Program/Verify, I get following error message (complete message after signature): ... ERROR: Selected Data…
  • Michael_adhoc -

    Posted the thread Segger RTT no output when using Jlink-Remote Server.

    Thread
    Hi, we are using segger remote server to run our builds on a different machine (see below). The deployment and the debugging works fine but unfortunately we are not able to get any rtt output from the JTrace. We tried to use the rtt client and the rtt…
  • lawrence_fp -

    Posted the thread JLINK Unspecified Error -1.

    Thread
    Hi, I'm getting the following error after flashing from a commander script Unspecified error -1 and was wondering if there is an issue with my commander script? When I keep re-running the commander script I always get the same error, until I open up…
  • Hello, Thank you for your inquiry. Currently only one symbols file can be loaded at a time: [SOLVED] [Ozone] Possibility to load symbols from multiple .ELF files? But it is already on our feature wishlist so in future you will be able to load as many…
  • SEGGER - Nino -

    Replied to the thread Trace timeline accuracy.

    Post
    Hello Thomas, Thank you for your inquiry. 1: That is expected as with 3.10 the timeline was joined with the data graph and power graph which both have their own accurate timebase. Now with tracing via buffer there is no timestamp information available.…
  • Arjuman -

    Replied to the thread How to take screenshot of the display.

    Post
    Hi, Thanks for the reply. We used f_write() to write into SD card instead of WriteFile(), but the BMP image is not getting stored on the SD card. Can you please help.
  • Hi, I'm using a freertos demo with trustzone in Nuvoton M2351 board. The demo link is freertos.org/RTOS-Cortex-M23-NuMaker-PFM-M2351-Keil.html. I want to watch the instruction trace by Ozone. How to import secure and non-secure elf file into Ozone at the…
  • SEGGER - Leon -

    Replied to the thread [SOLVED] SystemView serial port.

    Post
    Hello, You can find more information on how to use SystemView's UART recorder on the SEGGER Wiki: wiki.segger.com/Use_SystemView_UART_Recorder The above article includes a sample Embedded Studio project. Quote from phryniszak: “Is "hello" message…
  • icwiener -

    Posted the thread J-Flash - Failed to erase chip.

    Thread
    Hi, I am using J-Link Pro on an STM32F412 and I am trying to erase the chip with J-Flash. If I select Target -> Manual Programming -> Erase Chip, I get a pop-up dialog doing some work and then an error message pop-up telling me, erasing had failed. The…
  • Avenue33 -

    Replied to the thread Unable to upgrade firmware on J-Link Edu Mini.

    Post
    The J-Link Commander connects successfully to the J-Link Edu mini. The firmware seems to be up-to-date. Source Code (13 lines)However, JLinkConfig still fails to connect to the J-Link Edu mini. How to use the J-Link Commander to force an update and…
  • SEGGER - Schoenen -

    Replied to the thread GUI_Init() never returns (again) [SOLVED].

    Post
    Hi, emWin is completely independent of any hardware and any third party software. Also, there is no license check of CRC init within emWin. The libraries you are using are generated by STM , so I can not say if they build in some sort of license check…
  • thomask77 -

    Replied to the thread STM32H743 DBGMCU register reads as zero when using ETF-Trace.

    Post
    Googling for 0x5C001000 turns up some interesting results.. This might be relevant to you: xor-gate.org/post/stlink-arm-ap-access/ "On the STM32H743 there is an APB-AP on APSEL 2 which I suppose may be present on other STM32's as well. Through this…