Recent Activities

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • awneil -

    Replied to the thread How to Rotate Bitmap Image via emWin library.

    Post
    @ankit_knit - FYI, some general info on image rotation: avrfreaks.net/comment/2515936#comment-2515936
  • awneil -

    Replied to the thread Extra background color.

    Post
    Did you mean to post this in the emWin form :?: emWin related
  • awneil -

    Replied to the thread 'Always Rebuild' - not quite what I wanted..

    Post
    Yes - these are the usual tricks for IDEs which don't have an 'Always Build' option. So it's a bit frustrating that SES does have the option - but it doesn't (quite) do what I want! Does the SES 'Pre Build Step' run only when it's already decided that…
  • SEGGER - Schoenen -

    Replied to the thread emwin bidirectional uses 66628 bytes of RO data.

    Post
    Hi, Unfortunately, there is no way to reduce it. The information is required to distinguish between the different types of characters. Since we cover the UC ranges from 0x0000 to 0xFFFF this table gets quite large. Regards, Sven
  • mtajian -

    Replied to the thread emwin bidirectional uses 66628 bytes of RO data.

    Post
    Thanks Schoenen but it seems a bit high, 66kb. no way to reduce it?
  • SEGGER - Schoenen -

    Replied to the thread emwin bidirectional uses 66628 bytes of RO data.

    Post
    Hi, Yes, when enabling BIDI support emWin needs more ROM because the BIDI algorithm needs some sort of conversion table. So, no mistake from your side. Regards, Sven
  • mtajian -

    Posted the thread emwin bidirectional uses 66628 bytes of RO data.

    Thread
    Hi when i add GUI_UC_SetEncodeUTF8(); and GUI_UC_EnableBIDI(1); to my gui thread, gui__bidi2.o uses 66628 bytes of RO data. I want to know if it's ok , or i have made a mistake. and is there any way to reduce this ro data usage or even using external…
  • SEGGER - Schoenen -

    Replied to the thread How to Rotate Bitmap Image via emWin library.

    Post
    Hi, Unfortunately, it is not possible to rotate images directly with emWin. But, you can rotate memory devices. You need two memory devices. One which holds the image to be rotated and another one as destination which will contain the rotated…
  • gaurav -

    Posted the thread Extra background color.

    Thread
    Hi, I am using functions given below to display a string with background color. I want background color length corresponding to string length but in the end of string some extra length ( 1 character) of background color is coming. Please suggest…
  • ankit_knit -

    Posted the thread How to Rotate Bitmap Image via emWin library.

    Thread
    I want to rotate a Bitmap Image using emWin library. In APIs only linear translation is possible as Bitmap can be display from given location but how to rotate ?
  • rabbitlennon -

    Replied to the thread ETM on LPC55S69 EVK board.

    Post
    Currently, Ozone reported the following coresight components: CoreSight components: ROMTbl[0] @ E00FE000 ROMTbl[0][0]: E00FF000, CID: B105100D, PID: 000BB4C9 ROM Table ROMTbl[1] @ E00FF000 ROMTbl[1][0]: E000E000, CID: B105900D, PID: 000BBD21…
  • jev -

    Replied to the thread 'Always Rebuild' - not quite what I wanted..

    Post
    You could create a small tool (read: a shellscript, a python program or whatever your favorite poison is) that generates a unique timestamp in a headerfile that is included in your software. Run that in each build through the Pre-Build command settings…
  • rabbitlennon -

    Posted the thread ETM on LPC55S69 EVK board.

    Thread
    Hi there, I have a LPC55S69 EVK board and wanted to use the Jtrace to get the instruction trace. Since no trace pin is available on the board, I thought setting trace source to be "trace buffer" should work. Unfortunately, it is not allowed in OZone. I…
  • steve2641 -

    Replied to the thread Ozone ELF Loading Time.

    Post
    We were using Ozone 2.60. I downloaded and tried the latest, 2.62 and, WOW!, so much faster. What used to take 6-8 minutes to load is now loading in <10 seconds. Such a great improvement. Thanks!
  • LexaGb -

    Replied to the thread Fixed widget for all windows.

    Post
    Hello, three ways come to mind: 1. Placing your fixed widgets in one of the windows (also in GUIBuilder). When you go to the other page (if using MULTIPAGE widget) or just change a window then you can reattach these fixed widgets to the new selected…
  • HOSSEIN_TOMARI007 -

    Posted the thread Fixed widget for all windows.

    Thread
    In my project, inside the window there are fixed widgets that are inside all pages. For example, time and date, and I create the windows with a guibuilder. Do I need to add a widget for the date or time for each page? Is there a better solution? :?: :?:
  • env181025 -

    Posted the thread time related functions in debugio.h.

    Thread
    debug_time is very useful and it would be even more useful if you could please consider implementing the complementary functions debug_localtime_r and debug_strftime. Thanks.
  • rajdidaj -

    Replied to the thread Cannot select the correct Kinetis target in a JTAG chain.

    Post
    I was using j-link v6.46h for this. I'll try with v6.48b.
  • awneil -

    Posted the thread 'Always Rebuild' - not quite what I wanted..

    Thread
    It is a common requirement to have a build time & date included in the executable. An easy way to do this is to have a file with something like C Source Code (2 lines)But, for that to work, it has to be re-compiled every time the project is…
  • Damon Kelly -

    Replied to the thread Window/desktop layout.

    Post
    Both .emSession files have different time stamps (correct -- when each project was closed), but the layout still returns to the last closed.