Recent Activities

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • bio_med -

    Replied to the thread Reading from SD card.

    Post
    Florian, Thank you so much for the response. I will try these examples. Best regards, BMD
  • Is there a command I can send the J-Link GDB to cause it to issue the SWD command to the processor to exit the "debug mode"?
  • icwiener -

    Replied to the thread Cannot quit Ozone after J-Link lost connection to target.

    Post
    Hi, I am running Ozone V3.10 (which is the most recent one) on Windows 10 Pro and this happened to me with a custom board (stm32f412ce) as well as with the blue pill (stm32f103c8t6). Both boards have an exteral power supply and if that goes away, Ozone…
  • vikramtathe -

    Posted the thread GIF display issue on LCD.

    Thread
    Hello, I wanted to display the animated GIF on LCD. I have executed one program on simulator, it is showing animated GIF on the simulator as expected (PFA working_on_simulator.txt). The same program is executed on the imx1024 board, the loaded GIF…
  • SEGGER - Nino -

    Replied to the thread Cannot quit Ozone after J-Link lost connection to target.

    Post
    Hello, Thank you for your inquiry. Such an issue is not known to us. Could you provide more information about your setup? What version of Ozone are you using? Does it work when using the latest one? What host OS are you running Ozone on? Does the issue…
  • broca -

    Posted the thread How to set VAR_BREAK_AT_THIS_SYMBOL in the jdebug.

    Thread
    I have the same basic question as found in this thread: forum.segger.com/index.php/Thr…S-SYMBOL-value-by-script/ How should I set VAR_BREAK_AT_THIS_SYMBOL in the jdebug project file? When I have started up the debugging process, the following works in…
  • satheesh -

    Posted the thread No Cortex-M SW Device found.

    Thread
    Hi, I am working on ARM Cortex M4 development board provided by Vorago technologies. I am using keil IDE with "debug Jlink/J-trace Cortex". In the driver setup setting, there is no IDCODE getting detected and when I try to flash there is an error…
  • SEGGER - Nino -

    Replied to the thread Using Embedded studio with a dual core STM32H745?.

    Post
    Hello Jean-Louis, see here for debugging dual core: STM32H745 Dual Core Development/Debugging Regarding the linker you can specify separate memory maps and linker files for both projects. Just make sure they do not overlap. More information about the…
  • SEGGER - Nino -

    Replied to the thread STM32H745 Dual Core Development/Debugging.

    Post
    Hello, Thank you for your inquiry. A how to debug and setup multi core projects in Embedded Studio is explained here: wiki.segger.com/NXP_LPC43xx_se…4350_with_Embedded_Studio Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Processor frezzes after Enabled the Interrupt source.

    Post
    Hello, Thank you for your inquiry. Such an issue is not known to us. How did you move your application from Keil to ES? Did you use the imported or did you do the setup manually? Did you consider the following troubleshooting steps?
  • sylvioalves -

    Posted the thread Best approach for multiple MCU flashing.

    Thread
    Hi, I would like to flash post manufactured PCBs that are available on a panel. Each panel has 6 PCBs. I have been developing a software/IDE to handle JLInkEXE, flashing, verifying and printing PCB label. What would be the best approach for getting that…
  • SEGGER - Fabian -

    Replied to the thread S32K144 d-flash programming failure.

    Post
    Hi Victor, Glad to hear that you found the source for the issue. So if I understand you correctly, this is resolved now and we can consider this thread as closed? Best regards, Fabian
  • SEGGER - Fabian -

    Replied to the thread [SOLVED] STM32H750 - Writing DTCM.

    Post
    Hi Sébastien, No worries. :) We will consider this thread as closed now. Best regards, Fabian
  • bart -

    Replied to the thread GUI_BMP_Serialize() has Color Errors with emWin5.50.

    Post
    Thanks for the answer. In the meantime I went with directly reading the buffer of the LCD screen as a workaround.
  • SEGGER - Florian -

    Replied to the thread Reading from SD card.

    Post
    Hi, DWORD and HANDLE are types from the Win32-API, therefore these samples aren't to be used for any targets but rather on a Windows PC. I've attached a few samples that displays external images (BMP, GIF, JPEG, PNG and bitmap stream) from both the…
  • SeMoZi -

    Replied to the thread [SOLVED] STM32H750 - Writing DTCM.

    Post
    Hello, Indeed what you say make sense (and my question sounds a little bit silly afterwards :) ). Best regards, Sébastien
  • jlvern -

    Posted the thread Using Embedded studio with a dual core STM32H745?.

    Thread
    Hello, Is it possible to use Embedded Studio, and more specifically the Segger linker, to develop applications on STM32H7 dual-core processors? How do we inform the linker, when we compile for a core (in a project), of the space taken in the different…
  • Hello,I'm testing the Segger linker, and I have some troubles about initializing variables. The processor I use is an STM32H743, the linker is the Segger linker, the icf file is STM32H7xxFlash.icf provided by Segger (which defines the sections AXI_RAM1,…
  • ReMadza -

    Posted the thread how to connect ssd1963 to stm32f407.

    Thread
    hi. i want to run a 4.3 lcd (stemwin+stm32f407zix+ssd1963). but problem is here that i don't know how to wire between mcu an ssd1963... should i use fsmc? how to set other pins (except data/address)? or define own custom pins? if both ways are…
  • Andy_AN2 -

    Replied to the thread GUI_BMP_Serialize() has Color Errors with emWin5.50.

    Post
    Hello Bart, unfortunately I got no solution from Segger so far. So I still manually link to emwin 5.36 to detour the problem. Thus I can´t benfit from the new versions other features.... Best reagrds Andy