Recent Activities

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • SEGGER - Nino -

    Replied to the thread Using Embedded studio with a dual core STM32H745?.

    Post
    Hello Jean-Louis, see here for debugging dual core: STM32H745 Dual Core Development/Debugging Regarding the linker you can specify separate memory maps and linker files for both projects. Just make sure they do not overlap. More information about the…
  • SEGGER - Nino -

    Replied to the thread STM32H745 Dual Core Development/Debugging.

    Post
    Hello, Thank you for your inquiry. A how to debug and setup multi core projects in Embedded Studio is explained here: wiki.segger.com/NXP_LPC43xx_se…4350_with_Embedded_Studio Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Processor frezzes after Enabled the Interrupt source.

    Post
    Hello, Thank you for your inquiry. Such an issue is not known to us. How did you move your application from Keil to ES? Did you use the imported or did you do the setup manually? Did you consider the following troubleshooting steps?
  • SEGGER - Fabian -

    Replied to the thread S32K144 d-flash programming failure.

    Post
    Hi Victor, Glad to hear that you found the source for the issue. So if I understand you correctly, this is resolved now and we can consider this thread as closed? Best regards, Fabian
  • SEGGER - Fabian -

    Replied to the thread [SOLVED] STM32H750 - Writing DTCM.

    Post
    Hi Sébastien, No worries. :) We will consider this thread as closed now. Best regards, Fabian
  • bart -

    Replied to the thread GUI_BMP_Serialize() has Color Errors with emWin5.50.

    Post
    Thanks for the answer. In the meantime I went with directly reading the buffer of the LCD screen as a workaround.
  • SEGGER - Florian -

    Replied to the thread Reading from SD card.

    Post
    Hi, DWORD and HANDLE are types from the Win32-API, therefore these samples aren't to be used for any targets but rather on a Windows PC. I've attached a few samples that displays external images (BMP, GIF, JPEG, PNG and bitmap stream) from both the…
  • SeMoZi -

    Replied to the thread [SOLVED] STM32H750 - Writing DTCM.

    Post
    Hello, Indeed what you say make sense (and my question sounds a little bit silly afterwards :) ). Best regards, Sébastien
  • jlvern -

    Posted the thread Using Embedded studio with a dual core STM32H745?.

    Thread
    Hello, Is it possible to use Embedded Studio, and more specifically the Segger linker, to develop applications on STM32H7 dual-core processors? How do we inform the linker, when we compile for a core (in a project), of the space taken in the different…
  • Hello,I'm testing the Segger linker, and I have some troubles about initializing variables. The processor I use is an STM32H743, the linker is the Segger linker, the icf file is STM32H7xxFlash.icf provided by Segger (which defines the sections AXI_RAM1,…
  • ReMadza -

    Posted the thread how to connect ssd1963 to stm32f407.

    Thread
    hi. i want to run a 4.3 lcd (stemwin+stm32f407zix+ssd1963). but problem is here that i don't know how to wire between mcu an ssd1963... should i use fsmc? how to set other pins (except data/address)? or define own custom pins? if both ways are…
  • Andy_AN2 -

    Replied to the thread GUI_BMP_Serialize() has Color Errors with emWin5.50.

    Post
    Hello Bart, unfortunately I got no solution from Segger so far. So I still manually link to emwin 5.36 to detour the problem. Thus I can´t benfit from the new versions other features.... Best reagrds Andy
  • victorp -

    Replied to the thread S32K144 d-flash programming failure.

    Post
    Fabian, Thank you for the answer. I am downloading an S-rec file. The address information is correct. In case of success (no eeprom) the file is programmed into the correct addresses. The "@ 0x00000000" J-Link reports seems to be an offset in the…
  • icwiener -

    Replied to the thread J-Flash - Failed to erase chip.

    Post
    Hi, thanks for your answer. It is a custom board. I do not have an eval board at hand. I can test with one over the week end and will add the results here then. In J-Link Commander (connected via SWD), erasing finished successfully. Quote:…
  • CodeRunner -

    Posted the thread STM32H745 Dual Core Development/Debugging.

    Thread
    Does Segger have any examples or notes for the recommended way to develop/debug code for dual core processors in Embedded Studio? I am working with the STM32H745ZI processor and would like some guidance. I initially imported an ST STM32H745 Nulceo dual…
  • SEGGER - Fabian -

    Replied to the thread S32K144 d-flash programming failure.

    Post
    Hi Victor, Thank you for your inquiry. It looks like you are writing to 0x00000000, not to 0x10000000. Are you trying to download a .bin file? If so, you will have to add the starting address of where to download the file as well: Syntax: loadfile…
  • SEGGER - Fabian -

    Replied to the thread [SOLVED] STM32H750 - Writing DTCM.

    Post
    Hi, Thank you for your inquiry. I think there is a misunderstanding here. J-Flash is not able/supposed to program RAM. Also, what ever is written to the RAM, will be lost after reset anyway. It looks to me like you have a memory dump (.hex-file) and…
  • SEGGER - Fabian -

    Replied to the thread SAM-ICE works, but J-Link EDU does not.

    Post
    Hi, Thank you for your inquiry. Such an issue is not known to us. Could you please tell us which XPlained Pro board you are referring to? There are multiple boards with that name. Could you please send us a screenshot of the full J-Link Commander…
  • SEGGER - Fabian -

    Replied to the thread STM32G431CB / Flash issue.

    Post
    Hi Sébastien, Thank you for your inquiry. We are analyzing an issue regarding the STM32G431-series right now. What you are experiencing seems to be connected to this issue. We will come back to you as soon as we have news about this. Best…
  • SEGGER - Fabian -

    Replied to the thread Segger RTT no output when using Jlink-Remote Server.

    Post
    Hi, Thank you for your inquiry. Such an issue is not known to us. Could you please tell answer the following questions: 1) What device are you trying to get data from? 2) Do you get RTT output, when using a local setup (using RTT Viewer on the same PC…