Recent Activities

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • anthony.asterisk -

    Posted the thread Run static code analysis from batch command line.

    Thread
    Our software design process requires running static code analysis on all code before release. We would like to include this in our continuous integration which so far has been based on using emBuild to batch build. Is it possible to run static code…
  • AndrewJ -

    Replied to the thread Degree symbol in GUI Builder.

    Post
    Thanks both. Sven: I more-or-less tried this approach with the generated C file to set the Text widget, although I used octal rather than hex - I learnt something today from the use of hex in your code above! I did know how to do it in code - and when…
  • SEGGER - Schoenen -

    Replied to the thread language support.

    Post
    Hi, recently we have changed this. Now the Font Converter demo is the same as the full version except the fact that you are not allowed to create a product with the demo version. Just download the Font Converter again from our website. Regards, Sven
  • SEGGER - Schoenen -

    Replied to the thread Degree symbol in GUI Builder.

    Post
    Hi, the proper way is to use UTF8 encoding. As LexaGB already said the GUIBuilder supports only the ASCII range. You have to set other strings manually. After GUI_Init() call GUI_SetEncodeUTF8() to enable UTF8 encoding. C Source Code (2 lines) When…
  • Arjuman -

    Replied to the thread language support.

    Post
    Thanks for the reply. I am using the demo version of emWin font converter. I have tried to create a C file output for the font "Calibri" and used the generated output c file in one of the sample programs to change the font. While Generating the output…
  • LexaGb -

    Replied to the thread Degree symbol in GUI Builder.

    Post
    Hello, there is only support of the base ASCII set in text editable parameters of the widgets in GUIBuilder. The only thing you can do is generate the degree symbol as '°' in a text editor with extended symbols support (for example, in Word) and then…
  • AndrewJ -

    Posted the thread Degree symbol in GUI Builder.

    Thread
    I want a Text label that reads degreesC - symbol, not the word degree. The only way I've found to do it is to copy a degree symbol from Character Map and then size the Text widget accordingly, then overwrite the degree symbol with \260, leaving me with…
  • Sergey22 -

    Replied to the thread How to use external flash script from SES.

    Post
    Hello Nino, under that I see only additions to build process, or am I missing something? forum.segger.com/index.php/Att…60f2d5cf186f34d56c2b60752 but I need to have it separately as a push button.
  • arturo182 -

    Replied to the thread [SOLVED] NXP i.MX RT1011 support.

    Post
    Thank you for your reply :)
  • SEGGER - Nino -

    Replied to the thread How to use external flash script from SES.

    Post
    Hello, Thank you for your inquiry. In project options under User Build Steps you can find multiple hook points where you can execute external tools etc. that use command line options. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Pylink Square library Python 3.x.

    Post
    Hello, Thank you for your inquiry. Pylink is not supported or maintained by SEGGER so unfortunately we can't provide information on this matter. So we recommend contacting Pylink support in this regard. We will leave this open for a bit should someone…
  • SEGGER - Nino -

    Replied to the thread [SOLVED] NXP i.MX RT1011 support.

    Post
    Hello, Thank you for your inquiry. The iMXRT1011 will be supported with the next J-Link software update. You can subscribe to our notification list to stay up to date: segger.com/notification/subscribe.php?prodid=7 Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Problem while programming STM32F103RG.

    Post
    Hello, Thank you for your inquiry. The memory map in that J-Flash program is simply completely wring, this is why it does not work correctly. Attached you can find how it should look like. It seems that you are using a J-Link software that is quite old.…
  • SEGGER - Nino -

    Replied to the thread JTrace Cortex-M requirements.

    Post
    Hello, Correct as the J-Trace PRO has not application reference but only gets information from that target which instruction has been executed but not in what context. When you get your hands on a J-Trace PRO the following article will explain how you…
  • SEGGER - Schoenen -

    Replied to the thread language support.

    Post
    Hi, Yes, these languages are supported by emWin. emWin supports any language as long as the font you are using contains the proper characters to display the desired string. To generate an emWin font you need the Font Converter. A demo version can e…
  • SEGGER - Schoenen -

    Replied to the thread STemWin will not display large ellipses properly.

    Post
    Hi, We have experienced the same and added a function to draw large ellipses. This will be released with the next emWin version. Unfortunately, I can not say how long it will take till ST relases the new version. You can get access to the most recent…
  • Arjuman -

    Posted the thread language support.

    Thread
    Hello, We want to create an application using EmWin that supports multiple languages,which are 1.German 2.french 3.spanish 4.italian 5.portuguese 6.swedish 7.russian 8.czesh 9.polish 10.chinese 11.japanese 12.korean 13.turkish We wanted to know whether…
  • v01d -

    Replied to the thread r (reset) triggers flash write trace ....

    Post
    Quote from SEGGER - Fabian: “One reason could be, if you have any flash break points enabled. ” Just "enabled" (e.g. flash breakpoints = 1) or if set any? Does it mean that, on any reset, even if I don't change the program, it re-flashes? What…
  • mko -

    Posted the thread STemWin will not display large ellipses properly.

    Thread
    When drawing large ellipses, STemWin will not display them as an ellipse, but instead as this zigg-zagged-pattern, which you can see in the attached picture. Has anyone ever encountered a similar issue? Is there any kind of support for these kind of bug…
  • ecom -

    Replied to the thread J-Link on-board debugger does not work with SES.

    Post
    Hello Fabian, Thanks for your reply! I got the same error with your test code. BUT: When I reset the device (via reset button at eval board) while programming, it seems to work after a few tries... ?( The curious thing is, that this behavior appeared…