Recent Activities

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • SEGGER - Erik -

    Replied to the thread IMXRT1020 will not program on secondary pinmux.

    Post
    Thank you for the update. We will consider this case as closed for now. Best regards Erik
  • icwiener -

    Replied to the thread Ozone Data Sampling Number Formatting Inconsistent.

    Post
    Hi Nino, in my example it happens with uint16_t in C (stating ushort in the Type column in Ozone). I can also see it for int16_t (short). As shown on the screenshot, it does not happen with double. If I can observe something more, I will add it…
  • evorontsov -

    Replied to the thread Problem displaying 320*240 image from SD card.

    Post
    Which stm32 and how many RAM? Are you sure that size of buffer memory is enough for image?
  • Eli Hughes -

    Replied to the thread [SOLVED] Ozone - Support for relative paths.

    Post
    Ok, thanks for the response. My confusion was the result of how default ozone projects are setup (i.e. the path substitute) which lead me to believe paths could not be relative to the .jdebug file.
  • wzf -

    Now follows msantoli.

    Follow
  • abeck70 -

    Replied to the thread SystemView 3.10 (deb, x64) no connection.

    Post
    Hi Nino is there any update on this? I have the same issue on redhat. At least the application starts up now. But no luck connecting to previous or updated firmware. Thanks Alex.
  • Shino -

    Replied to the thread JlinkExe erase Command fails with RAM check.

    Post
    Quote from SEGGER - Fabian: “Do you experience the same problem on an evaluation board? ” I wired myself up to a STM32F4 discovery, which has almost the same Chip (STM32F407VGT6 instead of ...VET6) and the issue is still present. I have no…
  • SEGGER - Nino -

    Replied to the thread [SOLVED] How to use precompiled libraries.

    Post
    Hello Roger, Thank you for your inquiry. Great to hear that you are up and running again. We will mark this thread as solved now. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Ozone Data Sampling Number Formatting Inconsistent.

    Post
    Hello, Thank you for your inquiry. In the Average tab this was reproducible, but not in #Changes. Does this happen only for some data types or always? Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Ozone Data Sampling Change Counter becomes negative.

    Post
    Hi, Thank you for your inquiry. Good catch. Should be fixed with the next version. Sorry for any inconveniences caused. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Cannot quit Ozone after J-Link lost connection to target.

    Post
    Hello, Does your target application have any watchdogs, low power modes or similar running that might interfere with the debug interface? You seem to record quite a chunk of data samples, does the freeze happen around the same samples number each time…
  • SEGGER - Nino -

    Replied to the thread Import previously exported data graph in Ozone.

    Post
    Hi, Snapshot Files can be loaded without the other PC having a J-Link or the hardware. All you need is the .jdebug file, the elf file (if snapshot features are used where symbol information is needed) and the snapshot file obviously. So you open the…
  • bio_med -

    Posted the thread Problem displaying 320*240 image from SD card.

    Thread
    Hi, I am working on displaying images from external memory. I am having problems displaying the complete picture. I can display image up until 170*240, after which when I try to expand x value I see white background and nothing else on the LCD. Please…
  • grobot -

    Replied to the thread [SOLVED] How to use precompiled libraries.

    Post
    Hello Nico, Thank you for your answer, it helped me further. As you supposed I was using the wrong library. I've changed it to the bsec floating point library ...Cortex_M4F/libalgobsec.a and now it compiles without errors. Regards, Roger
  • dmarples -

    Replied to the thread IMXRT1020 will not program on secondary pinmux.

    Post
    With this new version, using GDB Server, after an initial 'load' of an elf, 'start' or 'run' for the first time will result in a target disconnect. Restarting GDB Server and gdb allows normal operation thereafter. I cannot recreate the previously…
  • SEGGER - Fabian -

    Replied to the thread J-Link stuck in bootloader mode, won't update.

    Post
    Hi Hugo, Thank you for your inquiry. From what we can see, the J-Link seems to be defective. Could you please provide us with the serial number of this J-Link? I am asking because the the S/N you have added to your forum profile is from a unit which is…
  • jev -

    Posted the thread Macro expansion in include paths.

    Thread
    For my projects, I often use the SDK from my silliconvendor. This SDK is unpacked in a directory, named after the version of the SDK. Thus, for example: "lib/nRF5_SDK_15.3.0_59ac345". I want to define an SDK_ROOT macro in my project and refer to files…
  • SEGGER - Arne -

    Replied to the thread I2C programming EEprom with Flasher ATE.

    Post
    Hello Bjarne, maybe you'd need to download the recent version. Just put "24C512" into the device search mask: ibb.co/Rzvkdpd Best regards Arne
  • Ronald -

    Replied to the thread I2C programming EEprom with Flasher ATE.

    Post
    Thanks Arne The device is not at the list in Universal Flashloader App. Do I then need to make a custom flashloader? Thanks in advance Bjarne
  • SEGGER - Oliver -

    Replied to the thread [SOLVED] Flasher STM8 - Programming Self-Powered Device.

    Post
    Answered via mail. Summary: Flasher stand-alone power supply in the project settings was enabled by the customer by accident. Additional information: Quote: “The project settings override the Flasher default state (that is what you set with power…