Recent Activities

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Torsten Robitzki -

    Replied to the thread unreliable flash upload with J-Trace and SAM4S.

    Post
    Hi Fabian, the J-Trace Pro is less than half a year old. If it helps to speed up this use, I will also open a ticket within your support system. The original message, that flashing with the J-Commander works flawless, was not quite correct. I can see…
  • stephrdev -

    Posted the thread Problems using JLink EDU with GD32VF103CBT6 based controller.

    Thread
    Hi! I tried to use the JLink EDU (V10.10) with the recently released Sipeed Longan Nano - RISC-V GD32VF103CBT6 Development Board. Not sure if this is a shortcoming of the EDU version (I hope not :( ) Or maybe just a software or configuration issue? Some…
  • minchingho -

    Replied to the thread Can watchdog be paused when MMD is used for debugging?.

    Post
    Hi Fabian, When will JLINK_MONITOR_OnPoll be called? If I stopped at a breakpoint for very long time, will the watchdog still be fed from this function? The CPU I used can not pause the watchdog, but keep feeding it. I have seen several reset even when…
  • Pieter Eggermont -

    Replied to the thread PROGBAR doesn't change colors.

    Post
    Quote from SEGGER - Schoenen: “Another way to change the look of the widgets is to overwrite their callback function or set a skinning/owner-draw function (if available). ” I have trobubles setting those settings. I do not manage to edit a progress…
  • phryniszak -

    Posted the thread stm32g431 J-Link error "Failed to measure CPU clock frequency".

    Thread
    Hi All, I try to start work with relatively new chip STM32G431, but Ozon stopped working with "Jlink reports unspecified download error" I tried to use jlink command line and erase chip but it also fails. In log I can see "Failed to measure CPU clock…
  • SEGGER - Fabian -

    Replied to the thread unreliable flash upload with J-Trace and SAM4S.

    Post
    Hello, Keep in mind, that this is not a support forum, so answers might be delayed. If you are still in the support period, you can also open a ticked in our support system. Please refer to my signature for more information. We are working on the…
  • SEGGER - Fabian -

    Replied to the thread Missing "Connect to running target" option?.

    Post
    Hello Dave, Sorry for the delay in response. Please find the Wiki article here: wiki.segger.com/STM32CubeIDE Best regards, Fabian
  • xhale -

    Posted the thread ST-Link reflash issues.

    Thread
    Hi, I recently attempted to convert the ST-Link from a STM32F411RE Nucleo board to a J-Link using the latest STLinkReflash utility. It appears to be functional as a J-Link however I have noticed some errors or odd behaviour: 1. The Nickname (and…
  • afedotov77 -

    Replied to the thread Failed to measure CPU clock frequency.

    Post
    Fabian, answers is below 1) Does this replacing firmware error also appear when you are using J-Link Commander (jlink.exe)? Message about replacing firmware does not always appears and Yes, this message also appear when I using J-Link Commander. 2)
  • SEGGER - Fabian -

    Replied to the thread Failed to measure CPU clock frequency.

    Post
    Hi Andy, Could you please answer the following questions?: 1) Does this replacing firmware error also appear when you are using J-Link Commander (jlink.exe)? 2) Could you send us a picture of the whole Commander output? 3) Is the J-Link connected to the…
  • cowens -

    Replied to the thread Pass ID CODE verification via command line.

    Post
    Quote from SEGGER - Fabian: “Hi, Thank you for your Inquiry. Unfortunately, there is currently no such command-line option. We will put it on our requested features list, but cannot say when it will be implemented. If you require this feature short…
  • I think this arch drawing helps explain why SWD /2-wire seems to work but not JTAG 4-wire .. I've seen at least few posts on Segger forum about problems with this IcePick. May be this was resolved somewhere already?
  • SEGGER - Fabian -

    Replied to the thread Can watchdog be paused when MMD is used for debugging?.

    Post
    Hello Min-Ching, Thank you for you r inquiry. The watchdog is not paused by our software. You have to implement the feeding/pausing of the watchdog yourself as part of the poll function. You can find further information about this topic in the J-Link…
  • afedotov77 -

    Replied to the thread Failed to measure CPU clock frequency.

    Post
    Fabian, I don't see any difference environment (debugger, scheme, chips and software SEGGER for debugger) between last successful experience and bad experience (when appeared problem). I updated J-Link software up to latest version, but it had fixed…
  • Hi Arjuman, the manual explains how to use GetData() functions and provides examples under "9.5 Getting data with the ...Ex() functions". Best regards, Florian
  • SEGGER - Fabian -

    Replied to the thread Failed to measure CPU clock frequency.

    Post
    Hello Andy, Could you tell me what is different to the last time it worked with these chips? Did you update the J-Link Software and Documentation Pack? Best regards, Fabian
  • SEGGER - Fabian -

    Replied to the thread Pass ID CODE verification via command line.

    Post
    Hi, Thank you for your Inquiry. Unfortunately, there is currently no such command-line option. We will put it on our requested features list, but cannot say when it will be implemented. If you require this feature short term, you can also buy and use…
  • SEGGER - Nino -

    Replied to the thread JLinkScript return value of customized action function.

    Post
    Hi Joe, quick update. The latest J-Link software version should have not fixed return values for SetupTarget. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Hilscher netx90 APP core dubugging.

    Post
    Hello, Thank you for your inquiry. The App Core is currently not supported as it is not directly accessible via the debug port. Only Com core is supported. Best regards, Nino
  • afedotov77 -

    Replied to the thread Failed to measure CPU clock frequency.

    Post
    Hello Fabian, When problem appeared first time I didn't updated Ozone. I updated Ozone later, I hoped to fix problem. But I could not fix problem. I checked voltage between VCC and GND on JTAG in during download .hex file - voltage was stable and equal…