Recent Activities

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • SEGGER - Fabian -

    Replied to the thread What makes something J-Link compatible?.

    Post
    Hi, Thank you for your inquiry. If you are unsure whether a specific device is supported or not, please refer to this list here: segger.com/downloads/supported-devices.php It contains all devices supported by J-Link. Best regards, Fabian
  • SEGGER - Fabian -

    Replied to the thread Jlink read out register of CC1352R1F3.

    Post
    Hi, Thank you for your inquiry. There should be no issues with reading the registers with J-Link + J-Link Commander. The base address should be mentioned somewhere in the PDF you are using (memory map, register category). If you cannot find it, please…
  • SEGGER - Fabian -

    Replied to the thread J-Flash - Failed to erase chip.

    Post
    Hi, Do you have any peripheral flash connected to the chip at address 0x90000000? Could you please check, that there are no flash banks enabled in the J-Flash project, that are not accessible? You can do so here:
  • SEGGER - Fabian -

    Replied to the thread JLink: Error connecting to device over SWD.

    Post
    Hi, Do you have the possibility to test the J-Link EDU Mini on another board or another J-Link you can connect to the board with? Unfortunately, there is not much more we can do for you, as long as we are not able to reproduce this with. Best…
  • Hi, Did you set the RTT Viewer to use "existing session" + "auto reconnect"? If not, does it work when using RTT Viewer with these options enabled? Could you please provide us with a screenshot of the RTT Viewer's "Configuration" dialog? Best…
  • Timonsku -

    Posted the thread Unable to connect to target in Ozone [Linux].

    Thread
    I'm unable to start a debugging session with Ozone. Whenever I want to attach (no matter which way, downloading first or not). I get the following error; Quote from Ozone: “Debug.SetConnectMode (CM_ATTACH); Debug.Start(); Device "ATSAMD21G18"…
  • SEGGER - Fabian -

    Replied to the thread STM32H743 DBGMCU register reads as zero when using ETF-Trace.

    Post
    Hi Thomas, Sorry for the delay in response. We have pretty busy days right now (preparations Embedded World, etc.). We looked at this again. The issue is in the HAL.c and not in the way how the memory accesses are executed. To access the DBGMCU registers…
  • SEGGER - Fabian -

    Replied to the thread Position independent code for flashloader.

    Post
    Hi Radhika, Thank you for your inquiry. When using Open Flashloader, you do not need to have position independent code. The flash loader is downloaded into the RAM area specified in the application. The Open Flashloader is designed to be used with the…
  • SEGGER - Fabian -

    Replied to the thread Multiple <FlashBankInfo> elements in the same <Device> possible?.

    Post
    Hi Radhika, Thank you for your inquiry. Reg 1.: As I can see in the image you attached, you are doing this already ("[..] Loader = [..]"). You actually have to provide a flashloader for each memory area. For more info, please refer to this page:
  • thomask77 -

    Replied to the thread STM32H743 DBGMCU register reads as zero when using ETF-Trace.

    Post
    Do you have any update on this topic?
  • thomask77 -

    Posted the thread Ozone shows global symbols with same name only once.

    Thread
    Ozone 3.10d In C, it's possible to have two distinct global static variables or functions with the same name in different source files. For example: a.c static int foo; static void bar(void) { } b.c static int foo; static void bar(void) { } In…
  • awneil -

    Replied to the thread What makes something J-Link compatible?.

    Post
    Look on the list of Supported CPUs: segger.com/products/debug-prob…pported-cpus-and-devices/ For ARM, there is a common standard debug interface (SWD or JTAG) on all their Cores - so a J-Link should work with anything ARM-based.
  • SEGGER - Florian -

    Replied to the thread ICONVIEW and External memory nOS.

    Post
    Hi, I can't tell what is wrong with your code, my guess is the file handles point all to the same image, thus all icons are the same. Best regards, Florian
  • SEGGER - Florian -

    Replied to the thread Swipelist transparency.

    Post
    Hi, this can be done for all widgets, just make sure to set the WM_CF_HASTRANS create flag via WM_SetHasTrans() or upon creation and set a transparent background color. Best regards, Florian
  • SEGGER - Erik -

    Replied to the thread IMXRT1020 will not program on secondary pinmux.

    Post
    Hello, We were able to reproduce not the same issue but a similar one. This one will be fixed in the next official version (V6.62b), scheduled to be available later today. Could you please give this version a quick try and provide feedback? BTW: I…
  • I tried those steps. See attached screenshots. Using JLink.exe, I can connect through the tunnel. Using SES 4.42 I can not connect through the tunnel. I tried both IP tunnel:SN and IP SN. forum.segger.com/index.php/Att…ddefe894f427ba5fb017e57db
  • Matt S -

    Posted the thread Swipelist transparency.

    Thread
    Can the SWIPELIST widget support a transparent background? I have tried: (1) SWIPELIST_SetBkColor(hItem, SWIPELIST_CI_BK_ITEM_UNSEL, GUI_MAKE_COLOR(GUI_TRANSPARENT)); (2) WM_SetHasTrans(hItem); (3) a custom owner draw function emWin 5.38
  • SEGGER - Nino -

    Replied to the thread Import previously exported data graph in Ozone.

    Post
    Hello, The snapshot should be able to restore any amount of data samples. Could you give it a try? Is something not working when using the snapshot approach? Best regards, Nino
  • westloser86 -

    Replied to the thread embOS with SiLabs BLE library.

    Post
    Hello Til I'm not 100% sure, but my guess goes to the same direction that all used interrupts are initialized inside the BLE library from SiLabs. I will contact SiLabs directly in order to get some information what interrupts they are using and if any…
  • SEGGER - Til -

    Replied to the thread embOS with SiLabs BLE library.

    Post
    I guess the interrupt is initialized in the BLE library and you don't have the source code, correct? Anyway you can change the interrupt priority at any time later before your application starts. You just need to know which interrupt is used (I think…