Recent Activities

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Ross Lee -

    Posted the thread Can GUI_CreateDialogBox() generate WM_CREATE message?.

    Thread
    When I use GUI_CreateDialogBox() to create a dialog including a window, I find that the code in WM_CREATE branch of callback function is not excuted. Then I set breakpoint in WM_CREATE branch and find it never arrived. However, if I just use…
  • Bit -

    Posted the thread TTF FONT issue?.

    Thread
    Hi, Use GUI_TTF_CreateFontAA to create 6 different font sizes. The initial display of the window is normal. After the WM_PAINT, the display is abnormal. Is this a bug? Please clarify. Thanks a lots
  • geom12 -

    Posted the thread Solution build not triggering project build.

    Thread
    When building from the solution level, per-project pre-build steps are not triggered. Attached is a sample project file. Not that the linker is unhappy but that should not matter (and is a completely different SES bug) What should happen on solution…
  • 40490FDB -

    Replied to the thread SAMA5 ETB trace.

    Post
    Trying to run the example in Embedded Studio (release 4.18) results in an error message: Failed to download application. Generic error. Please check J-Link and target connection. Ozone is V2.62f. When I select "Start Debugging" "Download and Reset…
  • I am getting this error message, only after using breakpoints. I have swapped debuggers but no joy. This just started out of the blue. Any help will be appreciated. SEGGER J-Link GDB Server V6.34c - Terminal output channel Connection closed by the GDB…
  • Hello all, I am not able to erase the STM32H743 anymore using the Segger J-Trace Pro (SW interface) within Keil MDK v5.25, while the ST-Link V2 works - with otherwise identical configuration. Erasing/flashing the STM32F767 on the same board (only µC…
  • Kusum Swarankar -

    Replied to the thread WM_SetDesktopColor behaviour.

    Post
    Hi Sven, I tried callling WM_SetDesktopColor only once after GUI_Init. but what i see is it is not working for other window if i am not calling it again after deleting one window and creating other. I am also using super loop for updating the screens but…
  • SEGGER - Nino -

    Replied to the thread SAMA5 ETB trace.

    Post
    Hello, I moved the inquiry to a new thread as this question is not related to the other. Both J-Links support ETB trace on the SAMA5 target device. Do you get any error message? Which version of Ozone are you using? Do you get any error messages? Best…
  • SEGGER - Schoenen -

    Replied to the thread How to trim leading zeros in spinbox?.

    Post
    Hi, Try the code below. First get the EDIT handle from the SPINBOX and then modify the EDIT widget. Although it is not documented, you can pass the flag GUI_EDIT_SUPRESS_LEADING_ZEROES to the function EDIT_SetDecMode(). I will update the manual. C…
  • Ross Lee -

    Posted the thread How to trim leading zeros in spinbox?.

    Thread
    Is there any way to remove the leading zero in spinbox? For example, if I set the Min and Max of a spinbox as 10 and 100, then when I input the value '24' , the spinbox displays '024'. How can I remove the leading zero? Thank you.
  • 40490FDB -

    Replied to the thread SAMA5 ETB trace.

    Post
    I've tried the ATSAMA5D2 trace example from the tested devices link shown above, without success. I have a J-Link Base as well as a J-Link Ultra+. The documentation specifies J-Link Pro so perhaps someone can confirm that neither of my units will…
  • rise.cai -

    Replied to the thread How can I code for SystemView?.

    Post
    Ok~ Thanks for these answer. :) I have the other question: I coding base on FreeRTOS. My board is ZYNQ7020 which same nice in my mind. :D How can I dynamic link to systemview.so? ?( Best regards~ Rose Rise :)
  • rise.cai -

    Replied to the thread SystemView's bugs.

    Post
    Quote from SEGGER - Nino: “Hello, Thank you for your inquiry. 1: Will be fixed in a future SystemView source release. 2: Is not reproducible with the currently available SystemView sources: https://www.segger.com/downloads/jlink/systemview_target_src
  • SEGGER - Nino -

    Replied to the thread Keil Cortex-M7 ETM Trace support.

    Post
    Hello, Quote from DawidS: “I know Ozone - the last version I used didn't had the ability to search in ETM Trace log which made Ozone almost useless for us ” Could you elaborate how you can do this in Keil? I just tested the latest uVision version…
  • SEGGER - Nino -

    Replied to the thread SystemView's bugs.

    Post
    Hello, Thank you for your inquiry. 1: Will be fixed in a future SystemView source release. 2: Is not reproducible with the currently available SystemView sources: segger.com/downloads/jlink/systemview_target_src Which version are you using? Quote from…
  • SEGGER - Nino -

    Replied to the thread Ozone on debian buster segfault.

    Post
    Hello, Attached you can find an example SWO project that contains an Ozone project which will output the SWO stream in Ozone terminal. Could you give that a try? I tested it with our STM32F103 Nucleo Board that we have in house and everything is working…
  • CheMax -

    Replied to the thread Data Breakpoint expressions.

    Post
    Good day, Thanks, I did not immediately see your answer, I apologize. the following construction works: (uint32_t *) 0x20008948> 0x3c, where 0x20008948 - address of interesting variable. Best regards, Maxim
  • DawidS -

    Replied to the thread Keil Cortex-M7 ETM Trace support.

    Post
    Thanks you for your answer. For the best trace experience including Cortex-M7 tracing we recommend using our stand alone debug software Ozone: - I know Ozone - the last version I used didn't had the ability to search in ETM Trace log which made Ozone…
  • mringwal -

    Replied to the thread RTT with dual-core STM32WB55 stops.

    Post
    Hi Nino. Thanks for the reply - I'm sorry I didn't have notifications configured and didn't see your reply in time (but fixed that just now!) I have a straight-forward/naive setup: start ozone, use project wizard to pick the stm32wb55xx (only two…
  • SEGGER - Nino -

    Replied to the thread How can I code for SystemView?.

    Post
    Hello, Thank you for your inquiry. Happy to see your interest in SystemView. Currently we do not offer a public repository for collaboration and there are no plans to add such an interface. So the correct approach for now would be to either post us your…